
The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

 

 

TTTHHHEEE   MMMTTTWWWSSS   DDDooocccuuummmeeennntttaaatttiiiooonnn   
SSSuuuiiittteee   

VVVooollluuummmeee   IIIVVV:::         
MMMTTTWWWSSS   SSSyyysssttteeemmm   
AAAdddmmmiiinnniiissstttrrraaatttiiiooonnn  

Version 3.0 
February 2003  

   



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

 

 

Table of Contents 

 

CHAPTER 1 - INTRODUCTION ............................................................................................................................................1 

CHAPTER 2 - SYSTEM CONFIGURATION......................................................................................................................1 
SECTION 1 - OVERVIEW ............................................................................................................................................................. 1 
SECTION 2 - SYSTEM HARDWARE CONFIGURATION.............................................................................................................. 1 

MAN, MSC, and CART Server Hosts.................................................................................................................................1 
Maui and CART Client Hosts..............................................................................................................................................2 
Network Configuration – MAN/Maui LANs.....................................................................................................................3 
Network Configuration – MTWS Hosts.............................................................................................................................3 

SECTION 3 - SYSTEM SOFTWARE CONFIGURATION ............................................................................................................... 4 
MAN, MSC, and CART Server Hosts.................................................................................................................................4 
Operating System Installation - Dell PowerEdge 4600.................................................................................................4 
Operating System Installation - Other Manufacturer (Non-Dell PE 4600)..............................................................12 
Additional Operating System Configuration – MAN/MSC/CART Server .................................................................19 
/etc/hosts or the Name Service Database........................................................................................................................19 
/etc/services..........................................................................................................................................................................21 
/etc/ sysconfig/network .......................................................................................................................................................21 
/etc/ftpaccess........................................................................................................................................................................22 
/etc/ ftphosts .........................................................................................................................................................................22 
/etc/ ftpusers.........................................................................................................................................................................23 
/.rhosts...................................................................................................................................................................................24 
/etc/fstab................................................................................................................................................................................24 
/etc/group..............................................................................................................................................................................24 
/etc/passwd...........................................................................................................................................................................24 
/etc/shells ..............................................................................................................................................................................25 
Creating and Configuring MTWS File Systems .............................................................................................................25 
Exporting MSC File Systems.............................................................................................................................................25 
Synchronizing Time.............................................................................................................................................................26 
Third-Party Support Software...........................................................................................................................................27 
Perl ........................................................................................................................................................................................27 
Maui Hosts ...........................................................................................................................................................................28 
Operating System Installation – Maui Hosts..................................................................................................................28 
Additional Operating System Configuration – Maui Hosts.........................................................................................29 
Maui User Account .............................................................................................................................................................29 
Shared Network Data.........................................................................................................................................................29 
Local Data............................................................................................................................................................................30 

CHAPTER 3 - MTWS INSTALLATION.............................................................................................................................30 
SECTION 1 - MAN/MSC HOSTS............................................................................................................................................. 30 

Backup DLT Tape Drive ....................................................................................................................................................30 
SECTION 2 - CART SERVER HOST ......................................................................................................................................... 33 

Environment Variables in MTWS .....................................................................................................................................34 
SECTION 3 - MAUI HOSTS........................................................................................................................................................ 35 

Saving Old Data..................................................................................................................................................................36 
Installing from an installation CD...................................................................................................................................37 
Installing from a networked drive....................................................................................................................................37 
Installing from your local drive........................................................................................................................................37 
Launching the Installation program................................................................................................................................38 

SECTION 4 - PARAMETRIC DATA............................................................................................................................................ 47 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

 

TIFF Map Files (*.tif) ........................................................................................................................................................49 
Terrain Data Files (*.trr) ..................................................................................................................................................49 

CHAPTER 4 - OPERATING PROCEDURES ...................................................................................................................50 
LOGIN SEQUENCE...................................................................................................................................................................... 50 
SPECIFYING MAPPING DATUMS.............................................................................................................................................. 50 
STARTING MSC SOFTWARE .................................................................................................................................................... 51 
CREATING AN EXERCISE .......................................................................................................................................................... 52 
STARTING OR RESTARTING AN EXERCISE ............................................................................................................................. 52 
ENABLING THE MDS INTERFACE ........................................................................................................................................... 54 
STARTING THE CART SERVER ............................................................................................................................................... 55 
STARTING MAUI DISPLAY STATION SOFTWARE .................................................................................................................. 55 
STARTING AN EXERCISE - NEW............................................................................................................................................... 56 
RESTARTING AN EXERCISE - START ....................................................................................................................................... 56 
RESTARTING AN EXERCISE - TIME ......................................................................................................................................... 57 
RESTARTING AN EXERCISE - END ........................................................................................................................................... 57 
SAVING AN EXERCISE ............................................................................................................................................................... 58 
EXERCISE STATES AND MODES............................................................................................................................................... 59 
SUSPENDING AN EXERCISE ...................................................................................................................................................... 59 
RESUMING AN EXERCISE.......................................................................................................................................................... 59 
MANIPULATING THE EXERCISE CLOCK.................................................................................................................................. 60 
CLOCK ADVANCE...................................................................................................................................................................... 60 
CLOCK RATE.............................................................................................................................................................................. 60 
HELPFUL HINTS......................................................................................................................................................................... 61 
CONTROLLING ENGAGEMENTS............................................................................................................................................... 61 
SUSPENDING ENGAGEMENTS................................................................................................................................................... 61 
RESUMING ENGAGEMENTS...................................................................................................................................................... 62 
CONTROLLING INTERFACES..................................................................................................................................................... 62 
MDS INTERFACE....................................................................................................................................................................... 62 
DISABLE MDS INTERFACE ...................................................................................................................................................... 62 
ENABLE MDS INTERFACE ....................................................................................................................................................... 63 
MAN INTERFACE...................................................................................................................................................................... 63 
HIGH-SPEED PRINTER INTERFACE.......................................................................................................................................... 63 
ENABLE HSP INTERFACE......................................................................................................................................................... 63 
DISABLE HSP INTERFACE........................................................................................................................................................ 63 
CLEAR HSP PRINT QUEUE....................................................................................................................................................... 64 
MANIPULATING TERRAIN ........................................................................................................................................................ 64 
DIGITIZED TERRAIN DATA....................................................................................................................................................... 64 
LOADING TERRAIN.................................................................................................................................................................... 65 
REMOVING TERRAIN................................................................................................................................................................. 66 
LOADING/REMOVING TABLETOP TERRAIN........................................................................................................................... 66 
MONITORING AN EXERCISE ..................................................................................................................................................... 67 
APPLICATION ASSIGNMENT ..................................................................................................................................................... 67 
MAN/MDS HOSTS ON-LINE .................................................................................................................................................. 68 
TERRAIN STATUS....................................................................................................................................................................... 68 
CONTROLLER ASSIGNMENT..................................................................................................................................................... 68 
EXERCISE DEFINITION SUMMARIES........................................................................................................................................ 68 
SUMMARY REPORT OF EXERCISE DEFINITION PARAMETERS............................................................................................. 68 
SUMMARY REPORT OF TERRAIN PARAMETERS FOR DEFINED EXERCISES....................................................................... 69 
OPERATING WITH THE JOINT TRAINING CONFEDERATION................................................................................................. 69 
CONFIGURING MTWS/ALSP MAPPING TABLES................................................................................................................. 69 
DECODING MTWS TEMPLATE_NAME SENT OVER ALSP........................................................................................... 75 
STARTING MTWS AND ALSP TRANSLATOR SOFTWARE................................................................................................... 78 
INITIATE EXECUTION OF MSC SOFTWARE............................................................................................................................ 78 

Initiate Execution of ALSP Translator............................................................................................................................80 
SUSPEND AND RESUME MTWS/ALSP .................................................................................................................................. 82 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

 

RESIGN AND REJOIN AN ALSP CONFEDERATION ................................................................................................................ 83 
INITIATE EXECUTION OF A RESIGN FROM ALSP CONFEDERATION................................................................................... 83 
INITIATE EXECUTION OF A REJOIN TO ALSP CONFEDERATION ........................................................................................ 84 
TERMINATING AN EXERCISE.................................................................................................................................................... 85 
JQUAD INTERFACE.................................................................................................................................................................. 86 
SECURITY ADMINISTRATOR CONFIGURATION...................................................................................................................... 86 

CHAPTER 5 - CART OPERATING PROCEDURES. ....................................................................................................94 
STARTING THE CART SOFTWARE .......................................................................................................................................... 94 
USING CART REPORTS ON THE CART SERVER. ................................................................................................................. 94 
MONITORING AND MANAGING THE CART EXERCISES. ..................................................................................................... 94 

Exercise Status.....................................................................................................................................................................94 
SERVER STATUS ........................................................................................................................................................................ 95 
EXERCISE DATA........................................................................................................................................................................ 95 
EXERCISE MANAGER................................................................................................................................................................ 96 
CONTROLLING ACCESS TO CART REPORTS......................................................................................................................... 97 

Permitting machines to access the CART Reports. .......................................................................................................97 
Removing report access from a workstation..................................................................................................................98 
Miscellaneous Security features. ......................................................................................................................................98 

CHAPTER 6 - DIAGNOSING SYSTEM PROBLEMS ...................................................................................................99 
SECTION 1 - ALERTS................................................................................................................................................................. 99 

Alert Log Files.....................................................................................................................................................................99 
Viewing the Alert Log.........................................................................................................................................................99 
Printing the Alert Log.........................................................................................................................................................99 
Notes on Alerts.....................................................................................................................................................................99 
Maui and CART Client Alerts ........................................................................................................................................ 100 
CART Diagnostic Files ................................................................................................................................................... 100 
CART Alerts ...................................................................................................................................................................... 101 

SECTION 2 - MTWS DIAGNOSTIC UTILITIES...................................................................................................................... 101 
Message Queue Monitor................................................................................................................................................. 101 
Disk Utilization Monitor................................................................................................................................................. 101 
Connection Monitoring................................................................................................................................................... 102 
Metrics Screens................................................................................................................................................................ 102 

SECTION 3 - MAN SOFTWARE .............................................................................................................................................. 103 
General .............................................................................................................................................................................. 103 
MAN Cyclical Applications............................................................................................................................................ 103 
MAN Intelligence (IN) Application............................................................................................................................... 103 
MAN Process Becomes Inoperative.............................................................................................................................. 104 
MAN Message Queues .................................................................................................................................................... 104 

SECTION 4 - MSC SOFTWARE............................................................................................................................................... 105 
General .............................................................................................................................................................................. 105 
MSC Host Configured to Receive Spot Reports.......................................................................................................... 105 
Processes Running on MSC Hosts................................................................................................................................ 105 
MSC Message Queues..................................................................................................................................................... 105 

SECTION 5 - MAUI SOFTWARE .............................................................................................................................................. 106 
Processes running on Maui Hosts................................................................................................................................. 106 
Maui Troubleshooting..................................................................................................................................................... 107 

SECTION 6 - CART TROUBLESHOOTING............................................................................................................................. 109 
Normal operating state. .................................................................................................................................................. 109 
Message Queues:.............................................................................................................................................................. 110 
Memory Usage:................................................................................................................................................................ 110 
Problems during Startup................................................................................................................................................. 110 

CHAPTER 7 - O/S UTILITIES ............................................................................................................................................ 112 
CPU UTILIZATION .................................................................................................................................................................. 112 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

 

APPENDIX A: MTWS TERRAIN GENERATION PROCEDURES ............................................................................1 
SECTION 1 - OVERVIEW ............................................................................................................................................................. 1 
SECTION 2 - TERRGEN TERRAIN CREATION........................................................................................................................ 1 

TerrGen Overview.................................................................................................................................................................1 
TerrGen Setup........................................................................................................................................................................2 
Running TerrGen...................................................................................................................................................................3 
Creating the CFE features File ..........................................................................................................................................4 
Creating the .Trr Terrain File.............................................................................................................................................5 

SECTION 3 - SELECT TERRAIN FILE.................................................................................................................................. 6 
Installing TerrGen TRR files in the MTWS Terrain ‘Database’...................................................................................6 
Running Terrain Compression............................................................................................................................................6 

SECTION 4 - TERRGEN TERRAIN EDITOR............................................................................................................................. 7 
EDIT TERRAIN FILE...........................................................................................................................................................8 
Select Terrain File ................................................................................................................................................................8 
Select Image...........................................................................................................................................................................8 
Line Definition.......................................................................................................................................................................8 
Enter Width ............................................................................................................................................................................8 
Shape Definition....................................................................................................................................................................9 
Modify Terrain Data.............................................................................................................................................................9 
Update Database.................................................................................................................................................................10 
Manipulating Terrain.........................................................................................................................................................11 
Loading Terrain ..................................................................................................................................................................11 
Removing Terrain................................................................................................................................................................11 
Loading/Removing Tabletop Terrain...............................................................................................................................12 

SECTION 5 - TRANSFERRING MTWS TERRAIN DATA BASE TO MTWS NETWORK....................................................... 13 
Moving files to MTWS terrain data base........................................................................................................................14 
Running Terrain Compression..........................................................................................................................................15 

SECTION 6 - EDITING MTWS TERRAIN DATABASE ............................................................................................................ 15 
SECTION 7 - MTWS TERRAIN DATABASE GENERATION.................................................................................................... 17 

APPENDIX B – C4I INTERFACE NOTES ...........................................................................................................................1 
SECTION 1 - INTRODUCTION...................................................................................................................................................... 1 
SECTION 2 - SYSTEM CONSIDERATIONS.................................................................................................................................. 1 

APPENDIX C – MAUI SECURITY PROCEDURES .........................................................................................................1 
SECTION 1 - OVERVIEW ............................................................................................................................................................. 1 

General Notes........................................................................................................................................................................1 
SECTION 2 - SECURITY PROCEDURES AND REQUIREMENTS................................................................................................. 1 

Passwords...............................................................................................................................................................................1 
Password Aging.....................................................................................................................................................................2 
Account Lockout....................................................................................................................................................................2 
Unique Password Count......................................................................................................................................................3 
Active Administrator Account.............................................................................................................................................3 
Adding Or Modifying Programs.........................................................................................................................................3 
Cached Data Objects............................................................................................................................................................4 
Preventing Malicious Commands......................................................................................................................................5 
Adding Print Drivers ............................................................................................................................................................5 
Anonymous FTP ....................................................................................................................................................................6 
Prevent Hacking Through FTP...........................................................................................................................................7 
Displayed SMTP Version.....................................................................................................................................................7 
Preventing NULL or Anonymous Login............................................................................................................................7 
Restricting Access To Event Logs......................................................................................................................................7 
Scheduling Priority Privilege..............................................................................................................................................8 
Closing Open Echo Port ......................................................................................................................................................9 
Closing Open Chargen Port................................................................................................................................................9 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

 

Auditing Successful Logons.................................................................................................................................................9 
Auditing Successful Shutdowns.........................................................................................................................................10 
Auditing Successful Security Policy Changes................................................................................................................10 
Auditing Successful User/Group Changes......................................................................................................................10 
Auditing Unsuccessful User/Group Changes.................................................................................................................10 
Auditing Unsuccessful File/Object Accesses..................................................................................................................11 
Auditing Unsuccessful Logons..........................................................................................................................................11 
Auditing Unsuccessful Process Tracking........................................................................................................................11 
Auditing Unsuccessful Restarts ........................................................................................................................................11 
Auditing Unsuccessful Security Changes........................................................................................................................12 
Auditing Unsuccessful Users Rights Usage....................................................................................................................12 
Auditing Unsuccessful User and Group Management..................................................................................................12 

 

 

 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

1 

Chapter 1 - INTRODUCTION 

This manual applies to version 3.0 of the Marine Air Ground Task Force (MAGTF) 
Tactical Warfare Simulation (MTWS) system.  This manual provides information and 
procedures for configuring the system hardware and software environment; and for 
installing and operating the MTWS application within that environment.  

This manual assumes basic familiarity with the MTWS system. Volume I of the MTWS 
documentation suite identifies related documents; and provides an overview of the MTWS 
system. This manual also assumes proficiency in the Linux, Windows NT, and Windows 
2000 operating systems; and proficiency with the relevant hardware. 

 

Chapter 2 - SYSTEM CONFIGURATION 

Section 1 - Overview 

The MTWS system consists of the following hardware components. 

a. Model Application Network (MAN) server.  

b. Model System Control (MSC) server.  

c. Model Display Station (MDS) workstation. The MDS workstation and its software is 
also known as Maui. The terms “MDS” and “Maui” are used interchangeably 
throughout this manual. 

d. Combat Analysis and Review Toolkit (CART) server.  

e. Combat Analysis and Review Toolkit (CART) clients. 

 

Each of these components requires an underlying x86 (also known as IA-32) processor. 
MAN, MSC, and CART components require the Red Hat Linux version 7.2 operating 
system. MDS components require the Windows 2000 or Windows NT operating system. 

 

Section 2 - System Hardware Configuration 

This section identifies the recommended, and the minimum, hardware configuration for the 
MTWS system 

MAN, MSC, and CART Server Hosts 

The recommended hardware for each MAN, MSC, and CART host is: 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

2 

 o Dell 4600 with dual 1.8 GHz processors 

 o 3 x 18GB disk in a RAID 5 configuration (54 GB total) 

o 1 Gb RAM. 

o (1) 100 MB network interface card for MAN and CART hosts 

o (2) 100 MB network interface cards for MSC host 

o CD drive. 

 

The minimum hardware for each MAN, MSC, and CART host is: 

 o  1.8 GHz x86 processor 

 o 40 GB hard disk drive 

o 1 GB RAM. 

o (1) 100 MB network interface card. 

o CD drive. 

For convenience, each of these hosts should have a dedicated monitor, keyboard, and 
pointing device.  However, only the MSC host requires these. 

Maui and CART Client Hosts 

The recommended hardware for each Maui host is: 

 o (2) 2.0 GHz Pentium IV CPUs 

 o (2) 40 GB hard disk drives 

 o 1 GB RAM. 

 o CD drive. 

 

 The minimum hardware for each Maui host is: 

 o (1) 600 MHz Pentium III CPU 

 o (1) 40 GB hard disk drive 
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 o 500 MB RAM. 

o CD drive. 

 

          The recommended hardware for each CART client host is:  

o (2) 2.0 GHz Pentium IV CPUs 

 o (2) 40 GB hard disk drives 

 o 2 GB RAM. 

o CD drive. 

 

The minimum hardware for each CART client host is: 

 o (1) 1.0 GHz Pentium IV CPU 

 o (1) 40 GB hard disk drive 

 o 2 GB RAM. 

o CD drive. 

 

Each of these hosts must have its own monitor, keyboard, and pointing device. 

 

Network Configuration – MAN/Maui LANs 

The recommended network configuration consists of two LANs – one for MAN, and one 
for Maui and CART hosts - with the MSC host serving as a “router” between the two 
LANs. This is the reason that two NICs are recommended for the MSC.  

Note that, although two LANs is the recommended configuration, all MTWS hosts can 
reside on a single LAN. In this type of configuration, the lack of LAN bandwidth may 
become a significant problem. 

Network Configuration – MTWS Hosts 

The system supports one MSC host; one or two MAN hosts; one CART server host; and 
up to 200 Maui hosts. If two LANs are used , note the following restrictions. 
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(a) if two MAN hosts are used, ensure that both are on the same LAN. 

(b) ensure that all Maui hosts are on the same LAN. 

NOTE: Although the system supports two MAN hosts, the recommended 
configuration is a single MAN host. In all performance benchmarks to date, the 
throughput of a single MAN configuration either meets or exceeds that of a 2-MAN 
configuration. 

 

 

Section 3 - System Software Configuration 

This section addresses the system software configuration for the MTWS system. 

MAN, MSC, and CART Server Hosts 

Each MAN, MSC, and CART server host requires the Red Hat Linux version 7.2 operating 
system. If dual processors are used, a shared memory multi-processor (smp) kernel must be 
installed. Install/configure the O/S as described below. 

Operating System Installation - Dell PowerEdge 4600 

1) Login (or power up) the server on which you wish to install Red Hat Linux 7.2. 

Put the Dell OpenManage Server Assistant Bootable CD v7.1 into the cdrom drive and 
reboot the system.  Once the system boots off of the CD, the “Dell OpenManage Server 
Assistant GUI” will appear. 

Click on “Click here for Server Setup” to continue.  

2) “Set Date and Time” window will appear 

  Enter the correct date, time and time zone for you server 

 Click on “Continue” 

3) “Select RAID Configuration Setting” window will appear 

  Choose RAID 5 – Striping with parity 

 “Select RAID Virtual Disk Size” 

  Choose Max Value  ie.  34711 MB 

 Click on “Continue” 
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 A warning window will pop up saying: 

 “One or more virtual disks have been found! 

  Are you sure you want to delete the existing virtual disk?” 

 Click on “Yes” 

 Another warning window will pop up saying: 

 “This action cannot be completed because the other program is busy. 

 Choose ‘Switch To’ to activate the busy program and correct the problem”. 

Click on “Switch To” 

Another warning window will pop up saying: 

 “The system must be rebooted to recognize the new virtual disk. 

 Click OK to reboot the system.  After rebooting, Server Setup will continue with the 
creation of the primary partition” 

Click on “OK” to start reboot. 

4)  “Select Operation System” window will appear 

 Choose Red Hat Linux 7.2 

 Click on “Continue” 

5) Configure Hard Drive 

 Uncheck the following checked boxes for:  /var and /home 

 Change /tmp to /mtws and then make changes according to the following 
recommended values: 

/root  6144 MB 

/boot  100 MB 

swap  2047 MB 

/usr  3072 MB 

/mtws  23266 MB *Note – if installing a MAN server, use /spare. 

 Click on “Continue” 
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6) “Enter Red Hat Linux 7.2 Configuration Information” window will appear. 

Enter in the appropriate information for the system you are installing. 

System Name  msc001 *Note - use appropriate name if a MAN server. 

 Domain Name  (leave blank if not in a Domain) 

 Firewall  None 

 Language  English 

 Root Password Enter Appropriate Password 

 DNS Server (leave blank if you are not using DNS) 

 Default Gateway Enter Appropriate Gateway IP Address 

 1) Network Interface eth0  (1000MB Lan not in use) 

  Click on “Disable this NIC” 

 2) Network Interface eth1  (Used for 100MB MAN Lan) 

  Specify an IP Address  ie.  192.6.24.50  *Note - use appropriate IP 

  Subnet Mask 255.255.255.0  Class C network  

 3) Network Interface eth2  (Used for 100MB MAUI Lan) 

  Specify an IP Address  ie.  192.6.25.50 *Note – Disable for MAN server. 

  Subnet Mask 255.255.255.0  Class C network 

 Click on “Continue” 

7) “Operating System Installation Summary” window will appear 

 Make sure “Save Installation Summary at /InstallSummary.htm” is 
check marked. 

 

* NOTE: 

Check the “Save Unattended Installation Script at /ks.cfg” box only if you want a 
copy of the output of the scripts ran/used to configure the system.  If you check 
this box, a warning window will pop up.  If you want to save installation script 
file, click “OK”, otherwise click the cancel button. 

 Click on “Continue” 
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A Server Assistant window will pop up.  Make sure the check box “Eject CD 
Automatically” is checked.  It is located on the lower left corner of the window. 

 Click on “Next” 

 The “Dell Open Manage Server Assistant CD” will eject at this time. 

 Place your Red Hat 7.2 Disk 1 Installation CD into the cdrom drive. 

 Click on “Finish” 

 A “Dell OpenManage Server Assistant” window will pop up suggesting that you to 
go to the Red Hat website for any of the latest updates once the installation is 
complete. 

 Click on “OK”  

 The server will reboot and then start the Red Hat 7.2 installation. 

 When prompted to insert Disk 2, replace Disk 1 with Disk 2 and then press the 
{Enter} key on your keyboard to continue. 

8) Once the system finishes installation of Red Hat 7.2 and the system reboots, login at 
the Console login prompt as “root”. 

 The /etc/hosts and /etc/sysconfig/network files need to be edited. Use the vi editor to                
make your changes. 

   

 /etc/hosts:   Make sure the file reflects what you put in for the MAN Lan and 
the MAUI Lan: 

  ie.  192.6.24.50  msc001    # MAN Lan 

   192.6.25.50  msc001-D   msc001 # MAUI Lan 

*NOTE – if MAN server use appropriate IP address 
  ie.   192.6.24.101  man001 

You may add in your MAUI and CART workstation IP addresses at this time. 

 /etc/sysconfig/network:   Make sure “HOSTNAME” matches what you 
put in /etc/hosts file.  If it doesn’t match, make 
the appropriate change and save the file.  Example: 
HOSTNAME=msc001.localdomain  -- change to: 
HOSTNAME=msc001 

 From the command line prompt, run “Xconfigurator” to setup the  

Xwindow system:     

Type in:  Xconfigurator  {Enter} 
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The “Welcome” screen will appear. 

Press the “Space Bar” to continue. 

The “PCI Probe” screen will appear. 

Make a note of the PCI card found. 

Press the “Space Bar” to continue. 

The “Monitor Probe” screen will appear.   

If it finds the correct monitor, Press the “Space Bar” to continue. 

If it doesn’t find the monitor, you will have to add the monitor manually by putting 
in the appropriate horizontal and vertical frequencies for that particular monitor 
before continuing. 

The “Video Memory” screen will appear.   

Use the arrow keys to choose the correct memory setting for your video card.  The 
PowerEdge 4600 comes with a built-in ATI video card with 8MB of RAM.  If 
you’re using a different video card, choose the appropriate value. 

 

Use the “Tab” key on the keyboard to get to the “OK” button and press the “Space 
Bar” to continue. 

The “Clockchip Configuration” screen will appear.   

 Choose “No Clockchip Setting (recommended)”, “Tab” to the 

 “OK” button and press the “Space Bar” to continue. 

The “Select Video Modes” screen will appear.   

 Use the “Arrow” keys to go to the appropriate 8 bit mode setting and press the 
“Space Bar” to mark that box. 

Mark the following 8 bit modes: 

   1280x1024 

   1152x864 

   1024x768 

  Then press the “Tab” key to move from 8 bit to 16 bit modes. 
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Mark the following 16 bit modes: 

   1280x1024 

   1152x864 

   1024x768 

 Use the “Tab” key to get to the “OK” button and press the  

“Space Bar” to continue. 

The “Starting X” screen will appear to test the settings you just put in your X 
configuration.  

Note: You have 9 seconds to complete the next step. 

Press the “Space Bar” to continue. 

If the Gnome Desktop appears properly, click on the “Yes” button 
with your mouse.   

 

Also, click the “Yes” button to start X at boot and reboot time.   

Click on “OK” to continue back to the original root console login prompt. 

Now reboot your server by typing in: reboot   {Enter} 

If “X” does not come up properly after you reboot, then you may have to rerun 
Xconfigurator or do some troubleshooting to find out why “X” is not starting. 

9) You should have the Red Hat login screen after the system reboot.   

Login in as “root” and edit the following system files to match the examples that are 
provided here:  /etc/ftpaccess,  /etc/ftphosts, and /etc/ftpusers 

/etc/ftpaccess -- should have the following: 

class   all   real,guest,anonymous  * 

email root@localhost 

loginfails 5 

readme  README*    login 

readme  README*    cwd=* 

message /welcome.msg            login 
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message .message                cwd=* 

compress          yes              all 

tar                     yes             all 

chmod       no  guest,anonymous 

delete       no  guest,anonymous 

overwrite      no  guest,anonymous 

rename      no  guest,anonymous 

log transfers anonymous,real inbound,outbound 

shutdown /etc/shutmsg 

passwd-check rfc822 warn 

 

/etc/ftphosts -- should look like the following: 

# Example host access file 

# Everything after a '#' is treated as comment, 

# empty lines are ignored 

allow root 192.6.24.* 

allow root 192.6.25.* 

allow soc 192.6.24.* 

allow soc 192.6.25.* 

allow mds 192.6.24.* 

allow mds 192.6.25.* 

 

/etc/ftpusers should look like the following. The line containing “root” should be deleted. 

bin 

daemon 
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adm 

lp 

sync 

shutdown 

halt 

mail 

news 

uucp 

operator 

games 

nobody 

 

The following RPM’s on your Red Hat Disk 2 CD should also be installed: 

linuxconf-1.25r7-3.i386.rpm 

gnome-linuxconf-0.67.1-1.i386.rpm 

vim-enhanced-5.8-7.i386.rpm 

vim-X11-5.8-7.i386.rpm 

 

Put the CD into your CD-ROM drive and mount the drive with the following command: 

Type in:  mount /mnt/cdrom   {Enter} 

Change directory to /mnt/cdrom/Red Hat/RPMS and then install the rpm using 

The “rpm –i or rpm –U” command. 

Reboot your system.  After reboot, you can run the MTWS rpm installation as described in 
section 3.1 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

12 

Operating System Installation - Other Manufacturer (Non-Dell PE 4600) 

Boot system with Red Hat Linux 7.2 CD-ROM Disk 1. 

If this is a re-installation, place the CD-ROM Disk 1 into the drive, and select                 
“reboot” from the System menu on the login dialog. If this is an initial installation, place 
the CD-ROM Disk 1 into the drive, power off the system; then power it back on again. 

 

The Select Language screen appears.   

Select the language of choice.  The default is English. 

Press NEXT. 

 

The Select Keyboard Configuration Screen appears. 

 Select keyboard configuration of choice or keep default 

 Press NEXT 

 

The Select Mouse Configuration Screen appears/ 

 Select mouse of choice 

 Press NEXT 

 

The Welcome Screen appears 

 Select NEXT 

 

The Select Installation Options Screen appears 

 Choose either 

  Workstation 

  Server 

  Laptop 
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depending upon the machine type on which you are installing. The default is Workstation 

 Press NEXT 

 

The Choose Partition Options Screen appears 

 Check the Have Installer Partition checkbox 

 Press NEXT 

 Select Remove All Partitions on the system 

 If you have 2 disks, in the “which drives to use?” selection area, select both. 

Leave the “Review” checkbox checked. 

 Press NEXT 

A WARNING Screen appears 

 Select NEXT 

The Partition Screen appears 

If you have 1 disk, use the defaults, which are: 

 hda1 … a boot partition mounted on /boot 

 hda2 … a root partition mounted on / 

 hda3 … a swap partition with no mount point 

 

 If you have 2 disks, use the defaults, which are: 

 1st disk): 

 hda1 … a boot partition mounted on /boot 

 hda2 … a swap partition with no mount point 

 hda3 … a free partition with no mount point  

 (2nd disk): 
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 hdb1 … a root partition mounted on / 

 

 Press OK 

The disk will now be partitioned.  When partitioning is complete select NEXT 

 

NOTE: MTWS will operate correctly and efficiently using the default partition 
configuration. There is no need to change it. Changing it can have adverse effects on 
MTWS operations. If changing it is desirable/necessary for some reason, refer to the Red 
Hat documentation. 

 

The Boot Loader Screen appears 

Accept the defaults  

Press NEXT 

 

The GRUB Password Screen appears 

 The default is no GRUB password 

 Accept the default 

 Press NEXT 

 

The Network Configuration Screen appears 

 Uncheck the Configure using DHCP checkbox 

 Enter IP address 

 Enter Net Mask = 255.255.255.0 

 The Network and Broadcast entries will fill automatically. 

 Enter Host Name 

 Enter Default Gateway. Use the IP address appropriate for your site. 
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 Enter Primary DNS. Use the IP address appropriate for your site. 

 Enter Secondary DNS. Use the IP address appropriate for your site. 

 Press NEXT 

 

The Firewall Configuration Screen appears 

 MTWS works correctly with no firewall. The selection you make here should 

 be appropriate for your site. If you select HIGH or MEDIUM, you must allow 

 incoming FTP and rsh. To do so, select FTP from the listed services; and enter 

 513 (the login port) in the “other ports” area to enable rsh. 

 Press NEXT 

 

The Language Support Screen appears 

 Enter languages desired 

 Press NEXT 

 

The Time Zone Screen appears 

 Click on desired area on map to view time zones 

 Click on the UTC tab 

 Choose a time zone, or choose a UTC offset. 

 DO NOT check the Daylight Savings time check box. MTWS computes exercise 
time based upon the system clock. If the system clock jumps forward or backward 
one hour, the exercise time will also jump forward or backward one hour, which is a 
very undesirable behavior. 

 Press YES 

 

The Account Configuration Screen appears 
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 Enter root password 

 Enter root password again to confirm 

 Press NEXT 

 

The Select Package Group Screen appears 

 Select GNOME, KDE, and SOFTWARE DEVELOPMENT 

 Select Individual Packages 

 Press NEXT 

 

The Individual Package Selection Screen appears 

 In addition to the default settings ensure that the following packages are selected: 

  Applications – Editors 

   VIM-X11 

   VIM-Enhanced 

  Applications – Internet 

   FTP 

   TELNET 

  System Environment – Daemons 

   rsh-server 

   Telnet – server 

   Wu-ftpd  

  If PC has a dual processor ensure the following package is selected 

  System Environment – kernel 

   kernel-smp 

 Press NEXT 
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The Video Configuration Screen appears 

 Choose Skip X Configuration. 

 Press NEXT 

 

The About to Install Screen appears 

 Press NEXT 

 

The Installation Screen appears 

 This process will take a few minutes 

 When prompted, insert the Linux Red Hat Version 7.2 CD-ROM Disk 2 

 Press YES 

 Installation continues 

 

When installation is complete, the Create Boot Disk Screen appears 

 To create boot disk, follow onscreen instructions or 

 Check the Skip Boot Disk Creation checkbox 

 Press NEXT 

 

Installation is now complete. 

The system will reboot automatically.   

 

After reboot, login as user root. 

From the command line prompt, run “Xconfigurator” to setup the Xwindow system:     

Type in:  Xconfigurator  {Enter} 
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The “Welcome” screen will appear.   

Press the “Space Bar” to continue. 

 

The “PCI Probe” screen will appear. 

 Make a note of the PCI card found. 

Press the “Space Bar” to continue. 

 

The “Monitor Probe” screen will appear.   

  Select “use default” and continue. 

 

The “Starting X” screen will appear to test the settings you just put 
in your X configuration.  

 

Note: You have 9 seconds to complete the next step. 

Press the “Space Bar” to continue. 

 

If the Gnome Desktop appears properly, click on the “Yes” button 
with your mouse.   

 

Also, click the “Yes” button to start X at boot and reboot time.   

Click on “OK” to continue back to the original root console login prompt. 

 

Now reboot your server by typing in:  

reboot   {Enter} 

 

If “X” does not come up properly after you reboot, then you may 
have to rerun Xconfigurator, or do some troubleshooting, to find out 
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why “X” is not starting. 

 You can now run the MTWS rpm installation script on the MTWS Installation CD. 

Additional Operating System Configuration – MAN/MSC/CART Server 

Following the basic installation of the operating system, several additional steps are 
necessary before the system is ready to support MTWS. This section describes operating 
system configuration items necessary to support the operation of the MAN, MSC, and 
CART server software. The following paragraph provides some background as to why 
these configuration items are needed. 

The MSC host is the central “hub” for the MTWS system. The MSC sends data to (e.g., 
commands) and receives data from (e.g., database updates) all MAN hosts. The MSC 
sends data to (e.g., database updates), and receives data from (e.g., commands), all Maui 
hosts. The MSC sends data to (e.g., database updates), and receives data from (e.g., 
requests for initialization data), the CART server. If MTWS is communicating with the 
Joint Command & Control Attack System (JCAS), a part of the JQUAD system, MSC 
sends data to JQUAD. See Operating with the Joint Training Confederation in Chapter 
4 for discussion of JQUAD considerations. All of the above are socket-based Transmission 
Control Protocol/Internet Protocol (TCP/IP) communications. In addition, Maui hosts use 
File Transfer Protocol (ftp) services to send files to (e.g., parametric data files), and to 
retrieve files from (e.g. batch files ) the MSC. 

MAN hosts perform simulation processing. Each MAN host receives data from (e.g., 
commands), and sends data to (e.g., database updates), the MSC host. If two MAN hosts 
are used, each MAN host passes database updates to the other MAN host, so that their 
databases stay synchronized. If MTWS is running as part of the Joint Training 
Confederation (JTC, formerly known as the Aggregate Level Simulation Protocol (ALSP) 
confederation), one MAN host sends data to (e.g., MTWS database updates), and receives 
data from (e.g., other model’s updates), the JTC. See Operating with the Joint Training 
Confederation in Chapter 4 for discussion of JTC considerations. All of the above are 
socket-based TCP/IP communications. 

The CART server host records and retrieves exercise data. The CART server host receives 
data from (e.g., database updates), and sends data to (e.g., requests for initialization data), 
the MSC. The CART server host receives data from (e.g., database queries), and sends data 
to (e.g., query results), CART client hosts. Communications with the MSC are socket-
based TCP/IP communications. Communications with CART client hosts are via Open 
Database Connectivity (ODBC) drivers, and Hypertext Transfer Protocol (HTTP). 

/etc/hosts or the Name Service Database 

As described in the preceding operating system installation sections, the /etc/hosts file must be 
configured to support inter-connectivity between MTWS components. MTWS will operate 
correctly with either file-based name service through /etc/hosts, or with the Distributed Name 
Service (DNS) protocol.  File-based name service through /etc/hosts is recommended since DNS 
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can incur a performance penalty. Note that MTWS is not compatible with Network Information 
Service (NIS) name databases. 

The following applies to /etc/host entries for all MTWS components. Note that all entries are 
case-sensitive. 

a. all hostnames must be six (6) characters long. 

b. the name of the MSC host must be “msc001”. 

c. the name of a MAN host must be either “man001” or “man002”. 

d. the name of a Maui host must be “mdsxxx”, where ‘x’ is lower case 
alphanumeric. 

e. the name of a CART server host must be a valid Maui hostname; and it must 
have the alias “cartserver” 

f. the “msc001”, “man00x”, “mdsxxx” name must the primary hostname; it cannot 
be an alias. 

g. each /etc/hosts file must have a “localhost” entry in the format: 

127.0.0.1 localhost.localdomain localhost 

h. each /etc/hosts file must have the host’s own IP address, in the format: 

 <IP address>   myhostname   <alias, if desired> 

 

On the MSC host, /etc/hosts must contain an entry for each MAN host; each Maui host; and the 
CART server, if CART is to be used. If MTWS is communicating with the JQUAD system, 
MSC’s  /etc/hosts file must contain an entry in the format: 

 <IP address>   jquadhost  

See section Operating with the Joint Training Confederation in Chapter 4 for discussion of 
JQUAD considerations  

On a MAN host, /etc/hosts must contain an entry for MSC; and for the other MAN host, if 
applicable. If MTWS is running as part of the Joint Training Confederation (JTC), the MAN host 
on which the ALSP application is running must contain an entry in the format: 

 <IP address>   jtchost  

See section Operating with the Joint Training Confederation in Chapter 4 for ALSP 
considerations. 
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On a CART host,  /etc/hosts must contain an entry for MSC; and for each CART client. 

 

/etc/services 

MTWS uses socket-based Transmission Control Protocol/Internet Protocol (TCP/IP) to 
pass messages among components; e.g., between MAN and MSC, between MSC and 
CART, etc. Ensure that /etc/services on each MAN, MSC, and CART host contains the 
following entry. 

 Mtws 12753/tcp  # general MTWS communications 

If MTWS is communicating with the JQUAD system, MSC’s  /etc/services file must 
contain an entry in the format: 

 JQUAD 2000/tcp jquad 

See section Operating with the Joint Training Confederation in Chapter 4 for JQUAD 
considerations 

If MTWS is running as part of the Joint Training Confederation (JTC), /etc/services on the MAN 
host on which the ALSP application is running must contain entries in the format: 

alsp_base_port 3000/tcp alsp_base 

alsp_monitor_port 3000/tcp alsp_base 

See section Operating with the Joint Training Confederation in Chapter 4 for ALSP 
considerations. 

/etc/ sysconfig/network 

Ensure that, in the /etc/sysconfig/network file on each MAN, MSC, and CART host, 
“HOSTNAME” exactly matches the corresponding entry in /etc/hosts. If it does not match, 
make the appropriate change. For example, change: 

 HOSTNAME=msc001.localdomain 

to: 

 HOSTNAME=msc001 
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/etc/ftpaccess 

This following is required to support File Transfer Protocol (ftp) operations on the MSC 
host. However, for convenience, we recommend that the /etc/ftpaccess file on all MSC, 
MAN, and CART hosts adhere to the following example. 

   class   all   real,guest,anonymous  * 

   email root@localhost 

   loginfails 5 

   readme  README*    login 

   readme  README*    cwd=* 

   message /welcome.msg            login 

   message .message                cwd=* 

  compress          yes              all 

  tar                     yes             all 

  chmod       no  guest,anonymous 

  delete       no  guest,anonymous 

  overwrite      no  guest,anonymous 

  rename      no  guest,anonymous 

  log transfers anonymous,real inbound,outbound 

  shutdown /etc/shutmsg 

  passwd-check rfc822 warn 

 

/etc/ ftphosts 

This following is required to support File Transfer Protocol (ftp) operations on the MSC 
host. However, for convenience, we recommend that the /etc/ftphosts file on all MSC, 
MAN, and CART hosts adhere to the following example. 

# Example host access file 

# Everything after a '#' is treated as comment, 
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# empty lines are ignored 

allow root 192.6.24.* 

allow root 192.6.25.* 

allow soc 192.6.24.* 

allow soc 192.6.25.* 

allow mds 192.6.24.* 

allow mds 192.6.25.* 

 

/etc/ ftpusers  

This following is recommended to support File Transfer Protocol (ftp) operations on the 
MSC host. However, for convenience, we recommend that the /etc/ftpusers file on all 
MSC, MAN, and CART hosts adhere to the following example (the line containing “root” 
should be deleted). Note that users identified in this file are denied ftp access. 

bin 

daemon 

adm 

lp 

sync 

shutdown 

halt 

mail 

news 

uucp 

operator 

games 

nobody 
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/.rhosts 

The /.rhosts file allows the super-user to log on to any of the Linux hosts without 
supplying a password.  This can greatly aid the site administrator in the set-up of each 
Linux host since a script can be used to update system files.  Every MTWS Linux 
hostname (e.g., man002) should be listed in the /.rhosts file on each MTWS Linux host.  
The hostname may include a domain name for networked installations.  These changes are 
not necessary for actual MTWS operation. 

/etc/fstab 

The /etc/fstab file contains the list of both local and networked file systems that should be 
mounted at boot time.  For each networked file system, access must  be allowed (i.e., 
exported to ) each man host.  For security, unlimited access to all hosts should not be 
allowed.  For all other hosts, the file will contain Network File System (NFS) mounting 
information used to access the file systems on the MSC.   

NOTE 

This file may not be the same for all non-MSC hosts since the device 
address of the boot disk may vary. 

 

/etc/group 

The /etc/group file defines valid group names for the workstation.  All MTWS user names 
(e.g., soc) require the group mtws.  The group ID is left to the site administrator's 
discretion, but must be the same across all MTWS workstations.  Failure to properly set the 
group name and group id will result in MTWS failures while reading and writing the /mtws 
file systems.  Normally, the group file may be set up on the MSC and copied to all other 
MTWS hosts. 

/etc/passwd 

The /etc/passwd file defines valid user names and passwords for the workstation.  MTWS 
requires the user names defined in Table 1.  The user IDs and passwords are left to the site 
administrator's discretion, but must be the same across all MTWS workstations.  Failure to 
properly set the user name and user id will result in MTWS failures while reading and 
writing the /mtws file systems.  Passwords should be selected so they are a minimum of 8 
characters in length.  They should contain one or more numeric or special characters.  They 
should not be based on words or names.  The /etc/group file must be set up prior to adding 
the user names to the passwd file.  Normally, the password file may be set up on the MSC 
and copied to all other MTWS hosts. 
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Table 1.  Required MTWS User Names 

User Name Home Group Start-up 
Program 

Login 
Environment 

soc /mtws/soc mtws /bin/bash Shell 
mds /mtws/mds mtws /bin/bash Shell 

 

/etc/shells 

The system file /etc/shells defines which shells are considered valid by the system.  For 
remote logins (including ftp), if the shell is not found in /etc/shells, the login will be 
rejected.  MTWS is based on the /bin/bash shell.  /etc/shells must be present on every 
MAN, MSC, and CART host with the following contents: 

/bin/sh 
/bin/bash 
/bin/bash2 
/bin/ash 
/bin/bsh 
/bin/tcsh 
/bin/csh 
/bin/ksh 

 

Creating and Configuring MTWS File Systems 

MTWS software and data files may be distributed across one or more disks on the MSC.  
The MAN boxes use Network File System (NFS) to access this data.  Each Maui 
workstation uses its own internal disk; and uses ftp network services to retrieve and store 
files from/to the MSC.  The recommended minimum for MSC and MAN disk space is 
18GB.   

The MSC /mtws file system must be mounted to the MAN hosts. This mounting requires 
that the file system be exported from the MSC for use by remote hosts; and mounted 
locally on each workstation that requires the file system. 

Exporting MSC File Systems 

File systems that require mounting on the MAN workstations must first be exported on the 
MSC.  This exporting operation results in changes to the system file /etc/exports.  The 
steps for exporting a file system on the MSC are:  

a. Edit the file /etc/exports 

b. Add the following to the file if it is not already there and save the changes:                                                     
/mtws       man001(rw,no_root_squash,insecure) 
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c. From the command line, type in:  exportfs  -a –v  {enter} 

 

Mounting Remote File Systems  

These instructions apply only to MAN hosts.  The operator must be on the network in 
order to create mount points. 

a. Edit the file /etc/fstab 

b. Add the following to the file if it is not already there and save the changes:  
msc001:/mtws       /mtws  nfs exec,dev,suid,rw 1 1 

c. From the command line, type in:  mount /mtws  {enter} 

 

Synchronizing Time 

Network Time Protocol (NTP) services can be used to synchronize the system times used 
by the MSC, MAN, and CART hosts. To configure NTP, set up the MSC as the NTP 
server, and the MAN and CART servers as clients by doing the following: 

a. On the MSC only, change the date and time to the correct date/time group by typing 
in:    date  MMDDhhmm  {enter}                                                                                 
where MM=month  DD=date  hh=hour  mm=minute                   

b. Edit the file /etc/ntp.conf on the MSC, MAN, and CART servers. 

c. Add the following to the file if it is not already there and save the changes:                                                     
server xxx.xxx.xxx.xxx  (IP address of  MSC) 

d. Edit the file /etc/ntp/step-tickers on the MSC, MAN, and CART servers. 

e. Add the following to the file if it is not already there and save the changes:                                                     
xxx.xxx.xxx.xxx  (IP address of  MSC) 

f. From the command line on each server,                                                                     
type in:   chkconfig –level 5 ntpd on  {enter} 

g. From the command line on each server,  type in:  service ntpd start {enter}; or re-
boot the systems in order: MSC, MAN, CART. 
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Third-Party Support Software 

Perl 

Perl version 5.6.0 is included with Red Hat Linux version 7.2. Perl is required on the MSC 
host for batch file conversion.  For further information about Perl, see http://www.perl.com 
and the Red Hat documentation. 

 

Linux CD Burning Software -- X-CD-Roast 
The following rpms need to be installed to use a CD-RW drive in RedHat version 7.2, they are 
located in the MTWS Support folder of the MTWS RPM CD. 
 
     cdrtools-cdda2wav-1.11a21-1.i386.rpm 
     cdrtools-cdrecord-1.11a21-1.i386.rpm 
     cdrtools-libscg-1.11a21-1.i386.rpm 
     cdrtools-mkisofs-1.11a21-1.i386.rpm 
     xcdroast-0.98alpha10-1.i386.rpm 
 
Once installed, the software needs to be configured as follows. 
 
Click on 'Main Menu' --> 'Programs' --> 'Applications' --> 'X-CD-Roast' 
A GUI will appear.  Click on "Launch X-CD-Roast" to begin the configuration. 
Another window will appear stating:   
   "No root configuration file found! 
     Please enter Setup and don't forget to add users who may also use X-CD-Roast" 
Click on "OK" to continue.   
The X-CD-Roast main menu GUI will appear. 
Click on "Setup".   
 
Click on the "CD Settings" Tab and change the "CD Writer Configuration" to the following: 
 CD Writer Device:  'Set to type of CD Writer' 
 CD Writer Mode:    'Autodetect' 
 CD Writer Speed:   'Set to preferred speed of writer and blank CD's' 
 CD Writer FIFO-Buffer-Size:  'Set to value you would like to use for buffer size' 
 
Click on the "HD Settings" Tab 
 Enter in a path you would like to use for 'Temporary Image Storage Directory': 
  example:  create a directory called /X-CD-Roast and enter it in the 
            'Path:' window box and click on the "Add" button. 
 
Click on the "Options" Tab and check the 'Windows style list selections' box 
 and make sure the 'Default Write Options' is set to "Disk-At-Once (DAO)" 
 
The defaults for everything else should be fine.   
Now click on the "Save configuration" button and the "Ok" button of the pop up window 
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and then click the "OK" button for the 'Setup' GUI. 
 
To create a CD: 
 
1.  Click on the 'Create CD' button 
2.  Click on the 'Master Tracks' button 
    and uncheck the 'Display directories only' box. 
3.  In the 'Master source' tab 'File/Directory view' box, choose the directory or files  
    you wish to write to CD. 
4.  Click on the "Add" button.  A popup window will appear.  Choose if you would 
    like full path names or just the file/directory name to be written to disk 
    and click on "OK" 
5.  If this is a bootable CD you are creating, click on the 'Boot options' tab and 
    select what type of boot options you would like. 
6.  Click on the 'Create session/image' tab 
    a)  make sure the 'Calculate automatically' check box is checked 
    b)  check the 'Create multi session CD' check box if you want to write to the 
        end of your CD, otherwise keep the rest of the defaults. 
    c)  If you have a CD-RW disk, click on "Blank CD-RW" button to clean up disk.  The default 
        is good enough in any case, but if you'd prefer to fully blank your CD-RW you can, 
        but it takes longer.  Click on the popup window 'Blank CD-RW' button to continue. 
    d)  To write to your CD, click on the "Master and write on-the-fly" button. 
        The CD will eject after it is finished. 
7.  Click on the "Back to main menu" button 
8.  Click on the "Exit" button when finished. 
 
 

 

Maui Hosts 

The recommended operating system is Windows 2000/Office 2000. Each Maui host that is 
to be used as a CART client workstation must have Microsoft Internet Explorer version 5.5 
or later. 

If Windows 2000/Office 2000 is not available, Windows NT Service Pack 5 or later, with 
Office 97, can be used instead. 

 

Operating System Installation – Maui Hosts 

Each Maui host requires the Windows NT, Service Pack 5 or later; or Windows 2000 
operating system. Microsoft Office 97 or Office 2000 is also required. Each Maui host that 
is to be used as a CART client workstation must have Microsoft Internet Explorer version 
5.5 or later. See Microsoft’s documentation for instructions on how to install this software. 
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Additional Operating System Configuration – Maui Hosts 

Following the basic installation of the operating system, several additional steps are 
necessary before the workstation is ready to support Maui. Most of these steps are 
performed as part of the Maui installation process as described in section 3.3. The 
following describes some additional, optional configuration issues, which are not 
addressed as part of the Maui installation. 

Maui User Account 

For convenience and simplicity, the username for the workstation should be mds, a 
username required by MTWS. The password should be the same as the user mds password 
on the MSC host. 

Shared Network Data 

To set up a Maui network to share data files such as ADRG maps, or overlay files, select a 
Maui workstation which will act as a "data server" and create a folder called 
\MauiData\Maps on a drive with enough disk space to support the expected number of 
ADRG and TIFF maps to be shared. Then create the following sub-folders  

      <DRIVENAME>:\MauiData\Maps\ADRG   

      <DRIVENAME>:\MauiData\Maps\TIFF 

      <DRIVENAME>:\MauiData\Maps\TRR 

      <DRIVENAME>:\MauiData\Maps\Elevation 

Make the MauiData folder shared by selecting the folder in Microsoft Explorer or "my 
computer", and right clicking to obtain the menu, then select properties which will open up 
the properties sheet for this folder.  Select the Sharing tab and then select the Shared As 
radio button.  Enter the name MauiSharedData in the Shared Name field. 

Then, on each workstation that will shared the “MauiSharedData” folder, including the one 
which contains the MauiSharedData folder, use network neighborhood to map a network 
drive as follows: 

   Drive: Z: 

   Path: \\mdsxxx\MauiSharedData 

where mdsxxx is the workstation on which you created the shared folder. 
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Local Data 

If maps are be stored locally on each workstation, set up a folder to store the ADRG maps 
by creating a folder on the drive in which Maui will be installed. If you are going to install 
Maui on the D drive, create a folder D:\MauiData\Maps\ADRG to hold the ADRG maps.  
For each map installed, create a sub-folder within the ADRG folder, and then copy the files 
from the ADRG CD to the sub-folder. For example, if you are installing the Camp 
Pendleton ADRG map, create a folder D:\ADRG\CampPendleton and then copy the 
contents of the CD into the CampPendleton folder. 

 

Chapter 3 - MTWS INSTALLATION 

Section 1 - MAN/MSC Hosts 

This section describes installation of the MAN and MSC application software. The 
installation is provided in a Red Hat Package Manager (rpm) format. 

Installing this software preserves the contents of the directories listed below. If any other 
directories/data should be saved, ensure that this is done prior to performing this 
installation. The following directories are preserved. 

/mtws/db/cmd_entry/batch … this directory contains user-defined batch and master batch 
files. 

/mtws/db/man … this directory contains exercise databases. 

/mtws/db/parametric … this directory contains parametric data. 

/mtws/db/terrain … this directory contains digitized terrain data. 

 

 

Backup DLT Tape Drive  

DLT tapes (DLT 1 40/80GB tape) are used to back up system data files.  The DLT  tapes 
should be labeled and stored in a safe place. 

To remove the DLT tape, press the EJECT button near the unit opening.  The status lights 
on the tape unit will begin to blink and the tape will be ejected.  To load a DLT tape, insert 
it into the opening in the tape unit.  If any resistance is encountered during insertion, 
remove it and try again.  When successfully inserted, the DLT tape is pulled into the unit 
and some status lights on the unit begin to blink.  When the lights stop blinking and remain 
steadily on, the tape is operational and ready for immediate use. 
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The “tar” commands are used to backup/restore files to a tape drive. Tar can be used to archive a 
group of files into another file or more commonly to write/restore a group of files to a tape drive. 

 

Options Description 

c create a archive (write to tape) 

t display files on archive (view only) 

x extract from archive (read from tape and 
write to disk) 

v verbose - display filenames 

z compress files (using gzip) 

f device name or file name to write to 

directory or 
file 

directory or file to use 

Note: The following examples assume the device name of your tape drive is /dev/st0 (Default 
name of tape drive). 

Command What it does 

tar cvf /dev/st0 /mtws backup the entire MTWS 
directory  to tape 

tar tvf /dev/st0 view the contents of a tape 

tar xvf /dev/st0 restore the entire contents of 
the tape 

 

The “mt” commands can be used to erase, data compression, status and more.  Please see the 
man pages for other options for the mt command. 

 

Note: The following examples assume the device name of your tape drive is /dev/st0 (Default 
name of tape drive). 
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Command What it does 

/usr/sbin/mt -f /dev/st0 
status 

Gives tape status 

/usr/sbin/mt -f /dev/st0 
erase 

Erases tape 

/usr/sbin/mt -f /dev/st0 
datcompression 

Turn data compression on.  This 
will make a 40GB tape an 80GB 
tape. 

 

 

Install the software as follows.  
 
Login to the MAN host as “root”. 
Insert the MTWS installation CD into the CD-ROM drive. 
Bring up a term window and check to see if the CD-ROM mounted by entering: 
   df –h.   
If there is no reference to /mnt/cdrom, mount the drive manually by entering: 
   mount  /mnt/cdrom  {Enter} 
 
Once the drive is mounted, change directory to /mnt/cdrom/MAN-RPM-Install 
 
To start the installation, enter: 
   ./Setup-MAN-Install   {Enter} 

 

Once the command prompt returns, reboot the server by entering: 

      reboot  {Enter} 

Repeat the above steps for each MAN host. Note that the MAN rpm installation is required 
the first time v3.0 is installed. However, if v3.0 is re-installed at some later time, this step 
is not necessary. The MAN rpm installation only establishes the system configuration 
needed to run the MAN software. It does not install the MAN application software itself. 
The MAN and MSC applications are installed by the following steps. 

 

Login to the MSC host as “root”. 
Insert the MTWS installation CD into the CD-ROM drive. 
Bring up a term window and check to see if the CD-ROM mounted by entering: 
   df –h.   
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If there is no reference to /mnt/cdrom, mount the drive manually by entering: 
   mount /mnt/cdrom  {Enter} 

 

Once the drive is mounted, change directory to /mnt/cdrom/MSC-RPM-Install / 
 
To start the MTWS installation, enter: 
   ./Setup-MSC-Install   {Enter} 
 
Once the command prompt returns, reboot the server by entering: 
      reboot  {Enter} 

 

 

Section 2 - CART Server Host 

This section describes installation of the CART server application software. The 
installation is provided in a Red Hat Package Manager (rpm) format. The CART Server is 
necessary for support of after-action review of the exercise. MTWS does not require a 
CART Server. If you do not intend to use CART, you can skip this section. 

CART requires the following packages (or later versions of these packages) to be installed 
onto the CART server: 

apache-1.3.20-16 
apacheconf-0.8.1-1 
 
mysql-3.23.49-3.i386 
mysqlclient9-3.23.22-6.i386 
mysql-server-3.23.49-3.i386 
postgresql-libs-7.2.1-5.i386 
 
perl-5.6.1-34.99.6.i386 
perl-CGI-2.752-34.99.6.i386 
perl-DBD-MySQL-1.2219-6.i386 
perl-DBI-1.21-1.i386 
libdbi-0.6.4-2.i386 
libdbi-dbd-mysql-0.6.4-2.i386 
gcc-2.96-98 
flex-2.5.4a-15 

bison-1.28-7 

These packages are provided on the MTWS Installation CD. You may check for the 
presence of a package by entering the following command into a command shell: 

 rpm --query <package> 
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For example: 
% rpm –query apache 
apache-1.3.23-11 
If your system returns a message “Package <package> is not installed”, the rpm command 
can be used to install the package as follows: 
rpm –install <files> 
e.g.:   
cd /mnt/cdrom/CART-RPM-Install 
rpm –install  apache-1.3.20-16.i386.rpm 

 

The CART installation software is supplied on the MTWS V3.0 CD. To install CART onto the 
CART server perform the following steps. 

1 Login as root  
2 Insert the MTWS installation CD into the CART server CD-ROM 
3 Open a shell. 
4 Check to see if the CD-ROM mounted by entering: 

a. df –h 
5 If there is no reference to /mnt/cdrom, then mount the drive manually by entering: 

a. mount /mnt/cdrom 
6 Enter the following commands: 

a. cd /mnt/cdrom/MTWS-CART-RPM-Install 
b. ./Setup-CART-Install 

 

The software for creating the reports are installed into the default apache directory structure 
/var/www. The exercise data is stored in the directory /var/lib/mysql. The remaining software is 
in /mtws/ 

 

Environment Variables in MTWS 

The MTWS environment includes a set of key variables that the system uses to find 
resources, store files, and the like.  These variables are listed in Tables 2 and 3 according to 
the MTWS component that uses them.  All of these variables have been set to their defaults 
in the supplied files. 

 

Table 2.  MAN Environmental Variables 

Defined in: /mtws/bin/MAN/Start_MAN 

Name Function Default Parameter 
XAPPLRESDIR Directory containing MAN X 

resource files 
/mtws/bin/app-
defaults/man-app-defaults/ 
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EXERCISE_PATH Directory in which MTWS 
exercises reside 

/mtws/db/man/ 

  

Table 3.  MSC Environmental Variables 

Defined in: /mtws/soc/.profile 

Name Function Default Parameter 
MTWS_ROOT Base directory for MTWS program 

installation. 
/mtws 

MTWS_DATA Directory for storage of MTWS 
data files 

/mtws/db 

MTWS_DEFAULT Directory for MTWS defaults /mtws/db/default 
XAPPLRESDIR Directory containing MSC X 

resource files 
/mtws/bin/app-defaults/msc-
app-defaults/ 

HELP_DIR path to help files and 
RELEASE_NOTES 

/mtws/help/ 

ALSP_HOME ALSP home directory path /mtws/bin/ALSP/ 
ALSPBIN ALSP executables directory path $ALSP_HOME 
MDS_BITMAP_DIR Bitmap directory for MDS 

applications 
/mtws/bin/app-
defaults/bitmaps/ 

EXERCISE_PATH Directory in which MTWS 
exercises reside 

/mtws/db/man/ 

TO_CONTROLLER_P
ATH 

Path to controllers.txt file /mtws/db/current/configs/ 

BASELINE_PATH Baseline parametric data directory /mtws/db/parametric/baseline/ 
USER_DEFINED_PA
TH 

User-defined parametric data 
directory 

/mtws/db/parametric/user_defi
ned/ 

PARA_DATA_PATH Directory in which Command 
Entry finds parametric data 
information 

/mtws/db/current/cmd_entry/p
ara_data/ 

SR_WORK Directory containing Solicited 
report formats 

/mtws/db/rg/ 

 

 

Section 3 - Maui Hosts 

This section describes installation of the Maui software suite. To install this software you 
must be user ADMINISTRATOR, or a user that has ADMINISTRATOR privileges.  

There are two folders of particular importance in the installation process. The first is the 
folder in which you install the software. The default, provided by the installation software, 
is Mtws. If both C: and D: drives are available, the default is D:\Mtws; if only a C: drive is 
available, the default is C:\Mtws. If the default is accepted, and if no \Mtws folder exists on 
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the drive, the installation will create it. We strongly recommend accepting this default; or 
selecting the drive with the most available space. 

We strongly recommend accepting this default. The folder chosen at this time will be 
completely removed when Maui is re-installed. The reason for providing the \Mtws default 
is so that the re-installation process does not interfere with other software on the system – 
i.e., the Maui software, and only the Maui software, resides in that folder. In the 
discussions that follow, “the MTWS path” and “the MTWS folder” refer to the path/folder 
in which the software is installed. 

The second folder of interest is \MauiData. This folder and its sub-folders contain various 
data files, including maps; overlays; reports; and log files generated during execution of 
the Maui software. If they do not already exist, the folders \MauiData\MDMData and 
\MauiData\Snapshots are created by the installation on the drive on which the installation 
is performed. For example, if D:\Mtws is chosen as recommended above, 
D:\MauiData\MDMData and D:\MauiData\Snapshots will be created if they do not 
already exist. The MDMData folder contains World Vector Shoreline maps; the Snapshots 
folder contains an example snapshot (a view of the tactical display database) included with 
the installation. 

Much of the Maui software is written in Java, and therefore requires a Java Run-time 
Environment (JRE) in which to execute. If the JRE is not found on the workstation during 
Maui installation, the installation program will attempt to install it. By default, the JRE is 
installed on the drive defined by the TEMP environment variable. For example, if TEMP is 
set to D:\TEMP, the JRE is installed on the D: drive. If that drive does not have enough 
space to install the JRE, but does have enough space to launch the installation program,           
a message is displayed, indicating that there is not enough room to install the JRE.  

If this problem occurs, do not continue with the installation. If you were to continue, 
portions of the installation would not be completed properly without the JRE. Instead,  
correct this problem by changing the TEMP environment variable to use a drive which has 
adequate space to install the JRE and Maui; and to hold data files such as maps, overlays, 
etc. 

 

 Saving Old Data 

Installing Maui completely removes the MTWS path; i.e., all files in that path are deleted. If 
you wish to preserve any data files in that path, copy them to a location outside the MTWS 
folder prior to installing Maui. If you get an error message saying there is an access violation 
or locked file detected, make sure that you are NOT: 

- Running any Maui software suite component. 

- Pointing to the MTWS folder or sub-folders with any other application program  

- Pointing to the MTWS folder or sub-folders in a DOS window 
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- Currently editing, or have an editor open which has a file from the MTWS folder or 
sub-folders in its history list (e.g. Word, NotePad) 

If all else fails, reboot the machine. This will remove all existing links to files in the 
MTWS path on the drive in which Maui is installed. When the files you want to keep are 
backed up or moved from the MTWS folder or sub-folders, you can start or restart the 
installation process. 

Installing from an installation CD 

a. Insert the CD into the CD-ROM drive. If the Installation program does not startup 
automatically, from the Start menu, select the 'Run' option and type in the  CDROM drive 
letter followed by: <driveLetter>:\v3.0-mb030212\Setup.exe.  e.g.: if the drive letter is 
'E',   type in the following: E:\v3.0-mb030212\Setup.exe 

b. If the installation program automatically starts, go to Paragraph b in Section “Launching 
the Installation Program”.  

c. If the installation program does not automatically start, select the Start button on the 
Windows taskbar, then choose Run. In the Run dialog box, type X:\SETUP, where X is 
the letter of your CD-ROM drive; then select the OK button.  

d. Go to Paragraph b in Section “Launching the Installation Program”. 

Installing from a networked drive 

a. Open Network Neighborhood by double-clicking on the Network Neighborhood icon on 
your desktop. 

b.  Locate the workstation computer name and shared folder containing the Maui 
installation program. 

c. Find the file named Setup.exe. 

d. Go to Paragraph b in Section “Launching the Installation Program”. 

Installing from your local drive 

 

NOTE 

The installation medium may be copied from a CD, or across the 
network, to your hard drive for an easier and faster installation. The 

entire folder in which the Setup.exe file resides must be copied to your 
local drive in order for the installation program to work properly.  

Make sure to remove this folder to free up this disk space when the 
installation has successfully completed. 
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a. Use Microsoft Explorer to find the file named Setup.exe. 

b. Go to Paragraph b in Section “Launching the Installation Program”. 

Launching the Installation program 

a. Double-click on Setup.exe to launch the installation program.  

b. The installation program will recognize a previously installed version of Maui.  Items d-h 
describe how to uninstall a previous installation. If there is no previously installed version 
on your computer, skip to Step i, otherwise go to the next step. 

c. Even if you have deleted or renamed your MTWS folder, the installation program will 
determine if there is previously installed version on your machine, and provide you with 
three radio button options to [Modify], [Repair], or [Remove] the previous installation. 

NOTE 

Putting a new Maui installation on your machine requires uninstalling, 
if it exists, the previously installed version.  This un-installation process 

deletes the current installation's MTWS folder and all of its contents 
and sub-folders.  If you want to save any or all of the contents of your 
MTWS folder, follow the instructions in the Saving Old Data section 

above. 

d. Select the [Remove] radio button option and then the [Next >] button. 

e. A confirmation dialog box will appear asking if you really want to completely remove the 
selected application and all its components.  Select the [OK] button. 

f. The installation program will remove the previously installed files from their location on 
your hard drive.  If you have moved the files to a location outside of the MTWS path, 
these files will not be disturbed by this un-install.  The configuration settings will also be 
removed.  

g. If, for any reason, the installation program cannot remove a file, it will ask you whether 
you want to Reboot" "Ignore" "Retry" and "Cancel".  Select the [Cancel] option and 
make sure that you do NOT have any files locked as described in the Saving Old Data 
section above.   

h. Reselect the Setup.exe program from this installation program folder to restart the 
installation program a second time. 

i. Maui Installation 

At this point the installation program should not encounter a previously installed version 
if Maui on your machine. The installation program will provide the series of scripted    
pages described below. 
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1) Uninstalling the JRE  

If the wrong version of the JRE is found, the Maui installation will first require that you 
to uninstall the JRE.  Follow the JREHelp.txt instructions provided by the Maui 
installation to uninstall the current JRE. 

2) Installing the JRE  

If no JRE is not found, the Maui installation will first require that you install the JRE. 
Follow the JRE installation instructions. When complete continue with the Maui 
installation Welcome step. 

3) Welcome: 

Select the [Next >] button to continue. 

4) Warning/Information:  

Select the [Next >] button to continue. 

5) User Information:  

Name: Accept the default, or enter another name; any name is valid. 

Company: Accept the default, or enter your company name. If blank, provide a 
company name. The installation will not continue without an entry in the field. 

Select the [Next >] button to continue. 

6) Choose the Destination Location: 

We strongly recommend accepting the default location (d:\MTWS).  Use the [Browse] 
button to select a different location.  Select the [Next >] button to continue. 

WARNING !! 

If you choose a location other than the default location, make sure to 
specify a drive and a target folder name, e.g., d:\myMTWS or 

c:\myMaui. 

Omission of the folder name along with the drive name can cause 
serious problems when reinstalling Maui at a future date because 

reinstalls remove the currently installed version starting at its installed 
folder.  If the installed folder is the root folder, ALL files in the root 

folder will be REMOVED!!! 
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7) Setup Type:  

NOTE 

DEFAULTS TO NO CART CLIENT INSTALLATION 

If you wish to install the CART Client application, you must select the 
[Custom] setup and then select the CART component.  The CART 

Client application is NOT installed under the [Typical] setup. 

 

NOTE 

NO TERRAIN GENERATOR INSTALLATION WHEN ONLY ONE 
HARD DRIVE 

Due to a limitation in the Terrain Generator software, if only one   
physical or logical hard drive is present on the target installation 

system, TerrGen will not be installed, otherwise it will, by default be 
installed on the same drive as the rest of the Maui Software Suite. 

Most users should select the [Typical] setup type.  If computer space is critically short, 
the [Compact] setup type can be selected.  

If you want to selectively install portions of the Maui software suite, select the 
[Custom] setup type. 

Custom will display a screen with the check boxes for the components.  

Select the [Next >] button to continue. 

Select the components you wish to install and deselect the components you wish to 
omit. 

Select the [Next >] button to continue. 

8) Setup Status:   

This screen should display the Setup Status list of files being installed as well as a 
status meter providing percent complete information. 

During the setup, the installation program will: 

- Install all required files for the selected MTWS applications 

- Set the appropriate file access attributes 

- Adds shortcut icons to the desktop and Start menu 
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9) Security Administrator Configuration window  

The Security Administrator Configuration interface allows you to set up the Security 
Administrator user name and password. The default Security Name is the user 
account name of the currently logged in user. It is advised that you use this default 
account name and enter in that account's password in the "Security Password" field 
and the "Confirm Password" field.  A ‘Security Administrator’ account name should 
be entered in if you require a different account (from the system administrator 
account) to administrator security related system operations.  If you choose a different 
user name, be sure it is a valid account name for the local computer and/or domain. 
The only way to modify the password is to know the original password or to reinstall 
Maui.  

See Appendix C for more information on Maui security administration. 

10) Selection of configuration options: 

A window will appear with checkbox options for the following: 

- Modify HOSTS 

- Check TEMP disk space 

- Check Maui log file usage (option available only for Maui) 

- Edit Maui resource data (option available only for Maui) 

- Setup Communications  (option available only for Apex and/or Maui) 

- Send Command Entry Rulefiles to the MSC 

- Display help on these options 

Select any, all, or none of these options. 

Select the [Next >] button to continue. 

NOTE 

If you select Display help on these options, a help window provides you 
with information about using these options.  The help window will not 

close on its own; the help window should be closed when no longer 
needed. 
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11) Modify HOSTS 

This option brings up the file: C:\WINNT\system32\drivers\etc\HOSTS in a text editor.  
This file must contain entries as specified in /etc/hosts or the Name Service Database in 
section 2. If the workstation will connect to the MSC (i.e., is not solely a CART client 
workstation), it must have an entry for the MSC. If the workstation is to be used as a 
CART client, it must have an entry for the CART server. 

12)  Check TEMP disk space 

This option brings up an Information window with the current System Environment 
Variable setting for TEMP, the disk usage for the all drives.  

Press the [OK] button.  

This will bring up a Change System TEMP Environment Variable dialog box. 

Press the [Yes] button to change the TEMP environment variable. 

If you select [Yes] the Selection of Maui configuration options window is displayed with 
the available drives for the TEMP directory with the current TEMP drive selected. 

Press the [Next>] button. 

This will bring up the System Properties interface, allowing you  to modify the TEMP 
environment variable via the environment tab. In the System Properties window, modify 
the TEMP and TMP variables by selecting the Environment tab.   

In the System Variables area, verify that the list includes a variable for TEMP and TMP.   

If it does not, create these variables by selecting any available variable from the System list 
and then modifying the name and value in the Variable and Value text field areas in the 
lower portion of the Environment tab.      

Then click the [Set] button in the Environment Tab.   

Also click on the [Apply] button at the bottom of the System Properties window. It is 
highly recommended that the TEMP and TMP System variables are both set to a folder 
called TEMP on a drive with at least 1GB of disk space that can be dedicated to Maui 
runtime swap space. This should be the drive on which Maui is installed. 

For example, if you have installed Maui on your 'D' drive, both TEMP and TMP variables 
should have a value of D:\TEMP. You do not need User Variables TEMP or TMP, but if 
they are defined, they should be set to the same drive as the TEMP and TMP System 
Variables. 
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NOTE 

After installing Maui, all other user accounts that may use Maui should 
be checked to see if they have TEMP and TMP User Variable settings 

defined.  If they are defined, make sure they are set to the same drive as 
the System Variable settings.  If they are not defined, the System 

Variables for TEMP and TMP will be used. 

 

13) Check Maui log file usage 

This option displays a window with the current log sub-folders. 

- Press the [Next >] button to delete all log sub-folders and files. 

- Press the [< Back] button to continue the installation without removing log files. 

14) Edit Resource Data 

Selecting this option will invoke the Resources Editor.  This tool provides you with a 
means to modify or view resource settings (also called key-value pairs). Key-value pairs 
with section labels in blue are modifiable, such as MSC hostname, Maui print definitions, 
and port settings. 

Key-value pairs with section labels in gray are read-only and provided primarily for 
information as to the file paths for data files used by Maui. It is strongly advised not to 
modify the MTWS\Maui\resources.dat file directly.  This could result in undesirable 
behaviors during execution of the software. 

 The following is a brief description of the modifiable fields: 

KEY Attribute Description 

MSC_HOSTNAME MSC001 Host name of MSC to which this 
workstation is connected. 

HIGH_SPEED_LINE_SERVER  Name of the server for the networked 
high speed printer. Default is no high 
speed printer, so no value is entered in 
for this key. 

HIGH_SPEED_LINE_PRINTER  Name of the printer for the networked 
high speed printer. Default is no high 
speed printer, so no value is entered in 
for this key. 

LINE_PRINTER_PORT LPT1 Port name for this local line printer. 
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LASER_PRINTER_ENABLED N A laser printer is accessible and 
enabled for this workstation (Y); or is 
not accessible/enabled (N). 

CLIENT_REMOTE_PORT 12753 TCP/IP port number. This value must 
match the ‘mtws’ entry in the 
/etc/services file on the MSC. See 
/etc/services in section 2. 

SERVER_LOCAL_PORT 12753 TCP/IP port number. This value must 
match the ‘mtws’ entry in the 
/etc/services file on the MSC. See 
/etc/services in section 2. 

MAPVIEWLIMIT 4 Maximum number of map windows 
(internal to the main map window) 
that can be displayed at one time.  As 
the number increases, workstation 
performance will decrease. 

MAX_REPORTS 10 Maximum number of solicited report 
windows that can be open at one time. 

MAX_SP_LINES 400 Number of lines displayed in Spot 
Report window before old reports fall 
off the top of the list. 

MAX_ALERT_LINES 1000 Number of lines displayed in Alert 
window before old alerts fall off the 
top of the list. 

ONLINE_TIMEOUT 20000 Number of milliseconds after which 
an attempt to go online to the MSC 
will timeout. 

OFFLINE_TIMEOUT 20000 Number of milliseconds after which 
an attempt to go offline from the MSC 
will timeout. 

TRANSMIT_TIMEOUT 120000 Number of milliseconds after which 
an attempt to receive a command or 
report request response will timeout. 

MAX_CE_WINDOWS 5 Maximum number of command entry 
forms that can be displayed at one 
time. 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

45 

MAX_MR_WINDOWS 5 Maximum number of solicited report 
request forms that can be displayed at 
one time. 

MAX_COC_REPORT_WINDOWS 2 Maximum number of chain-of-
command report windows that can be 
displayed at one time. 

MAX_RIGHT_CLICK_ITEMS 20 The maximum number of objects that 
can be accessed by a right-button 
mouse click. 

REUSE_BROWSER_WIN Y Use an open browser (Y), or open a 
new one (N), when starting a CART 
client report browser. 

SERVER_DATABASE jdbc:mysql://car
tserver/cart 

The database to which the CART 
client connects. 

USER cart The user name with which the CART 
client connects. 

MAX_CART_STEP 60 The number of minutes of data for 
which the CART client queries the 
server. Larger values result in higher 
memory utilization; smaller values 
result in slightly longer query times. 

 

NOTE 

This program is available only if you install Maui.   

After Maui is installed, this program can also be run from the shortcuts 
created at install time.  A shortcut is available for it in the MTWS Tools 

folder or from the Programs-> MTWS-> Maui -> Mau Resources 
Editor option from the Start menu. 

 

 

15) Setup Communications   
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This option is selected by default.  It runs Apex Login (if Apex is installed) and Maui 
Login (if Maui is installed) tools, which set up the Apex-to-MSC and Maui-to-MSC 
login/password files.  

Apex Login: 

When installing Apex without a networked MTWS suite available, click on the Cancel 
button and go to the next step. 

Use the default user name of soc and enter in the soc password for your site. This 
establishes the username/password dataset used by Apex for connectivity to the MSC as 
user soc. 

NOTE 

This program is run automatically only if you install Apex.   

After Apex is installed, this program can also be run from the shortcuts 
created at install time.  A shortcut is available for it in the MTWS Tools 

folder or from the Programs-> MTWS-> Apex -> Apex Login option 
from the Start menu. 

 

Maui Login: 

When installing Maui without a networked MTWS suite available, click on the Cancel 
button and go the next step.  Otherwise, use the default user name mds and enter in the 
mds password for your site. 

This establishes the username/password dataset used by Maui for connectivity to the MSC 
as user mds. 

NOTE 

This program is run automatically only if you install Maui. 

After Maui is installed, this program can also be run from the shortcuts 
created at install time.  A shortcut is available for it in the MTWS Tools 

folder or from the Programs-> MTWS-> Maui -> Maui Login option 
from the Start menu. 

 

16) Send Command Entry Rulefiles to the MSC 

Batch file conversion is required for this installation. Use the utility program, Send 
RuleFiles, to send the uncompressed rule files and command entry files to the MSC.  This 
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need only be run once to place the files on the MSC for the batch file conversion program 
to access. 

17)  Setup Complete: 

The installation program will then ask whether you wish to reboot your system. Select the 
[Yes, I want to restart my computer now.] radio button; then select the [Finish] button to 
reboot your machine. This insures a complete Maui installation and correct configuration. 

 

Section 4 - Parametric Data 

Following installation of the MAN, MSC, CART, and Maui software, baseline parametric 
data must be made available to the MAN and MSC software. If this installation is an 
upgrade from a previous version, all user-defined parametric data sets must be converted 
before they are usable by this version. 

Note that, because of their parametric data, pre-v3.0 exercises are incompatible with v3.0. 
Converting a pre-v3.0 parametric data set makes that data set compatible with v3.0; but 
pre-v3.0 exercises – i.e., those defined with parametric data prior to conversion to v3.0 – 
are still not compatible with v3.0. These exercises should be archived offline. Please 
contact MTWSHelp@titan.com for assistance in making a pre-v3.0 exercise compatible 
with v3.0.  

Baseline parametric data is a component of Apex. It is the data set with which Apex is 
installed. The following steps must be taken in order to make it available to the MAN and 
MSC applications. 

- Run Apex as administrator 

- Launch Apex from a shortcut on the desktop, the MTWS Tools folder, or 
the Programs -> MTWS -> Apex -> Apex option from the Start menu.   

- Select the Import/Export button from the main window.   

- Select the Send button from the Import/Export window  

- Select the ‘Apex Baseline to MSC Baseline’ option and click the  ‘OK’ 
button. 

- Click the ‘OK’ button in the (Warning! This function will overwrite the 
contents of your database!) dialog. 

- Wait for the delete, populate and extract background operations to 
complete and then click on the ‘Submit’ button in the Send (Apex 
Baseline to MSC Baseline) window.   
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- Click the ‘OK’ button in the Apex warning “Are you sure you want to 
overwrite the directory /mtws/db/parametric/baseline” message window. 

- In the “Send Apex Baseline to MSC Baseline” window, when the status 
bar displays the message, “Done sending files”, click the ‘Cancel’ button. 

 

The following steps must be taken in order to convert user-defined parametric data sets, so 
that they are useable by this version of MTWS. 

- Back up the entire /mtws/db/parametric/user_defined directory on the 
Linux side. 

- To insure a clean import, make sure the Inbox is empty. 

- On Apex, select Import/Export; select Retrieve. 

- In Apex’s Retrieve Dialog, select MSC User-defined to Apex Inbox; and 
from the pull-down menu, select the name of the parametric data set to be 
retrieved/converted.  

- Select Submit. 

- Select Populate. Use the pre-set Apex Inbox radio button, and click on 
OK. 

- On the Linux side, delete the contents of the parametric data directory 
being converted. 

- To insure a clean export, make sure the Outbox is empty. 

- Select Extract. Select OK, which extracts the database to Apex’s outbox. 

- Select Send. Use the pre-set Apex Outbox to user-defined radio button, 
and click on OK. 

- In the Send dialog, from the pull-down menu, select the name of the 
parametric data directory to which the data will be sent.  

- Select Submit. 

- Perform the above steps for each user-defined parametric data set. 

Depending upon the version of the data set being converted, a message may be displayed 
during the conversion process, indicating that one or more files are missing from the data 
set. If this happens, the corresponding v3.0 baseline data is substituted for the missing data. 
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When the conversion process is complete, a dialog is displayed, from which a Populate 
Report is available. This report identifies changes made to the data during the conversion 
process to make it compatible with v3.0. 

Only one parametric data set can reside in Apex at any point in time. Over time, users tend 
to create multiple versions of user-defined parametric data. MSC becomes the repository 
for these data sets. A user-defined data set can be created from BASELINE; or from 
another user-defined data set. The procedures described above for converting user-defined 
data sets for v3.0 compatibility use the same general procedures as those for creating or 
modifying a parametric data set. The following describes these procedures in general. 

Select  Import/Export->Retrieve on the main Apex screen to begin the process of bringing 
either baseline, or a user-defined, data set from the MSC to Apex. Once the desired data set 
is chosen, and the Submit button is selected, Apex begins the process of populating its 
“inbox” with the the data set. Once in Apex’s inbox, its database must be “populated” with 
the data; this is done via the Import/Export->Populate option on the main Apex screen.  
After Apex’s database has been populated, the data can be modified, reports can be 
obtained, etc. Once the desired modifications have been made, the data must be sent to the 
MSC, so that is can be used by the simulation. The first step in doing this is to “extract” the 
data to Apex’s outbox; this is done via the Import/Export->Extract option on the main 
Apex screen.  Once the data resides in Apex’s outbox, it can sent to the MSC, via the 
Import/Export->Send option on the main Apex screen. Note that this option supports over-
writing an existing data set; as well as creating a new data set. 

 

TIFF Map Files (*.tif) 

Once installed on the MSC, the TIFF map files can be downloaded from the MSC to the 
Maui Workstation. Using an FTP program on the workstations, ‘get’ the *.tif files from the 
/mtws/maps directory on the MSC and place them into the \MauiData\Maps\TIFF folder 
on the workstation.  These files are then immediately available for use by Maui.  For help 
on using FTP on a workstation, consult Windows Help. 

Terrain Data Files (*.trr) 

Once installed on the MSC, the TRR terrain files can be downloaded from the MSC to the 
Maui workstation. Using an FTP program on the workstation, ‘get’ the TRR files from the 
/mtws/db/terrain directory and subdirectories on the MSC; and place them into the 
\MauiData\Maps\TRR folder and corresponding subfolders on the workstation.  Once 
there, use the Elevator application to convert them to TIFF images, which can then be 
loaded into Maui.  The convention for files converted from TRR to TIFF is to place them 
into the  \MauiData\Maps\Elevation folder and corresponding subfolders.  For help on 
using FTP on a workstation, consult Windows Help. 
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Chapter 4 - Operating Procedures 

Material in this paragraph is presented from a functional perspective; it identifies the 
operations a system operator can perform and describes how to do them.  Generally, topics 
are discussed in the context of running an exercise from beginning to end. 

The following conventions apply throughout:  

a. The syntax "MenuItem  Sub-menuItem --> Sub-sub-menuItem -->..." means: 

1) MenuItem is visible on some (X-Windows) interface 

2) When MenuItem is selected with the cursor, Sub-menuItem becomes visible on the 
interface 

3) When Sub-menuItem is selected with the cursor, Sub-sub-menuItem becomes 
visible on the interface, and so on. 

b. Select means go to that menu item/button and click on it. 

c. Click on means position the cursor on the item/button and press the left mouse button. 

d. When the terms host, station, and workstation are used; they all mean computer. 

e. Tactical database means exercise entities created by the user by entry of commands 
(units, missions, etc.). 

f. Sysop means System Operations. 

Login Sequence 

At the login screen, enter soc for the user name. At the password prompt, enter the 
password for user soc that you have defined for your site. See Additional Operating 
System Configuration – MAN/MSC/CART, etc/passwd in Chapter 2,  

Specifying Mapping Datums 
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A file named /mtws/bin/MAN/sphere_config is used by MAN, MSC, and Maui software to 
control the conversion of geographic locations between latitude/longitude, and Military 
Grid Reference System (MGRS), coordinate systems. (MGRS is often mistakenly referred 
to as Universal Transverse Mercator (UTM) format. There are references throughout 
MTWS to “UTM”, which should properly be “MGRS”.) The following procedure 
determines whether locations within a given spheroid will be converted using WGS84 
mapping datum, or a local datum.  

 

This file is read by the MAN/MSC/Maui software at start-up time only. If any MTWS 
software is currently running, it must be shut down prior to performing this 
procedure.   

If not already logged into the MSC station, do so. Note that the MSC application software 
must not yet be started. Using a text editor, edit the file /mtws/bin/MAN/sphere_config.  
Note that there is a list of spheroid names, and a corresponding value for each. A value of 0 
(zero) means “use local datum”; a value of 1 (one) means “use WGS84 datum”.  For 
example, if the value for the Bessel spheroid is 1, and all other values are 0, locations 
within the Bessel spheroid will be converted using WGS-84 datum; and all other locations 
will be converted using their local datum. To determine the appropriate values for the 
relevant spheroids, examine the set of maps being used to support the exercise. Each map 
typically identifies the datum on which it is based. 

As installed, local datum is used for all spheroids – i.e., all values are 0. If this file is 
modified to support a particular exercise, consider making a copy of the modified file. This 
practice is recommended because this file is not exercise-specific. Making exercise-
specific copies of this file facilitates exercise management. For example, if an exercise is 
re-run several months after its initial run, and other exercises using other spheroid values 
have been run since then, the spheroid values used in the initial run can be easily restored. 
If this practice is followed, each copy of the sphere_config file should be kept in its 
corresponding exercise directory. The /mtws/bin/MAN/ directory is overwritten by a new 
installation; but the /mtws/db/man/… exercise directories are not overwritten. 

 

Starting MSC Software 

To initiate execution of the MSC software, perform the following steps. 

a. Log on to the MSC station as described above. 

b. If MTWS is to be run in a non-ALSP configuration, select the Start MTWS icon on 
the task bar. In an ALSP configuration, select the Start ALSP icon on the task bar. 

c.  Select System Control --> Admin --> Start MSC from the System Operations 
window to start the remaining MSC programs. 
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d. Wait for a response to appear in the System Operations window indicating that MSC 
has started. 

e. The Exercise Status  display will indicate that the MDS net is down; i.e., no MDS can 
communicate with any MSC or MAN host.  The MDS net can be enabled only after the 
Start Applications  step.  Refer to paragraph “MDS Interface”.   

f. Select the desired display/print reports features in the Station Control interface. 

Creating an Exercise 

To create a new exercise, perform the following steps. 

a. Start the MSC software as described above. 

b. Select Exercise Control --> Database --> Exercise --> Create from the System 
Operations window.  The exercise create interface will appear. 

c. Enter the desired exercise name , start time  and zone , parametric data set, and 
terrain area(s) in the templates provided. 

d. The values selected in step c can never be changed, except as described in paragraph 
“Saving an Exercise”.  If, at some later time, a different parametric data set or terrain 
values are desired, a separate exercise must be created. 

NOTE 

When creating an exercise for ALSP, use the baseline parametric 
database. This database is designed to support ALSP confederation 

exercises. 

e. To create the exercise, click on the Apply and Close button on the exercise create 
interface after all desired values have been entered in step c.  To abort the exercise 
creation, click on the Cancel and Close button instead. 

f. Wait for a response to appear in the System Operations window indicating that the 
exercise has been created. 

For discussion of another way to create an exercise, deriving one exercise from another, 
see paragraph “Saving an Exercise.” 

Starting or Restarting an Exercise 

To start an exercise, perform the following steps. 

a. Start the MSC software as described above. 

b. If desired, create an exercise as described above. 
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c. Select System Control --> Applications --> Load MAN from the System Operations 
window to begin execution of the MAN software on the desired host(s).  The MAN 
hostnames interface will appear with only valid hostnames selectable. 

d. Select the hostname(s) on which the MAN software is to run. 

e. Select the OK button in the System Operations window. 

f. Wait for response(s) to appear in the System Operations window indicating that the 
Load MAN step is complete each of the designated host(s).  There is one such response 
for each MAN.  The MAN monitors will remain at the login screen. 

g. Select Exercise Control --> Database --> Exercise --> Load.  The exercise load 
interface will appear. 

h. Select the desired exercise from those listed in the exercise load interface. 

i. Select the New, Start, Time, or End button in the exercise load interface.  If Time is 
chosen, enter the exercise time  at which the exercise is to be loaded.  The 
consequences of each choice are discussed individually in sections “Starting or 
Restarting and Exercise through Restarting an Exercise – End”.  If the exercise has 
never been loaded, New must be selected. 

j. Click on the OK button on the exercise load interface, confirming the choices made in 
step i.   

k. To abort the exercise load, click on the Cancel button on the exercise load interface. 

l. Inspect and verify the message displayed in the System Operations window identifying 
the exercise name and the New/Start/Time/End option chosen in steps h and i.  If any 
of information is incorrect, click on the Cancel button in the System Operations 
window. 

m. To load the exercise, click on the OK button on the System Operations window.  To 
abort the exercise load, click on the Cancel button on the System Operations window.  
If this option is chosen, steps (g) - (l) can be repeated. 

n. Wait for response(s) to appear in the System Operations window indicating that the 
exercise has been loaded on the MAN host(s) designated in step (d). 

o. Select System Control --> Applications --> Start App from the System Operations 
window to assign MAN functions to the desired host(s).  The application/host mapping 
interface will appear with a list of MAN hosts and a button for each application.  A 
default mapping of applications to MAN hosts is provided.  This default mapping is the 
recommended distribution for a typical land/sea/air exercise. 
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p. To change the host for a selected application, select the desired MAN host by clicking 
on the MAN host selector.  Once the MAN is selected, click on the application button 
for each application that is to run on the selected host. 

q. When an application button is selected, the hostname label corresponding to that button 
changes to reflect the selected host. 

r. Applications distribution should be selected to maximize CPU usage and minimize 
message traffic.  A slow running application should NOT necessarily be run on a 
separate host.  Metrics cycle times available from the MSC Status Window should be 
used as a measure to achieve the best overall performance for the exercise. 

s. If acceptable, select the OK button on the System Operations window.   

t. To abort the application start, click on the Cancel button on the System Operations 
window. 

u. Wait for response(s) to appear in the System Operations window indicating that the 
applications have started on the MAN host(s) designated in step d. 

v. At this point, Maui workstations can be allowed to connect to the MSC. Also, if data is 
going to be output to CART, it may be appropriate to start the CART server at this 
time. See Enabling the MDS Interface and Starting the CART Server sections 
below. 

w. If the New option was chosen in step i, establish the initial tactical database by entering 
commands and/or submitting batch files.   

1) Then select Exercise Control --> Database --> Exercise --> Initialize  from the 
System Operations window.   

2) Wait for a response to appear in the System Operations window indicating that 
exercise initialization is complete. 

x. Select Exercise Control --> Operation --> State --> Run from the System Operations 
window.   

1) This step must be performed or the database established in step v will be 
lost.   

2) Putting the system into RUN state causes the exercise database to be saved to a 
set of files in the exercise directory.  These files, and others like them, comprise 
the data set used to initialize the exercise in subsequent loads. 

Enabling the MDS Interface 

The MDS interface should be enabled after the System Control?Applications?Start 
App step has been completed, as described above. It cannot be enabled prior to this time. If 
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the exercise was loaded New, it is necessary to allow Maui workstations to come online, to 
enter commands to establish the exercise database. If the exercise was loaded at Start, 
Time, or End, then. Other than CART server considerations (see below), the exercise is 
ready to run, and Maui workstations should typically come online at this time. 

To enable the MDS interface, select System Control? Interfaces?MDS Net?Start. 
Note that the MDS interface icon on MSC’s exercise status window changes to relect the 
change in status. 

Starting the CART Server 

The CART server 

 

Starting Maui Display Station Software 

To initiate execution of the Maui MDS software, perform the following steps:   

a. Log on to the Maui Display Station. Once login has completed and the standard arrow 
cursor appears, the workstation is available for use. 

b.  Find the Maui icon on the desktop and double-click on it to start up the Maui software.  
Once the software startup is complete, the four default Maui windows should appear: 
Station Control, Exercise Status, Spot Reports, and the map window. 

c. In the Station Control window: 

-- Click on the User Privilege Level: 2 radio button. 

-- Enter the level 2 password in the template provided. 

-- If the MDS station is not to have level 2 privilege, click on the User Privilege 
Level: ...0 or User Privilege Level: 1 radio button, as appropriate. 

-- If the Line Printer has been configured via the Resources Editor tool, select the Print 
to Line Printer features desired. 

-- If the HSP has been configured via the Resources Editor tool, select the Print to 
HSP features desired. 

d. In the Spot Reports window: 

-- Select the Select Controllers  button. The Controller Selection window will appear 
with the list of available controllers. 

-- Select the controller(s) to be assigned to this MDS station. 

-- Click on the OK button on the controller names interface. 
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e. In the Maui map window: 

-- Select Object Filters  option from the Display Objects menu.  The Object Filters  
window will appear. 

-- Select the display settings desired for this display station. 

-- Click on the OK button in the Object Filters  window. 

f. In the Station Control window: 

-- If the MDS station is not to have level 2 privilege, click on the User Privilege 
Level: 0 radio button or User Privilege Level: 1 radio button, as appropriate. 

g. After the MSC software has been started, activate the Station Control window and 
click on the On/Offline: On button.  This action enables Maui communications with 
the MSC and with the exercise (MAN). 

 

Starting an Exercise - New 

When an exercise is loaded with the New option, only the parametric data and terrain 
specified at the time of exercise creation (see paragraph “Creating an Exercise”) are 
loaded; the exercise's entire tactical database (if any) is deleted.  In this context, "tactical 
database" refers to exercise entities created by the user through entry of commands -- units, 
missions, etc.  The exercise time is set to the exercise start time specified at the time of 
exercise creation. 

When an exercise is loaded with the New option, step v in paragraph “Starting or 
Restarting an Exercise” (database initialize) is required. 

New is the only valid way to load an exercise that has no tactical database. 

New is a convenient way to purge an exercise's tactical database while retaining its 
parametric data and terrain. 

Restarting an Exercise - Start 

When an exercise is loaded with the Start option, the parametric data and terrain specified 
at the time of exercise creation are loaded.  The portions of the exercise's tactical database 
that were established before entering the RUN state when the exercise was last run are also 
loaded; all other portions of the tactical database are deleted.  The exercise time is set to 
the exercise start time specified at the time of exercise creation. 

As an example, consider the following situation: 
¥ A new exercise is created; then 
¥ Steps a through u in paragraph “Starting or Restarting an Exercise” are performed; 
then 
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¥ A unit named UNIT_1 is defined; then 
¥ Steps v and w in paragraph “Starting or Restarting an Exercise” are performed; then 
¥ A unit named UNIT_2 is defined; then 
¥ The exercise is eventually terminated. 

 

If this exercise were then (re-)loaded using the Start option, the tactical database would 
consist of UNIT_1 only; UNIT_2 would be deleted. 

Loading an exercise with this option is one form of what is commonly known as a 
"restart". 

When an exercise is loaded with the Start option, step v in paragraph “Starting or 
Restarting an Exercise” (database initialize) is unnecessary and cannot be performed; the 
Exercise Control --> Database --> Exercise --> Initialize  menu selection is disabled in 
the System Operations window. 

Restarting an Exercise - Time 

When an exercise is loaded with the Time option, the parametric data and terrain specified 
at the time of exercise creation are loaded.  The portions of the exercise's tactical database 
that were established before the specified time are also loaded; all other portions of the 
tactical database are deleted.  The exercise time is set to the time specified during the 
exercise load operation (see 3.4.5, step i). 

NOTE 

Consult the Release Notes for the version being run for restart time 
constraints.  As of this writing, the time specified should be one hour 
plus 9, 19, 29, 39, 49 or 59 minutes (e.g., 13:29, 23:09,or 7:59) or an 

even ten minute interval.  The highest risk of restart failures occur with 
times ending in 7 or 8. 

 

THIS NOTE APPLIES TO ALL CASES 

Certain changes to parametric data -- in particular to 
/mtws/db/max_sizes -- may make an exercise unloadable.  Exercise load 
can fail if one or more definitions in para_data_max_sizes are smaller 

than the corresponding definition at the time the exercise database was 
first defined.  Using larger definitions than originally set in the exercise 

database does not cause a problem.  For an exercise to be restarted 
correctly, all values in /mtws/db/max_sizes should be equal to or 

greater than those used when the exercise was created. 

Restarting an Exercise - End 
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When an exercise is loaded with the End option, the parametric data and terrain specified 
at the time of exercise creation are loaded.  The entire tactical database that was established 
when the exercise was last run is also loaded.  The exercise time is set to one minute later 
than the time at which the exercise was terminated the last time it was run.  To understand 
why the exercise time is determined this way, suppose an exercise was terminated at 1015. 
When restarted at the end, events that happened at 1015 have already occurred, and are 
included in the restart. Therefore, the time must now be 1016. Loading an exercise with 
this option is one form of restart.    

WARNING: A restart at End should NOT be used if a graceful transition to SUSPEND 
mode and ADMIN state could not be performed.  In this case, a restart from a time at least 
10 minutes prior to the end should be used. 

When an exercise is loaded with the End option, step v in paragraph “Starting or Restarting 
an Exercise” (database initialize) is unnecessary and cannot be performed; the Exercise 
Control --> Database --> Exercise --> Initialize  menu selection is disabled in the System 
Operations window. 

Saving an Exercise 

Once an exercise has been loaded it may be saved.  This operation can be used to create a 
new exercise with the same characteristics as the loaded exercise, except that the start time 
of the new exercise will be the current exercise time.  To save the currently loaded 
exercise, perform the following steps: 

a. If the exercise is in RUN state, select Exercise Control --> Operation --> Mode  --> 
Suspend from the System Operations window. 

b. Select the OK button on the System Operations window. 

c. While the system is transitioning to Suspend mode, the MSC Status Window will flash 
a yellow SUSPEND.  When the mode displayed in the MSC Status Window transitions 
to a solid red SUSPEND, this indicates that the exercise has been suspended. 

d. Select Exercise Control --> Database --> Exercise --> Save from the System 
Operations window.  The exercise save interface will appear. 

e. Enter the name to be given to the saved exercise in the template provided on the 
exercise save interface. 

f. Select either the Overwrite or the Don't Overwrite option on the exercise save 
interface. 

NOTE 

if the name entered in step e is the same as the name of the loaded 
exercise and if Don't Overwrite is selected in step f, the command will be 

rejected. 
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g. Select the OK button on the System Operations window. 

h. Wait for a response to appear in the System Operations window indicating that the 
exercise has been saved. 

If the loaded exercise is saved under a different name, a new exercise is created with the 
same characteristics as the currently loaded exercise, except that the start time of the new 
exercise is set to the current exercise time.  If the loaded exercise is saved under the name 
of the currently loaded exercise and if the Overwrite option is selected, the start time of the 
(new) current exercise is changed to the current exercise time. 

Exercise States and Modes 

MTWS operates in three states -- Admin, Replay, and Run -- and two modes -- Suspend 
and Normal.  All operations described in sections “Creating an Exercise” and “Starting or 
Restarting an Exercise” take place in Admin state; this is the default/initial state of the 
system when the software is initiated.  See paragraph “Starting or Restarting an Exercise” 
(w) for the discussion of initial entry into Run/Normal. 

Suspending an Exercise 

To temporarily stop a running exercise, perform the following steps: 

a. Select Exercise Control --> Operation --> Mode --> Suspend from the System 
Operations window. 

b. Select the OK button on the System Operations window. 

c. While the system is transitioning to Suspend mode, the MSC Status Window will flash 
a yellow SUSPEND.  When the mode displayed in the MSC Status Window transitions 
to a solid red SUSPEND, this indicates that the exercise has been suspended. 

This action causes the exercise clock to stop advancing, which effectively stops exercise 
activity.  Note, however, that all exercise activity may not stop immediately after step c -- 
e.g., new alerts may continue to appear in the Alert Window on the MSC host for a short 
time (one minute or so) after this action has been performed.  This is normal and is due to 
the fact that some MAN software processing is cyclical; if the exercise is suspended while 
this software is in the middle of a cycle, exercise activity will not cease until the cycle is 
complete.  The transition of the MSC Status Window display to a solid red SUSPEND 
signifies the completion of all cycles. 

Resuming an Exercise 

To resume normal operation of a suspended exercise, perform the following steps: 

a. Select Exercise Control --> Operation --> Mode --> Resume  from the System 
Operations window. 

b. Select the OK button on the System Operations window. 
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c. Wait for a response to appear in the System Operations window indicating that the 
exercise has been resumed. 

d. Observe that alert(s) are displayed in the Alert Window on the MSC host that are 
generated by the MAN host(s) and that include the current exercise time. 

NOTE  

If there is not one such alert from each active MAN host, the 
resumption has failed.  In this case, it is probably necessary to put all 
MDS stations off-line (see paragraph “Controlling Interfaces”) and 

then perform a restart (see sections “Restarting an Exercise – Start" 
through “Restarting an Exercise – End"). 

. 

Manipulating the Exercise Clock 

The MTWS system operator has two ways to control the rate at which exercise time 
advances - Clock Advance and Clock Rate. Both are most useful for advancing rapidly 
through a portion of a running exercise (e.g., a part of the exercise of relatively little 
interest).  Clock Rate may also be used to run the exercise more slowly than normal. 

Clock Advance 

To advance the exercise clock, perform the following steps. 

a. Select Exercise Control --> Clock --> Advance from the System Operations window.  
The clock advance interface will appear. 

b. Enter the time to which the clock should advance in the clock advance interface 
template. 

c. To suspend the exercise when the specified time has been reached, select Suspend on 
the clock advance interface. 

d. To continue normal running of the exercise when the specified time has been reached, 
select Don't Suspend on the clock advance interface. 

e. Click on OK in the System Operations window. 

f. Wait for a response to appear in the System Operations window indicating that the 
clock advance has been accepted. 

The exercise time will be advanced as rapidly as possible to the specified time.  During this 
time, all exercise activity will continue without omissions.  When the specified time is 
reached, the clock rate is restored to the value it had before the Clock Advance operation. 

Clock Rate 
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To set the exercise clock advance rate, perform the following steps: 

a. Select Exercise Control --> Clock --> Rate from the System Operations window.  
The clock rate interface will appear. 

b. Select the desired clock rate on the clock rate interface. 

c. If desired, enter the duration for which the rate is to apply or the exercise time  at 
which the rate is to expire on the clock rate interface. 

NOTE 

This parameter is optional.  If it is omitted, the specified rate will 
remain in effect until the rate is set to a different value. 

d. Click on OK in the System Operations window. 

e. Wait for a response to appear in the System Operations window indicating that the 
clock rate has been accepted. 

The exercise time will be advanced at the specified rate for as long as specified.  During 
this time, all exercise activity will continue without omissions. 

Helpful Hints 

Clock Rate and Clock Advance have equal precedence; i.e., if both operations are 
performed, the last one performed overrides the first.  If a Clock Advance is done and 
followed by setting the Clock Rate to less than real-time, the exercise clock will advance at 
the rate specified in the Clock Rate operation.  If the Clock Rate operation is done first and 
followed by the Clock Advance, the exercise clock will advance as rapidly as possible. 

Controlling Engagements 

The system operator can suspend or resume an individual direct fire engagement.   

Before performing these operations, the operator must obtain the identifier of the 
engagement from the relevant spot report(s) or from the ground engagement status 
solicited report. 

While a direct fire engagement is suspended, no weapons are fired and no ammunition is 
expended.  However, ground movements will continue and units may still join or leave the 
engagement. 

Suspending Engagements 

To suspend an engagement, perform the following steps: 

a. Select Exercise Control --> Engagement --> Suspend from the System Operations 
window.  The engagement suspend interface will appear. 
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b. Enter the ID of the engagement. 

c. If desired, enter the duration for which the engagement is to be suspended. 

NOTE 

This parameter is optional.  If it is omitted, the engagement will remain 
suspended until an engagement resume operation is performed. 

d. Click on OK in the System Operations window. 

e. Wait for a response to appear in the System Operations window indicating that the 
engagement suspension has been accepted. 

Resuming Engagements 

To resume an engagement, perform the following steps: 

a. Select Exercise Control --> Engagement --> Resume  from the System Operations 
window.  The engagement resume interface will appear. 

b. Enter the ID of the engagement. 

c. Click on OK in the System Operations window. 

d. Wait for a response to appear in the System Operations window indicating that the 
engagement resume has been accepted. 

Controlling Interfaces 

The system operator has control over the state of the MDS network interfaces, and the HSP 
interface.  This paragraph discusses operations to control the states of these interfaces.  See 
paragraph “MAN/MDS Hosts On-Line” for discussion of operations to view the status of 
these interfaces. 

The MDS interface must be enabled for an MDS station to communicate with the MSC.  
When the MSC software is started, the MDS net is disabled.  The MAN net is always 
enabled when the MSC is running. 

MDS Interface 

The MDS interface is disabled whenever an exercise is being loaded.  When the MAN 
applications have been started, this interface should be enabled. 

The MDS interface should be disabled whenever is it necessary to restart the MSC and 
MAN software.  The MDS interface will be automatically disabled if the MSC is shutdown 
or restarted. 

Disable MDS Interface 
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To disable the MDS interface, perform the following steps: 

a. Select System Control --> Interfaces --> MDS Net --> Halt from the System 
Operations window. 

b. Click on OK in the System Operations window. 

c. Wait for a response to appear in the System Operations window indicating that the 
interface has been halted. 

d. Observe that the MSC Status Window (or the MSC Connections window) shows no 
users on-line. 

Enable MDS Interface 

To enable the MDS interface, perform the following steps: 

a.  Select System Control --> Interfaces --> MDS Net --> Start from the System 
Operations window. 

b.  Click on OK in the System Operations window. 

c.  Wait for a response to appear in the System Operations window indicating that the 
interface has been started. 

Enabling this interface does not cause MDS stations to be put on-line.  Once this interface 
is enabled, each MDS station must be put on-line individually as described in 3.4.3.4(g). 

MAN Interface 

As there is no reason to ever disable this interface, no mechanism is provided for doing so. 

High-Speed Printer Interface 

Enable HSP Interface 

To enable the HSP interface, perform the following steps: 

a. Select System Control --> Interfaces --> HSP --> Resume  from the System 
Operations window. 

b. Click on OK in the System Operations window. 

c. Wait for a response to appear in the System Operations window indicating that the 
interface has been enabled. 

Disable HSP Interface 

To disable the HSP interface, perform the following steps: 
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a. Select System Control --> Interfaces --> HSP --> Suspend from the System 
Operations window. 

b. Click on OK in the System Operations window. 

c. Wait for a response to appear in the System Operations window indicating that the 
interface has been disabled. 

Clear HSP Print Queue 

To clear all pending print jobs from the HSP print queue, perform the following steps: 

a.  Select System Control --> Interfaces --> HSP --> Clear from the System Operations 
window. 

b.  Click on OK in the System Operations window. 

c.  Wait for a response to appear in the System Operations window indicating that the 
interface has been cleared. 

Manipulating Terrain 

Several operations are available to the system operator to manipulate the digitized terrain 
for an exercise.  Note that these operations are in addition to the terrain definition portion 
of the exercise definition operation (see paragraph “Creating an Exercise”). 

Digitized Terrain Data 

Digitized terrain data was obtained from the National Imagery and Mapping Agency 
(NIMA).  The raw data contains elevation and terrain features and is in two formats: 
Digital Terrain Elevation Data (DTED) and Digital Feature Analysis Data (DFAD).   

The raw data (elevation and terrain features) are then converted to elevation, trafficability 
and vegetation values in each 3-second (3") terrain data element.  See Appendix A for 
conversion procedures. 

The distance between adjacent lines of longitude is greatest near the equator, and 
diminishes toward the poles.  Therefore, terrain data resolution is least near the equator. 

a. From the equator to 50º, resolution is 3" latitude x 3" longitude. 

b. From 50º to 70º, resolution is 3" x 6".  

c. From 70º to 80º, resolution is 3" x 9".  

d. From 80º to 90º, resolution is 3" x 12".  

MTWS terrain files normally contain data cells 1º latitude by 1º longitude or 1200 x 1200 
elements using 3" resolution.  One file corresponds to 1.44 million terrain data points.   
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Any given exercise can incorporate data from several files that are loaded into memory.  
Up to 20 1º x 1º digitized terrain areas can be loaded, each of which is specified by two 
pairs of coordinates bounding the selected area.  The system responds by loading the 
corresponding 1º x 1º files.   

MTWS is required to run in real time; it is recommended that no more than four million 
terrain data points be resident in memory at any given time.  This is equivalent to 
approximately 200 by 200 kilometers at 100-meter resolution. 

In addition to the digitized terrain areas, the computer system operator can define tabletop 
terrain areas, areas with constant values of elevation, trafficability and vegetation.  
Procedures to define these tabletop terrain areas are described in paragraph 
“Loading/Removing Tabletop Terrain.”   

If non-contiguous areas (specific digitized terrain areas and/or tabletop areas) are specified, 
the system uses default terrain data for the unspecified areas.  Default terrain data can be 
modified as required by using the procedure for modifying functional parametric data. 

The MTWS system allows a maximum of 20 terrain areas to be loaded in memory at any 
given time; these can be any combination of specific digitized terrain areas and table-top 
areas; e.g., eight specific digitized areas and 12 tabletops.  If both digitized and tabletop 
terrain are specified for a location, the digitized data will override the tabletop data.  
Digitized terrain areas may occupy less disk space but will occupy the number of cells in a 
finite information table as tabletop areas. 

The 3" latitude resolution data from 0 to 90º can be pre-processed in MTWS to provide 
additional lower resolution files of 6" x 6" and 9" x 9".  This provides the system operator 
with the option of loading in various resolutions.  Resolution levels are referenced in the 
MTWS commands as High, Medium and Low, corresponding to 3" x 3", 6" x 6" and 9" x 
9" resolutions, respectively.  Lower resolution data may be used when high resolution is 
not required or desired.   

Under certain circumstances, this may also have the effect of speeding up the system under 
heavy loading conditions.  In general, use of lower resolution files should be considered 
when more than five digitized terrain areas are to be loaded.  At 6" resolution, memory 
requirements are half that for 3" resolution; at 9" resolution, memory requirements are one-
third. 

Refer to Appendix A for terrain generation procedures. The terrain data can also be 
installed on a Maui Workstation for use with the Elevator utility. Once installed on the 
MSC, an FTP program can be run from a Maui Workstation to access and download these 
MSC resident files.  For help on using FTP on a Maui Workstation, consult the Windows 
Help from the Start menu. 

 

Loading Terrain 
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To load one or more terrain areas, perform the following steps: 

a. Select Exercise Control --> Database --> Terrain --> Load from the System 
Operations window.  The terrain load interface will appear. 

b. Select Low -, Medium -, or High-Resolution from the terrain load interface. 

c. Enter at least one pair of coordinates in the template provided in the terrain load 
interface. 

d. Click on OK in the System Operations window. 

e. Wait for a response to appear in the System Operations window indicating that the 
terrain definition has been accepted. 

Removing Terrain 

Terrain areas can also be removed.  When terrain is removed from an area, that area reverts 
to the tabletop values defined in the parametric data for the exercise. 

To remove one or more terrain areas, perform the following steps: 

a. Select Exercise Control --> Database --> Terrain --> Remove from the System 
Operations window.  The terrain remove interface will appear. 

b. Select Low -, Medium -, or High Resolution from the terrain remove interface. 

c. Enter at least one pair of coordinates in the template provided in the terrain remove 
interface. 

d. Click on OK in the System Operations window. 

e. Wait for a response to appear in the System Operations window indicating that the 
terrain removal has been accepted. 

Loading/Removing Tabletop Terrain 

The system operator can assign tabletop characteristics to a specified area. Tabletop means 
that all terrain points within the specified area have the same trafficability, cover, and 
elevation.   

NOTE 

Tabletop values defined by this operation can differ from those defined 
in the parametric data for the exercise. 

To assign tabletop values to a terrain area or to restore an area's terrain values to those 
defined in the parametric data for the exercise, perform the following steps: 
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a. Select Exercise Control --> Database --> Terrain --> TableTop from the System 
Operations window. 

The tabletop terrain interface will appear. 

b. Enter the locations and the action (LOAD or REMOVE) to be performed. 

NOTE 

If the REMOVE option is chosen, proceed to step (f).  As a result of the 
REMOVE, the trafficability, cover, and elevation values for the region 

revert to the tabletop values defined in the parametric data for the 
exercise. 

c. Enter the elevation to be assigned to all points within the region defined by the 
specified locations. 

d. For each type of trafficability to be defined, select a trafficability value  from those 
provided.  Then click on the button(s) for each type of trafficability (foot, tracked, 
wheeled) which is to have the selected value.   

NOTE 

When a button is clicked, the label corresponding to that button 
displays the selected trafficability value. 

e. For each type of cover to be defined, select a cover value  from those provided.  Then 
click on the button(s) for each type of cover (air, ground) which is to have the selected 
value.   

NOTE 

When a button is clicked, the label corresponding to that button 
displays the selected cover value. 

f. Click on OK in the System Operations window. 

g. Wait for a response to appear in the System Operations window indicating that the 
tabletop terrain load/remove has been accepted. 

Monitoring an Exercise 

The system operator has access to several exercise monitoring operations. 

Application Assignment 

To obtain a report identifying which MAN applications are running on each MAN host, 
perform the following steps: 
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a.  Select System Control --> Applications  --> Assignment Report from the System 
Operations window. 

b.  Click on OK in the System Operations window. 

Note that the information in this report can also be obtained from the Exercise Status 
window on the MSC host. 

MAN/MDS Hosts On-Line 

To determine which MAN or MDS hosts are on-line, perform the following steps: 

a.  Select the Users Online button on the MSC Status window.  This will display the 
Connections window which will display a graph of all open connections. 

Terrain Status 

To obtain a report identifying the area(s) for which digitized terrain has been loaded, 
perform the following steps: 

a.  Select Exercise Control --> Database --> Terrain --> Report from the System 
Operations window. 

b.  Click on OK in the System Operations window. 

A window will appear in which the coordinates of the lower-left and upper-right corner(s) 
of each area for which digitized terrain has been loaded are displayed. 

Controller Assignment 

To obtain a report identifying the controller(s) assigned to each MDS and MSC host, 
perform the following steps: 

a.  Select Exercise Control --> Controller --> Assignment Report from the System 
Operations window. 

b.  Click on OK in the System Operations window. 

A window will appear which displays the name of each controller and the host(s) to which 
each is assigned. 

Exercise Definition Summaries 

Summary Report of Exercise Definition Parameters  

To obtain a summary report of the exercise definition parameters (except terrain) for all 
defined exercises, perform the following steps. 

a. Select Exercise Control --> Database --> Exercise --> Summary Report from the 
System Operations window. 
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b. Click on OK in the System Operations window. 

A window will appear which displays, for each exercise residing on the system, the 
exercise name, start time and zone, and parametric data set identifier. 

Summary Report of Terrain Parameters for Defined Exercises 

To obtain a summary report of the terrain parameters for all defined exercises, perform the 
following steps. 

a. Select Exercise Control --> Database --> Exercise --> Terrain Report from the 
System Operations window. 

b. Click on OK in the System Operations window. 

A window will appear which displays, for each exercise residing on the system, the 
exercise name and the terrain values defined at the time the exercise was defined. 

 

Operating with the Joint Training Confederation 

Configuring MTWS/ALSP Mapping Tables 

When MTWS is to run in ALSP mode, the MTWS-to-ALSP and ALSP-to-MTWS 
enumerations mapping tables should be updated.  These tables allow the ALSP simulations 
to agree on the definition for defined objects.  MTWS is delivered with tables derived from 
the BASELINE parametric data set.  The database builder should find out which ALSP 
enumeration list will be used for their particular exercise.  If the proper ALSP enumeration 
list is unknown, the latest ALSP enumeration list can be downloaded at 
http://ms.ie.org/alsp. 

The translation tables may be found in directory /mtws/bin/ALSP/tables.  Generally, you 
can ignore the following tables because they don't change very often:  

CAPABLE_STATUS.AtoM CAPABLE_STATUS.MtoA 

FLIGHT_OPS.AtoM  FLIGHT_OPS.MtoA 

FORMATION.AtoM  FORMATION.MtoA 

MISSION.AtoM   MISSION.MtoA 

POSTURE.AtoM   POSTURE.MtoA 

ROLE.AtoM   ROLE.MtoA 

SIDE.AtoM   SIDE.MtoA 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

70 

SIZE.AtoM   SIZE.MtoA 

STATUS.AtoM   STATUS.MtoA 

TARGETS.AtoM   TARGETS.MtoA 

TYPE-Fuel.MtoA 

In all mapping files, if a “#” (pound/number symbol) appears in the first column of the 
line, it is a comment and is not an entry.  No blank lines may appear in the files, otherwise 
the rest of the entries will be ignored.  Each valid entry MUST start with a tab and is 
delimited by a tab.  If a “/” is part of the mapping or starts with a period (.), the quote (“) 
character must surround the mapping.  For example: 

# This is a comment. 

# tab     tab 

#  |      | 

#  V      V 

 MTWS_MAPPING ALSP_MAPPING 

 “MTWS/ALSP”  “.ALSP” 

# end of file 

 

 

Note 

Files starting with “PD_” or ending with “.TXT” can be found in the 
/mtws/db/parametric/user_defined/<para data file set> directory. 

The AMMO_TO_WEAPON file contains look-up values for MTWS ammunition and 
weapon dependencies.  Multiple weapons can fire the same ammunition.  The entire list in 
the PD_Ammo_IDs file should be in the left column of this file.  The right column should 
contain the proper weapon that can fire the ammunition.  A listing can be found in the 
WEPNB.TXT file. 

The EMITTER-AIRCRAFT.MtoA file contains look-up values for the TYPE field of the 
MTWS "EMITTER" attribute in the "AIR" class.  Since MTWS does not specify which 
emitter is associated with a particular aircraft, this file provides the information for 
transmission to ALSP. The entire list in the PD_Aircraft_Type_IDs file should be in the 
left column of this file.  The right column should contain the proper emitter enumeration 
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from the ALSP enumerations list for object class AIR.FIXEDWING, AIR.HELICOPTER, 
AIR.CRUISE_MISSILE of attribute EMITTER.RADAR.TYPE. 

The EMITTER-ALLRAD.MtoA file contains look-up values for the TYPE field of the 
MTWS "EMITTER" attribute in the "GROUND.MANEUVER.ALLRAD" class.  The 
source file for the left column is the PD_PAR_Radar_IDs file.  All shipboard radars should 
be removed.  The right column should contain the proper emitter enumeration from the 
ALSP enumeration list for object class GROUND.MANEUVER.ALLRAD of attribute 
EMITTER.RADAR.TYPE. 

The EMITTER-SHIP.MtoA file contains look-up values for the TYPE field of the MTWS 
"EMITTER" attribute in the "SEA.SURFACE.SHIP" class.  The source file for the left 
column is the PD_PAR_Radar_IDs file.  All non-shipboard radars should be removed.  
The right column should contain the proper emitter enumeration from the ALSP 
enumeration list for object class SEA.SURFACE.SHIP of attribute 
EMITTER.RADAR.TYPE. 

The UNIT_EQUIPMENT.AtoM file contains look-up values for the ALSP 
“UNIT_EQUIPMENT” attribute in the “GROUND.MANEUVER.COMBAT” class.  The 
source information for the left column is the ALSP enumeration list for object class 
GROUND.MANEUVER.COMBAT of attribute UNIT_EQUIPMENT.TYPE.  The right 
column should contain the proper asset from the PD_Asset_IDs and 
PD_Aircraft_Type_IDs files. 

The UNIT_EQUIPMENT.MtoA file contains look-up values for the MTWS 
“UNIT_EQUIPMENT” attribute in the “GROUND.MANEUVER.COMBAT” class.  The 
source file for the left column is the PD_Aircraft_Type_IDs and PD_Asset_IDs files.  For 
the PD_Asset_IDs file, only the following heading need to be mapped:  Amphibious, 
Armored, Arty (Self-Propelled and Towed), Mobile Rocket Launchers, Transporter 
Erector Launchers, Radars, Tanks Vehicles, Weapons (Mortars, Infantry Weapons, 
Antitank Dumb Weapons, Antitank Guided Missiles, Surface-to-Surface Missiles and 
Surface-to-Air Missiles) and “TROOPS”.  The right column should contain the proper 
asset enumeration from the ALSP enumeration list for object class 
GROUND.MANEUVER.COMBAT of attribute UNIT_EQUIPMENT.TYPE. 

The UNITTYPE-AD.MtoA file contains translation information for the MTWS 
"UNIT_TYPE" attribute in the "GROUND.MANEUVER.ALLRAD" and 
"GROUND.MANEUVER.SHORAD" class.  The source file for the left column is the 
PD_Asset_IDs file.  Only the assets listed under “Weapons - Surface-to-Air Missiles” need 
to be mapped.  The right column should contain the proper asset enumeration from the 
ALSP enumeration list for object class GROUND.MANEUVER.ALLRAD of attribute 
UNIT_TYPE. 

The UNITTYPE-CM.AtoM file contains look-up values for the ALSP “UNIT_TYPE” 
attribute in the “AIR.CRUISE_MISSILE” class.  The source information for the left 
column is the ALSP enumeration list for object class AIR.CRUISE_MISSILE of attribute 
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UNIT_TYPE.  The right column should contain the proper asset from the PD_Asset_IDs 
under the heading “Cruise Missiles”. 

The UNITTYPE-CM.MtoA file contains translation information for the MTWS 
"UNIT_TYPE" attribute in the "AIR.CRUISE_MISSILE" class.  The source file for the 
left column is the PD_Asset_IDs file.  Only the assets listed under “Cruise Missiles” need 
to be mapped.  The right column should contain the proper asset enumeration from the 
ALSP enumeration list for object class AIR.CRUISE_MISSILE of attribute UNIT_TYPE. 

The UNITTYPE-FIXEDWING.AtoM file contains look-up values for the ALSP 
“UNIT_TYPE” attribute in the “AIR.FIXED_WING” class.  The source information for 
the left column is the ALSP enumeration list for object class AIR.FIXED_WING of 
attribute UNIT_TYPE.  The right column should contain the proper asset from the 
PD_Aircraft_Type_IDs. 

The UNITTYPE-FIXEDWING.MtoA file contains translation information for the MTWS 
"UNIT_TYPE" attribute in the "AIR.FIXED_WING" class.  The source file for the left 
column is the PD_Aircraft_Minus_CMs_IDs file.  Only fixed-wing assets need to be 
mapped.  The right column should contain the proper asset enumeration from the ALSP 
enumeration list for object class AIR.FIXED_WING of attribute UNIT_TYPE. 

The UNITTYPE-HELO.AtoM file contains look-up values for the ALSP “UNIT_TYPE” 
attribute in the “AIR.HELICOPTER” class.  The source information for the left column is 
the ALSP enumeration list for object class AIR.HELICOPTER of attribute UNIT_TYPE.  
The right column should contain the proper asset from the PD_Aircraft_Type_IDs. 

The UNITTYPE-HELO.MtoA file contains translation information for the MTWS 
"UNIT_TYPE" attribute in the "AIR.HELICOPTER" class.  The source file for the left 
column is the PD_Aircraft_Minus_CMs_IDs file.  Only rotary-wing assets need to be 
mapped.  The right column should contain the proper asset enumeration from the ALSP 
enumeration list for object class AIR.HELICOPTER of attribute UNIT_TYPE. 

The UNITTYPE-SHIP.AtoM file contains look-up values for the ALSP “UNIT_TYPE” 
attribute in the “SEA.SURFACE.SHIP” class.  The source information for the left column 
is the ALSP enumeration list for object class SEA.SURFACE.SHIP of attribute 
UNIT_TYPE.  The right column should contain the proper asset from the 
PD_Aircraft_Type_IDs under the heading “Ships”. 

The UNITTYPE-SHIP.MtoA file contains translation information for the MTWS 
"UNIT_TYPE" attribute in the "SEA.SURFACE.SHIP" class.  The source file for the left 
column is the PD_Asset_IDs file.  Only the assets listed under “Ships” need to be mapped.  
The right column should contain the proper asset enumeration from the ALSP enumeration 
list for object class SEA.SURFACE.SHIP of attribute UNIT_TYPE. 

The UNITTYPE-TBM.AtoM file contains look-up values for the ALSP “UNIT_TYPE” 
attribute in the “AIR.TBM” class.  The source information for the left column is the ALSP 
enumeration list for object class AIR.TBM of attribute UNIT_TYPE.  The right column 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

73 

should contain the proper asset from the PD_Asset_IDs under the heading “Cruise 
Missiles”. 

The WEAPON-AirToAir.AtoM file contains look-up values for the ALSP “WEAPON” 
parameter in the “ENGAGEMENT.AIR_TO_AIR” interaction.  The source information 
for the left column is the ALSP enumeration list for interaction parameter 
ENGAGEMENT.AIR_TO_AIR of parameter WEAPON.  The right column should 
contain the proper air-to-air ammunition from the PD_Ammo_IDs file under the “Ammo” 
heading. 

The WEAPON-AirToAir.MtoA file contains translation information for the MTWS 
"WEAPON" attribute in the " ENGAGEMENT.AIR_TO_AIR " interaction.  The source 
file for the left column is the PD_Asset_IDs file.  Only the air-to-air assets listed under 
“Ammo” need to be mapped.  The right column should contain the proper asset 
enumeration from the ALSP enumeration list for interaction parameter 
ENGAGEMENT.AIR_TO_AIR of parameter WEAPON. 

The WEAPON-AirToSurface.AtoM file contains look-up values for the ALSP 
“WEAPON” parameter in the “ENGAGEMENT.AIR_TO_GROUND” interaction.  The 
source information for the left column is the ALSP enumeration list for interaction 
parameter ENGAGEMENT.AIR_TO_GROUND of parameter WEAPON.  The right 
column should contain the proper air-to-surface ammunition from the PD_Ammo_IDs file 
under the “Ammo” heading. 

The WEAPON-AirToSurface.MtoA file contains translation information for the MTWS 
"WEAPON" attribute in the " ENGAGEMENT.AIR_TO_GROUND " interaction.  The 
source file for the left column is the PD_Asset_IDs file.  Only the air-to-surface assets 
listed under “Ammo” need to be mapped.  The right column should contain the proper 
asset enumeration from the ALSP enumeration list for interaction parameter 
ENGAGEMENT.AIR_TO_GROUND of parameter WEAPON. 

The WEAPON-GrdToAir.AtoM file contains look-up values for the ALSP “WEAPON” 
parameter in the “ENGAGEMENT.GROUND_TO_AIR” interaction.  The source 
information for the left column is the ALSP enumeration list for interaction parameter 
ENGAGEMENT.GROUND_TO_AIR of parameter WEAPON.  The right column should 
contain the proper surface-to-air ammunition from the PD_Ammo_IDs file under the 
“Ammo” heading. 

The WEAPON-GrdToAir.MtoA file contains translation information for the MTWS 
"WEAPON" attribute in the " ENGAGEMENT.GROUND_TO_AIR " interaction.  The 
source file for the left column is the PD_Asset_IDs file.  Only the ground-based air 
defense listed under “Weapons – Surface-to-Air Missiles” need to be mapped.  The right 
column should contain the proper asset enumeration from the ALSP enumeration list for 
interaction parameter ENGAGEMENT.GROUND_TO_AIR of parameter WEAPON. 

The WEAPON-GrdToGndArty.AtoM file contains look-up values for the ALSP 
“WEAPON” parameter in the 
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“ENGAGEMENT.GROUND_TO_GROUND.ARTILLERY” interaction.  The source 
information for the left column is the ALSP enumeration list for interaction parameter 
ENGAGEMENT.GROUND_TO_GROUND.ARTILLERY of parameter WEAPON.  The 
right column should contain the proper land-based indirect ammunition from the 
PD_Ammo_IDs file under the “Ammo” heading. 

The WEAPON-GrdToGndArty.MtoA file contains translation information for the MTWS 
"WEAPON" attribute in the " ENGAGEMENT.GROUND_TO_GOUND.ARTILLERY " 
interaction.  The source file for the left column is the PD_Asset_IDs file.  Only the land-
based indirect ammunition listed under “Ammo” need to be mapped.  The right column 
should contain the proper asset enumeration from the ALSP enumeration list for 
interaction parameter ENGAGEMENT.GROUND_TO_GROUND.ARTILLERY of 
parameter WEAPON. 

The WEAPON-GrdToGndCC.AtoM file contains look-up values for the ALSP 
“WEAPON” parameter in the 
“ENGAGEMENT.GROUND_TO_GROUND.CLOSE_COMBAT” interaction.  The 
source information for the left column is the ALSP enumeration list for interaction 
parameter ENGAGEMENT.GROUND_TO_GROUND.CLOSE_COMBAT of parameter 
WEAPON.  The right column should contain the proper direct-fire ammunition from the 
PD_Ammo_IDs file under the “Ammo” heading. 

The WEAPON-GrdToGndCC.MtoA file contains translation information for the MTWS 
"WEAPON" attribute in the " 
ENGAGEMENT.GROUND_TO_GOUND.CLOSE_COMBAT " interaction.  The source 
file for the left column is the PD_Asset_IDs file.  Only the direct-fire ammunition listed 
under “Ammo” need to be mapped.  The right column should contain the proper asset 
enumeration from the ALSP enumeration list for interaction parameter 
ENGAGEMENT.GROUND_TO_GROUND.CLOSE_COMBAT of parameter WEAPON. 

The WEAPON-GrdToShp.AtoM file contains look-up values for the ALSP “WEAPON” 
parameter in the “ENGAGEMENT.GROUND_TO_SHIP” interaction.  The source 
information for the left column is the ALSP enumeration list for interaction parameter 
ENGAGEMENT.GROUND_TO_SHIP of parameter WEAPON.  The right column should 
contain the proper indirect ammunition from the PD_Ammo_IDs file under the “Ammo” 
heading. 

The WEAPON-GrdToShp.MtoA file contains translation information for the MTWS 
"WEAPON" attribute in the " ENGAGEMENT.GROUND_TO_SHIP " interaction.  The 
source file for the left column is the PD_Asset_IDs file.  Only the indirect ammunition 
listed under “Ammo” need to be mapped.  The right column should contain the proper 
asset enumeration from the ALSP enumeration list for interaction parameter 
ENGAGEMENT.GROUND_TO_SHIP of parameter WEAPON. 

The WEAPON-ShpToAir.AtoM file contains look-up values for the ALSP “WEAPON” 
parameter in the “ENGAGEMENT.SHIP_TO_AIR” interaction.  The source information 
for the left column is the ALSP enumeration list for interaction parameter 
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ENGAGEMENT.SHIP_TO_AIR of parameter WEAPON.  The right column should 
contain the proper surface-to-air ammunition from the PD_Ammo_IDs file under the 
“Ammo” heading. 

The WEAPON-ShpToAir.MtoA file contains translation information for the MTWS 
"WEAPON" attribute in the " ENGAGEMENT.SHIP_TO_AIR " interaction.  The source 
file for the left column is the PD_Asset_IDs file.  Only the ship-based air defense listed 
under “Weapons – Surface-to-Air Missiles” need to be mapped.  The right column should 
contain the proper asset enumeration from the ALSP enumeration list for interaction 
parameter ENGAGEMENT.SHIP_TO_AIR of parameter WEAPON. 

The WEAPON-ShpToGrd.AtoM file contains look-up values for the ALSP “WEAPON” 
parameter in the “ENGAGEMENT.SHIP_TO_GROUND” interaction.  The source 
information for the left column is the ALSP enumeration list for interaction parameter 
ENGAGEMENT.SHIP_TO_GROUND of parameter WEAPON.  The right column should 
contain the proper ship-based indirect ammunition from the PD_Ammo_IDs file under the 
“Ammo” heading. 

The WEAPON-ShpToGrd.MtoA file contains translation information for the MTWS 
"WEAPON" attribute in the " ENGAGEMENT.SHIP_TO_GOUND " interaction.  The 
source file for the left column is the PD_Asset_IDs file.  Only the ship-based indirect 
ammunition listed under “Ammo” need to be mapped.  The right column should contain 
the proper asset enumeration from the ALSP enumeration list for interaction parameter 
ENGAGEMENT.SHIP_TO_GROUND of parameter WEAPON. 

The WEAPON-ShpToShp.AtoM file contains look-up values for the ALSP “WEAPON” 
parameter in the “ENGAGEMENT.SHIP_TO_SHIP” interaction.  The source information 
for the left column is the ALSP enumeration list for interaction parameter 
ENGAGEMENT.SHIP_TO_SHIP of parameter WEAPON.  The right column should 
contain the proper ship-based indirect ammunition from the PD_Ammo_IDs file under the 
“Ammo” heading. 

The WEAPON-ShpToShp.MtoA file contains translation information for the MTWS 
"WEAPON" attribute in the " ENGAGEMENT.SHIP_TO_SHIP " interaction.  The source 
file for the left column is the PD_Asset_IDs file.  Only the ship-based indirect ammunition 
listed under “Ammo” need to be mapped.  The right column should contain the proper 
asset enumeration from the ALSP enumeration list for interaction parameter 
ENGAGEMENT.SHIP_TO_SHIP of parameter WEAPON. 

Decoding MTWS TEMPLATE_NAME Sent Over ALSP 

The purpose of this section is to describe what MTWS sends in the TEMPLATE_NAME 
attribute in an ALSP message. 

a. Unit defined, not using TOTE: 

The unit’s name (up to 14 characters), followed by a “_T” is sent in the 
TEMPLATE_NAME attribute.  For example, if the unit name is “B/1/1” then “B/1/1_T” is 
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sent.  Likewise, if the unit name is “3RDINFANTRYSQUAD”, then 
“3RDINFANTRYSQU_T” is sent. 

b. Unit defined, using TOTE: 

The following is the list of characteristics used to uniquely identify a 
TEMPLATE_NAME: Service/Alliance/Country (up to eight characters), unit kind in 
number format, hierarchy in number format, and unit subtype in number format.  For 
example, if an USMC tank company of subtype M1A1 is defined, using the tables below, 
“USMC_0304080”. 

Table 4 – Unit Kind Lookup 

  0 1 2 3 4 5 6 7 8 9 

0XShip Civilian Artillery Tank Infantry Mortar Motor Transport  
Air 
Squadron Light Armor 

Motorized 
Rifle 

1XEngineer Supply Medical Maintenance 
Assault 
Amphibian Reconnaissance Anti-tank 

Air 
Defense Communication 

Electronic 
Warfare 

2XCSS          
 
 
 
 

Table 5 – Hierarchy Lookup 

  0 1 2 3 4 5 6 7 8 9 
0XTeam Squad Section Platoon Company Battery Battalion Squadron MEU Regiment 
1XMAG Brigade MEB Division MAW Group MEF Corps Civilian  
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Table 4 – Unit Subtype Lookup 
 0 1 2 3 4 5 6 7 8 9 

0X
BELKNAP_C
LASS 

BURKE_CLAS
S CA_CLASS CARGO CRRC DET_SHIP FRUNZE_CLASS HQ_SHIP JFK_CLASS KARA_CLASS

1X
KASHIN_CL
ASS KIDD_CLASS KIEV_CLASS KIROV_CLASS KRESTA_2_CLASS KRIVAC_1_CLASS KRIVAC_3_CLASS LCAC LCC LHA 

2XLHD LPD LPD_AG_CLASS LPH LSD LST LST_AG_CLASS MOSKVA_CLASS NIMITZ_CLASS OILER 

3X
PERRY_CLA
SS RRC SLAVA_CLASS 

SOVRENMNY_
CLASS SPRUANCE_CLASS SUPPORT_SHIP TICO_CLASS TRUXTON_CLASS UDALOY_CLASS VA_CLASS 

4XSHIP_1 SHIP_2 SHIP_3 SHIP_4 SHIP_5 SHIP_6 SHIP_7 SHIP_8 SHIP_9 SHIP_10 
5XARTY_105T ARTY_122SP ARTY_122SP_SNI ARTY_122T ARTY_122T_ABN ARTY_152SP ARTY_152T ARTY_155SP ARTY_155T ARTY_203SP
6XARTY_M198COMPOSIT DET_ARTY HQ_ARTY MLRS MRL_SNI MRL RL_ABN ARTY_1 ARTY_2 
7XARTY_3 ARTY_4 ARTY_5 ARTY_6 ARTY_7 ARTY_8 ARTY_9 ARTY_10 DET_TANK HQ_TANK 
8XM1A1 T62 T64 T72 TANK_ABN TK TK_LAI TK_MRR TK_SCOUT TK_SNI 
9XTK_TR TANK_1 TANK_2 TANK_3 TANK_4 TANK_5 TANK_6 TANK_7 TANK_8 TANK_9 

10XTANK_10 ABN_BMD AIRBORNE ANTI_ARMOR DET_IFY HMG_IFY HQ_IFY IFY_3 IFY_4 MG 
11XMOTORIZEDMP_DIV MP_FSSG SNI TRUCK_IFY WPN IFY_11 IFY_12 IFY_13 IFY_14 

12XIFY_15 IFY_16 IFY_17 IFY_18 IFY_19 IFY_20 DET_MTR HQ_MTR MTR_120 
MTR_120_AB
N 

13XMTR_60 MTR_81 MTR_81_LAI MTR_82 MTR_82_SNI MTR_1 MTR_2 MTR_3 MTR_4 MTR_5 
14XMTR_6 MTR_7 MTR_8 MTR_9 MTR_10 DET_MT DS_TRANS GS_LVS GS_TRANS HQ_MT 

15X
MSSG_MOT
OR_T MT_AMMO MT_CARGO MT_POL TRANS_LVS TRUCK TRUCK_DS TRUCK_GS MT_1 MT_2 

16XMT_3 MT_4 MT_5 MT_6 MT_7 MT_8 MT_9 MT_10 COMP_HELO 
COMP_HELO
_SOC 

17XDET_AS HMA HMH HMH_DET HML HMLA HMLA_DET HMM HQ_AS MASS 
18XMATC VMA VMA_DET VMAAW VMFA AS_1 AS_2 AS_3 AS_4 AS_5 
19XAS_6 AS_7 AS_8 AS_9 AS_10 DET_LA HQ_LA LAI LAI_AD LAI_MTR 
20XLAI_TOW LAI_WPN LAR LAR_AD LAR_MTR LAR_TOW LAR_WPN LA_1 LA_2 LA_3 
21XLA_4 LA_5 LA_6 LA_7 LA_8 LA_9 LA_10 AAAV_MECH AAV_MECH BMP 
22XBMP_WPN BRADLEY BTR BTR_WPN DET_MR HMG HMG_MECH HQ_MR MR_1 MR_2 
23XMR_3 MR_4 MR_5 MR_6 MR_7 MR_8 MR_9 MR_10 ASLT_MR BULK_FUEL
24XCMB_ENG DET_ENG ENG_ABN ENG_BRIDGE ENG_EQUIP ENG_FSSG ENG_MR ENG_MRR ENG_SNI HQ_ENG 
25XMWSS ENG_1 ENG_2 ENG_3 ENG_4 ENG_5 ENG_6 ENG_7 ENG_8 ENG_9 
26XENG_10 AIR_DELVRY ARTY AV_ORD BEACH_OPS BSSG DET_SUP HQ_SUP LANDING_SUPP MAT_SUP 
27XMSSG MSSG_SUP MWSS_FW MWSS_RW ORD ORD_GS SUP SUP_MR SUP_SNI SUP_TD 
28XSUP_1 SUP_2 SUP_3 SUP_4 SUP_5 SUP_6 SUP_7 SUP_8 SUP_9 SUP_10 
29XCOL_CLR DS_MED FLD_HOSP GS_MED HQ_MED MCSSD_MED MED_DET MSSG_MED SHOCK_TRAUMA SURG_SPT
30XMED_1 MED_2 MED_3 MED_4 MED_5 MED_6 MED_7 MED_8 MED_9 MED_10 
31XAAAV AAAV_SPT AAV AAV_SPT DET_AAV HQ_AAV AAV_1 AAV_2 AAV_3 AAV_4 

32XAAV_5 AAV_6 AAV_7 AAV_8 AAV_9 AAV_10 CHEM DET_RECON DIV_RECON 
FORCE_REC
ON 

33XHQ_RECON LAI_RECON RECON_BMP RECON_BRDMRECON_BTR RECON_DA RECON_MR RECON_MTZD RECON_RR RECON_SNI
34XRECON_T64RECON_1 RECON_2 RECON_3 RECON_4 RECON_5 RECON_6 RECON_7 RECON_8 RECON_9 
35XRECON_10 ASLT ATK_76 ATK_ABN ATK_LAI ATK_MR ATK_MRR ATK_SNI DET_AT DRAGON 
36XHQ_AT TOW AT_1 AT_2 AT_3 AT_4 AT_5 AT_6 AT_7 AT_8 
37XAT_9 AT_10 AAA AAA_14_5 AAA_37 AD_14_5 AD_ABN AD_BMP AD_BTR AD_MR 
38XDET_AD HQ_AD LAAD LAAD_A LAAM MACS MSL_TECH PATRIOT SA_2 SA_3 
39XSA_6 SA_8 SA_9 AD_1 AD_2 AD_3 AD_4 AD_5 AD_6 AD_7 
40XAD_8 AD_9 AD_10 DET_EW HQ_EW RDF RI EW_1 EW_2 EW_3 
41XEW_4 EW_5 EW_6 EW_7 EW_8 EW_9 EW_10 CSSD_CSS CSSE DET_CSS 
42XDS_CSS FSSG GS_CSS HQ_CSS MCSSD_CSS MSSG_CSS CSS_1 CSS_2 CSS_3 CSS_4 
43XCSS_5 CSS_6 CSS_7 CSS_8 CSS_9 CSS_10 CSSD_MAINT DET_MAINT DS_MAINT GS_MAINT 
44XHQ_MAINT MALS_FW MALS_RW MCSSD_MAINTMSSG_MAINT MAINT_1 MAINT_2 MAINT_3 MAINT_4 MAINT_5 
45XMAINT_6 MAINT_7 MAINT_8 MAINT_9 MAINT_10 DET_COMM HQ_COMM RELAY_SITE COMM_1 COMM_2 
46XCOMM_3 COMM_4 COMM_5 COMM_6 COMM_7 COMM_8 COMM_9 COMM_10 DISPLACED EPW 
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47XNONE REFUGEES CIV_1 CIV_2 CIV_3 CIV_4 CIV_5 CIV_6 CIV_7 CIV_8 
48XCIV_9 CIV_10 HQ               

 

 

Starting MTWS and ALSP Translator Software 

Initiate Execution of MSC Software  

To initiate execution of the MSC software, perform the following steps: 

a. Log on to the MSC station and select Applications  --> Start Sysop  
 --> ALSP from the root menu.  See paragraph “Accessing the Root Menu” for 
procedures to access the root menu. 

b. Select System Control --> Admin --> Start MSC from the System Operations 
window to start the remaining MSC programs. 

c. Wait for a response to appear in the System Operations window indicating that MSC 
has started. 

d. Select System Control --> Applications --> Load MAN from the System Operations 
window to start execution of the MAN software on the desired host(s).  The MAN 
hostnames interface will appear. 

e. Select the hostname(s) on which the MAN software is to run. 

f. Click on OK button on the System Operations window. 

g. Wait for response(s) to appear in the System Operations window indicating that the 
MAN software has started on the designated host(s).  There is one such response for 
each MAN host. 

h. Select Exercise Control --> Database --> Exercise --> Load.  The exercise load 
interface will appear. 

i. Select the desired exercise from those listed in the exercise load interface. 

j. Select the New, Start, Time, or End button in the exercise load interface.  If Time is 
chosen, enter the exercise time at which the exercise is to be loaded.   

NOTE  

The consequences of each choice are discussed individually in 
paragraphs “Starting an Exercise – Start” through “Starting an 

Exercise – End”. 
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k. When the desired choices have been made, click on the OK button on the exercise load 
interface. 

NOTE  

To abort the exercise load, click on the Cancel button on the exercise 
load interface. 

l. Inspect and verify the message displayed in the System Operations window, which 
identifies the exercise name and the New/Start/Time/End option chosen in steps i and j.  
If this information is incorrect or if an operator error occurred in selecting values from 
the exercise load interface, refer to the note in the following step. 

m. To load the exercise, click on the OK button on the System Operations window. 

NOTE 

To abort the exercise load, click on the Cancel button on the System 
Operations window.  If this option is chosen, steps g through k can be 

repeated. 

n. Wait for response(s) to appear in the System Operations window indicating that the 
exercise has been loaded on the MAN host(s) designated in step d. 

o. Select System Control --> Applications --> Start App from the System Operations 
window to assign MAN functions to the desired host(s).  The application/host mapping 
interface will appear with a list of MAN hosts and a button for each application.  A 
default mapping of applications to MAN hosts is provided.  This default mapping is the 
recommended distribution for a typical land/sea/air exercise. 

p. The ALSP windows will display by default on the MSC.  They may be displayed on 
the ALSP MAN host by logging in to that MAN as user soc before selecting Start 
App.  A second desktop has been provided on the MSC for use with ALSP.   

q. To change the host for a selected application, select the desired MAN host by clicking 
on the MAN host selector.  Once the MAN is selected, click on the application button 
for each application which is to run on the selected host. 

r. Click on the OK button on the System Operations window. 

NOTE  

To abort the application start, click on the Cancel button on the System 
Operations window. 

s. Wait for response(s) to appear in the System Operations window indicating that the 
applications have started on the MAN host(s) designated in step d. 
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t. Activate the MDS Station Control interface and click on the On/Offline: ...  On 
button.   

u. Proceed with loading any MTWS Batch Files that are to be loaded while in the Admin 
State. 

NOTE 

Units built without the TO/TE parametric data will not be assigned 
ALSP identification numbers or appear on other simulation systems as 

ghosted units UNLESS the Asset Update command is used to update 
units with complex assets or troops before initializing the database. 

Initiate Execution of ALSP Translator 

To initiate execution of the ALSP Translator, perform the following steps: 

a. If the ALSP windows are being displayed on MSC, move the ALSP window to the 
ALSP desktop by clicking the left or right mouse button with the pointer over the icon.  
Select Occupy Workspace --> ALSP Control.  Restore the front panel (the bottom 
left icon) to allow convenient access to both desktops.   

b. Inspect the alsp window on the MSC or MAN.   

c. The parameters displayed are:  

1) LOOK AHEAD = 0.0167 

2) ACTOR # = 6 

3) NODE = (MAN number host) 

4) CONFED = 1 

5) START TIME = 0.00 

6) ACTOR NAME = MTWS.   

Some of these defaults may be set by editing 
/mtws/bin/ALSP/Config.dat.   

The Look Ahead and Start Time units of measure are hours, so the look-ahead time is set 
to one minute (one hour divided by 60 minutes = 0.0167).  The Start Time is changed only 
when joining an ALSP confederation exercise at a different time than the default MTWS 
exercise start time.   

The register/filter box at the top of the alsp window displays the default register and filter 
data that are selected to be sent to the astream window.  The register/filter attribute list 
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contains the information of which class, interactions, and object attributes to display or 
allow.  The list can be added to by using the register/filter menu or deleted from using the 
Delete selected button. 

d. Click on the Start button in the alsp window of the ALSP MAN.  The astream, 
mstream, and database windows will appear on the ALSP MAN.   

1) The astream window is used to join the ALSP confederation network, log ALSP 
messages, and display ALSP message traffic.   

2) The mstream window is used to recover MTWS and ghosted objects and to enable 
the MTWS msc001 interface. 

3) The database window is used to display a count of MTWS and ALSP (ghosted) 
objects.  The count of MTWS entities will be equal to the number of objects defined 
in the MTWS database that are assigned identification numbers after object 
registration.  The ALSP Entities Count will be the total of the Air.Count, Sea.Count, 
and Ground.Count objects after object registration.   

e. On the astream window menu, select Log_File --> OPEN --> logs directory 
(/mtws/bin/ALSP/logs/).  (This is an optional step, useful for troubleshooting) 

f. Define a unique file name with the extension ".log" to capture the ALSP message 
traffic to the named particular log file for historical purposes. 

g. Click on the Connect button in the astream window of the ALSP MAN. 

h. Click on the Join button in the astream window of the ALSP MAN.  Observe the Join 
message appear in the astream message window with the join parameters defined in the 
alsp window. 

i. Wait for the ID_REQUEST message to appear in the astream window. 

j. Click on the Send button in the alsp window to send filter information.  The filter 
information will appear in the astream message traffic window. 

k. Click on the red interface arrow in the mstream window and observe that the arrow is 
now green and pointing upward. 

l. If the New option was chosen when loading the exercise, establish the initial tactical 
database by selecting Exercise Control --> Database --> Exercise --> Initialize  from 
the System Operations window.,  

m. Wait for a response to appear in the System Operations window indicating that exercise 
initialization is complete. 

n. When MTWS is ready to pass objects to the ALSP confederation, select RECOVER --
> OWNED from the mstream menu. 
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o. If other confederation systems have joined the confederation, select RECOVER --> 
GHOSTED from the mstream menu.  The database window of the ALSP MAN will 
reflect the total count of ALSP entities in addition to a breakdown by Air.Count, 
Sea.Count, and Ground.Count.  Ghosted objects should appear on the MDS if it is on-
line. 

p. Select Exercise Control --> Clock --> Synchronization from the System Operations 
window.  The clock synchronization interface will appear.  The current clock 
synchronization setting is shown as being selected in this interface. 

q. Clock Synchronization overrides Clock Advance and Clock Rate settings which are 
faster than real-time.  For example, if the Clock Rate has been set to twice real-time, 
exercise time will advance at twice real-time only if all MAN functions are capable of 
doing so.  Otherwise, exercise time will advance at less than twice real-time. 

r. Select ENABLED from the clock synchronization interface, then click on OK in the 
System Operations window. 

s. If it is desired to run the exercise at this point, select Exercise Control --> Operation -
-> State --> Run from the System Operations window. 

Ghosted objects (air missions, ships, and ground units from other simulation systems) will 
be displayed on the MDS as an MTWS-type object with a grey outline.  As with an MTWS 
object, the object name for an ALSP object is assigned by the MTWS system and may be 
used in targeting.  The format is ALSP_annnnn where a is the remote actor number and 
nnnnn is a sequence of five digits that ID the object.  This number increments with each 
new object.   

Spot reports can be received by assigning controller ALSP_CONT_1 to the MDS display.  
The ALSP object identification number is a different assignment which occurs for 
outgoing MTWS objects and incoming confederation objects.  The numbers are only 
viewed in the ALSP Message Traffic box in the astream window on the ALSP MAN.  This 
is the identification number assigned during object registration (create) and used in object 
updates and deletions.  The format is ID(nnnnnn) where the first digit is the Actor Number 
(from the alsp window) followed by the new object's ID.   

Suspend and Resume MTWS/ALSP 

The Suspend and Resume operations of the MTWS system while operating in a 
confederation are identical to those executed in an MTWS stand-alone system.  During a 
Suspend, the data received and displayed in the astream message traffic box is halted.  
When the Resume command is executed, data processing and display will continue. 

WARNING ! 

Due to the ALSP Confederation's unique system status, the Suspend 
command will halt the entire confederation. 
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Obtain permission from Confederation staff before 
suspending the MTWS system. 

Resign and Rejoin an ALSP Confederation 

The Resign and Rejoin operations of the MTWS/ALSP system are critical processes that 
must be executed with care.   

When resigning from a confederation, it is not normally required to halt the MTWS 
system.  The Resign operation deletes the ALSP identification numbers for all MTWS 
objects in the confederation and therefore removes MTWS from any further confederation 
interaction.  The ALSP Translator process is terminated and all four of the ALSP windows 
are closed on the ALSP MAN.  The update and display of all ghosted objects on the MDS 
is halted.   

The Rejoin operation is similar to an initial join operation except that the MTWS database 
is already established and only the ALSP MAN processes need to be started. 

NOTE 

Resigning from the Confederation may have an impact on other 
exercise participants.  Always obtain permission from the 

Confederation staff before resigning. 

Initiate Execution of a Resign from ALSP Confederation 

To initiate execution of a Resign from the ALSP confederation without restarting the 
MSC, perform the following steps: 

a. Select Exercise Control --> Operation --> Mode --> Suspend. 

b. Click on the OK button on the System Operations window. 

c. Wait for a response to appear in the System Operations window indicating that the 
exercise has been suspended. 

d. Click on the Resign button in the alsp window of the ALSP MAN.  A series of Delete  
messages will be sent to and displayed on the astream message traffic box.  The alsp, 
astream, mstream, and database windows will disappear on the ALSP MAN.   

e. Click on and close the Translator process icon on the MAN. 

f. If MTWS must also be halted, continue with terminating the exercise as described in 
paragraph “Suspending an Exercise”. 

NOTE 
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If MTWS is halted, the procedure for starting ALSP must be repeated.  
(See paragraph “Initiate Execution of MSC Software”)  

Initiate Execution of a Rejoin to ALSP Confederation 

To initiate execution of a Rejoin to the ALSP confederation, perform the following steps: 

a. On the ALSP MAN, open a terminal window from the root menu. 

b. At the Unix prompt, change directory to /mtws/bin/ALSP/ by typing cd 
/mtws/bin/ALSP at the prompt. 

c. To start the Translator, execute the Start_Translator command at the Unix prompt.  
The alsp window will appear.  Minimize  the Unix window. 

d. Inspect the alsp window on the ALSP MAN.  The parameters displayed are: 

1) LOOK AHEAD = 0.0167 

2) ACTOR # = 6 

3) NODE = (MAN number host) 

4) CONFED = 1 

5) START TIME = 0.00 

6) ACTOR NAME = MTWS.   

e. MTWS should rejoin the ALSP confederation at a time slightly ahead of the current 
exercise time so that confederation time will continue to advance and MTWS will wait 
a short time to start processing.  Otherwise, if MTWS is behind the current exercise 
time, all other confederation systems will be placed in a wait status while MTWS 
advances to the play time.   

NOTE 

The ALSP confederation staff should be consulted when an MTWS 
rejoin operation is to take place.  The staff will supply the current game 
time and coordinate with other confederation members before granting 

permission to join. 

f. Set the Start Time  ahead of the confederation elapsed exercise time (e.g., ten minutes 
or .17) in the format n.nn.  For example, if the confederation has been operating for 
three hours and 45 minutes, the Start Time to enter would be Ò3.92Ó (add .17 to 3.75 
hours to produce the decimal number of 3.92). 
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g. Click on the Start button in the alsp window of the ALSP MAN.  The astream, 
mstream, and database windows will appear on the ALSP MAN. 

h. On the astream window menu, select Log_File --> OPEN --> logs directory 
(/mtws/bin/ALSP/logs/).  (This step is optional). 

i. Define a unique file name with the extension ."log" to capture the ALSP message 
traffic to the named particular log file for historical purposes. 

j. Click on the Connect button in the astream window of the ALSP MAN. 

k. Click on the Join button in the astream window of the ALSP MAN.  Observe the Join 
message appear in the astream message window with the join parameters defined in the 
alsp window. 

l. Wait for the ID_REQUEST message to appear in the astream window. 

m. Click on the Send button in the alsp window to send filter information, which will 
appear in the astream message traffic window. 

n. Click on the red interface arrow in the mstream window and observe that the arrow is 
now green and pointing upward. 

o. Select RECOVER --> OWNED from the mstream menu. 

p. If other confederation systems have joined the confederation, select RECOVER --> 
GHOSTED from the mstream menu. 

q. Select Exercise Control --> Operation --> State --> Run from the System Operations 
window. 

Terminating an Exercise 

To terminate an exercise gracefully, perform the following steps: 

a. Suspend the exercise as defined in paragraph “Suspending an Exercise”.  MDS inputs 
should be disabled as soon as possible after the MDS hosts have been notified of the 
SUSPEND.  SUSPEND may still be flashing yellow on the MSC.  All on-line MDS 
hosts have been notified when the following alert appears: 

INFO : MAN_Control -  For New advance rate of 0.000 , Current time is...   

b. Disable the MDS interface as described in paragraph “Disable MDS Interface” 

c. Select Exercise Control --> Operation --> State --> Admin from the System 
Operations window. 

d. Wait for the MSC Status Window to indicate that Admin state has been entered. 
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e. Select System Control --> Applications  --> Halt MAN from the System Operations 
window. 

f. Wait for response(s) to appear in the System Operations window indicating that the 
MAN applications have halted. 

g. Log out of the MSC or restart MTWS by pressing the left or right mouse button on the 
root window.   

After performing steps a through f, it is still possible to perform various exercise-related 
functions: 

a. The (terminated) exercise can be saved as described in paragraph “Saving an Exercise”   

b. The MDS interface can be enabled as described in paragraph “MDS Interface”. 

c. Solicited reports can then be obtained from the MDS stations. 

NOTE  

At this point, although the MAN software is still technically active (the 
MAN processes are still running), it is effectively terminated -- the 
MAN can do nothing until this software (and the MSC software) is 

restarted as described in paragraph “Installing from your local drive”. 

JQUAD Interface 

The JQUAD interface is used to pass battle damage assessment (BDA) air mission 
information directly to JCAS (Joint Command & Control Attack System), one of four joint 
models in the JQUAD system.  The other three models in JQUAD are: JECEWSI, Joint 
Electronic Combat Electronic Warfare Simulation; JOISIM, Joint Operational Intelligence 
Simulation; and JNETS, Joint Network Simulation.  The JQUAD interface can only be 
used in JTC exercises where both MTWS and JQUAD are members of the confederation. 

The MTWS-JQUAD communications interface is a TCP/IP socket connection between the 
MSC and the JQUAD host. To enable this interface, select System Control --> Interfaces 
--> JQUAD --> Start. To disable this interface, select System Control --> Interfaces --> 
JQUAD --> Halt. This interface can be enabled/disabled as many times as is needed. 

 

 

 Security Administrator Configuration 

As described in section 3.3.3, during Maui installation, a new Security Administrator 
Configuration window allows the setup of a security administrator's user name and 
password. For normal users (non-security administrator account user), the security 
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administrator's user name and password is required in order to continue running Maui 
when data (e.g.: the loading of a raster map) is introduced into Maui at a higher 
classification level than Maui's current classification level. 

MTWS exercise classification levels are set by the MSC.  These classification level data 
sets are exercise-specific, copied to the exercise directory when creating an exercise.  The 
security level of an exercise is defined at exercise creation time using the MSC’s 
classification data.  This data is controlled by the MSC's System Operations (Sysop) 
interface and should not be manually modified. 

The security classification data is comprised of tuplets of  

1. Classification level. 

2. Red,Green,Blue (RGB) values which set the color of this classification level. 

3. List of 0 or more aliases, names which equate to this classification level. 

These classification levels are listed from low to high. That is, the lowest classification 
level (also the default classification level) is the first entry in the file; the highest 
classification level is the last entry in the file. 

At initial install of MTWS and Maui, Maui has a local copy of the MSC's security 
classification levels. 

At startup, Maui retrieves the currently loaded exercise’s security classification data from 
the MSC. It renames and overwrites the local copy. If Maui cannot access the MSC's 
security classifications data, an alert is logged to the Maui alerts.log and a dialog box is 
displayed warning the user that the security classification file could not be found and 
allowing the user to continue at risk. Maui will use its local security classifications data. 
However, the fact that Maui could not retrieve the security classifications data from the 
MSC is symptomatic of the following possible problems: 

- Maui started up before the exercise was loaded on the MSC (check to make sure the 
exercise load is complete, then restart Maui) 

- There is a problem with FTP between Maui and the MSC (check the Alerts log) 

- Not sure?! (see your Maui Security/System administrator) 

Security classification checks are made based on security classification level comparisons 
between MTWS and Maui and between Maui and MTWS external inputs (e.g.: C4I or 
loading of raster maps into Maui). 

To manually set the classification level in Maui: 
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-  Start up Maui under the Security Administrator account (If you are not running Maui 
under the Security Administrator account you will not get the option to change the security 
classification level within the profile preference interface). 

-  Set Maui's user level to 2 

-  Select the 'Profile Preferences...' option from the 'Tools' menu. 

-  Select the 'Display' tab from the 'Preference' window. If you are properly running Maui 
under the 'security administrator' account you should see a 'Security Classifications' 
selection box. 

-  To set Maui's classification level to the lowest classification level, select the first entry in 
the drop down list. 

-  To set Maui's classification level to the highest classification level, select the last entry in 
the drop down list. (Again, as previously mentioned, levels are listed from lowest to 
highest) 

The exercise's classification level can be modified during runtime,  via the MSC’s System 
Operations window.  Note that, currently, Maui is not notified of this exercise security 
level change without going offline and back online. 

To modify the exercise's classification level during run time, from the Sysop interface, 
select the exercise->modify menu option and then select the 'new' exercise security level.  
Remember to notify all Maui operators to put their Maui's off and then on line to have this 
security level modification take affect on each Maui. 

The Security Administrator Configuration tool which is launched when installing Maui 
(see the section on INSTALLATION) is available in from the "Security Administration 
Configuration" shortcut in the "MTWS Tools" folder on the desktop or the Programs-
>MTWS->Tools from the Start Menu. 

You must be logged under the Security Administrator user account in order to use this tool.  
If you try to run this tool under any other account a "User Name Error" dialog window will 
appear and you will not be able to run the tool. 

You can use this tool to modify the security administrator account should the password 
become compromised. Launch the tool and enter in the new security administrator account 
and/or new password. 

If you change the "Security Name" a "User Name Warning" dialog will be displayed 
warning you that you are about to change the account name from <oldname> to <new 
name> and that only the <new name> will be able to change the security username and 
password (from here on in).  

Select the "Yes" option if you wish to continue. 
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The "Security Admin Login" dialog will appear when a security violation such as 
introduction of data into an “online” Maui which is at a higher level than that of the 
currently running exercise. 

When the "Security Admin Login" dialog will appears the follow can occur: 

1. Security Login Successful 

   Enter the current name and password of the security administrator's account, (set up at 
install time, or modified via the security administrator configuration tool) and click the 
"OK" button.  If correct, the login dialog window will go away allowing you to continue to 
use Maui or take any further corrective actions necessary. 

2. Security Lockout 

   You are given 3 attempts to enter the correct current name and password of the security 
administrator's account. After the third attempt, Maui will be shut down, if running. Any 
subsequent attempt at starting up Maui will bring the Security Login interface up and 
require the correct name and password of the security administrator's account be entered in 
before Maui can be successfully started up. 

3. Security Login Cancelled 

If you cancel out of the Security Login interface, Maui will be shut down, if running, and 
any subsequent attempt at starting up Maui will bring the Security Login interface up and 
require the correct name and password of the security administrator's account be entered in  
before Maui can be successfully started up. 

4. Security Administrator's account is not properly configured 

   If the security administrator account is not properly configured a dialog window will be 
displayed with the following warning:   "Security administration has not been set up 
properly.    Proceeding in this state may pose a security violation. 

    Are you sure you want to continue? 

    [ Yes ]   [ No ] " 

     

   This state can occur if the security administration configuration step is skipped 
(Canceled) during installation. 

   If you continue (click "Yes" button) you may have problems with Maui should a security 
violation occur.  To remedy this problem, click the "No" button and run the Security 
Administrator Configuration tool to set up the security administrator account as described 
in Appendix C of this document. 
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5. Security Administrator Account is Corrupt 

If the security administrator account becomes corrupt, Maui starts up or a security 
violation occurs, a dialog window will be displayed. 

To remedy this situation run the Security Administrator Configuration tool to set up the 
security administrator account as described in the in Appendix C of this document. 

Security dialog messages can occur under the following conditions: 

1. Maui is set to a lower level than the current exercise (same results/response whether 
under security administrator user or non security administrator account). 

   state:    Maui is offline.   

  action:   Click the "On" button attempt to go online. 

 results:  The "Classification Modification" dialog appears with the warning: 

             "The current MTWS exercise's classification level is at a higher level than Maui. 

             Maui's classification level has been raised from <old level> to <new level>." 

   response: Click the "OK" button and, provided the MDS net is enabled, 

             Maui's security classification level is raised to the security classification level of 
the current exercise. 

 

2. Maui is set to a higher level than the current exercise   (same results/response whether 
under security administrator user  or non security administrator account) 

   state:    Maui is offline. 

   action:   Click the "On" button attempt to go online. 

   results:  The "Status: Online" text is yellow and blinks until a timeout occurs. At this 
time Maui's status text will change to "Status: Offline" in red text and a dialog  
box will be displayed which states: 

             "Maui timed out while going online. 

              Please see your Maui system administrator for further assistance." 

   response: Click the "OK" button. 

When running Maui under the Security Administrator account, you can modify the security 
classification level via the profile preferences. 
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3a. Introduction of higher level data into Maui while online 

   (under security administrator user account). 

    state:    Maui is online and at the same level as the current exercise. 

    action:   An attempt is made to load a map or Maui receives C4I data at a higher level 
than the current exercise. 

    results:  1. Maui's status text will change to "Status: Offline" in red text  

                  2. The "Security Violation" dialog appears with the message: 

                "A security violation has occurred. 

                 Maui has encountered data at a higher classification level than the current 
exercise. Maui has been forced offline and its classification level will now be 
raised                  from <old level> to <new level>. 

                 Please alert your system administrator." 

              3. A "SECURITY VIOLATION !!" dialog will appear on the MSC with the 
hostname of the offending Maui box as well as the time of the violation. 

    response: Click the "OK" button in the Security Violation dialog on the Maui and the 
"OK" button in the Security Violation dialog on the MSC, and proceed as 
specified by your site security administration procedures. 

 

3b. Introduction of higher level data into Maui while online 

   (under non security administrator user account) 

    state:    Maui is online and at the same level as the current exercise 

    action:   An attempt is made to load a map or Maui receives C4I data at a higher level 
than the current exercise. 

    results:  1. Maui's status text will change to "Status: Offline" in red text  

                 2. The "Security Violation" dialog appears with the message: 

                "A security violation has occurred. 
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                 Maui has encountered data at a higher classification level than the current 
exercise. Maui has been forced offline and its classification level will now be 
raised from <old level> to <new level>. 

                 Please alert your system administrator." 

              3. A "SECURITY VIOLATION !!" dialog will appear on the MSC with the 
hostname of the offending Maui box as well as the time of the violation. 

    response: Click the "OK" button in the Security Violation dialog on the Maui and the 
"OK" button in the Security Violation dialog on the MSC.  Because a security 
violation has occurred, the "Security Admin Login" dialog will appear. 

              The security administrator account login name and password must be entered to 
be able to continue to use Maui. 

              Enter in the security administrator account login name and password  that were 
entered in at installation time (the security administrator should know this 
information). 

4a. Loading a higher level map when offline (under security administrator user account)     

     state:    Maui is offline. 

    action:   An attempt is made to load a map at a higher level  than Maui's current 
classification level. 

    results:  The "Classification Modification" dialog appears with the warning: 

              "The data being loaded into Maui has a classification level which is at a higher 
level than Maui.  Maui's classification level has been raised  from <old level> to 
<new level>." 

    response: Click the "OK" button and the Maui's security classification level is raised to 
the map's security classification level.  

4b. Loading a higher level map loading when offline (under non security administrator 
user account) 

    state:    Maui is offline. 

    action:   An attempt is made to load a map at a higher level  than Maui's current 
clasification level. 

    results:  The "Classification Modification" dialog appears with the warning: 

              "The data being loaded into Maui has a classification level  
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               which is at a higher level than Maui.  Maui's classification level has been raised               
from <old level> to <new level>." 

    response: Click the "OK" button and the Maui security classification level  is raised to 
the map's security classification level,  however, the Security Administrator 
Login dialog window appears requiring the Security Administrator to enter in 
their user name and password before the user can continue. 
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Chapter 5 - CART Operating Procedures. 

Starting the CART Software. 

The software needed to run the CART Server is started up during the CART Server boot 
process. No additional user action is required other than switching on the machine and 
waiting for the boot process to complete. Once booted, the CART Server is capable of 
recording exercises (see section Error! Reference source not found.) and serving 
information to the CART clients (see Volume V of the MTWS Documentation Suite). 

 

Using CART reports on the CART Server. 

Managing exercises and the access permissions for workstations may be performed from 
the CART Server. To start the reports: 

Start the Mozilla web browser on the CART Server. 

Type: “http://localhost/cgi-bin/index.pl” into the address bar and press return. 

From the menu bar select Edit->Preferences. 

In the Preferences dialog box click on the button marked “Use Current Page” and then 
click “OK”. 

 

Monitoring and Managing the CART Exercises. 

Exercise Status. 

To view the exercise state, perform the following steps. 

1 login into the CART server. 

2 start the internet browser. 

3 In the address bar, type ‘localhost/cgi-bin/index.pl’ and press return. 

4 Your browser will display a menu of options. From the Menu page select “Exercise 
Status”. 

A report page such as that shown below will be presented: 
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EXERCISE STATUS 
 

Server Status  
CART DATABASE 
Up 

 

CART DATA CAPTURE 
Connected 

 

CART SERVER 
mdscrt 

 

YOUR CLIENT IP 
159.62.131.60 

 

 

Exercise Data 
EXERCISE NAME 
TEST 

 

START TIME 
210800UJAN03 

 

MOST RECENT UPDATE 
220259UJAN03 

 

CLASSIFICATION 
UNCLASSIFIED 

 

PARAMETRIC DATA 
BASELINE 

 

SOURCE 
CART release i3.0 
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The first table titled Server Status, shows which services are up. The database should always 
be ‘up’. If the database is not up, there is a problem with the system that must be corrected 
before CART will work. See Section ?? for more information on the CART database.  

CART Data Capture shows whether the CART server is currently connected to MTWS. If 
this shows as connected then CART is recording an exercise from the MSC. The CART 
clients may connect to CART whether or not the CART data capture is connected. 

The exercise data shows information on the current exercise (if any.) When CART is first 
installed, no database is selected and this table is not shown. The table shows: 

1 Exercise name: CART records the name used when originally creating the exercise on 
the MSC.  

2 Start time: The game time that the exercise started. 

3 Most recent update: The most recent complete minute of data that has been received 
from the MSC. Typically this is updated on CART just after the MSC has changed 
minute, but is one minute behind the time shown on the MSC. NOTE: Until an exercise 
has run for a complete minute this time is not available. CART clients cannot connect 
to the CART Server until this time is shown. 

4 Classification: The classification shows the exercise’s classification as defined when 
creating the exercise. 

5 Parametric Data: The Parametric Data used for the exercise, either ‘BASELINE’ or the 
name of the user defined parametric data.  

6 The build of CART that recorded the exercise. The current build of CART will show 
“CART release v3.0”. Future CART clients may not be compatible with exercises 
recorded with the current CART server. 

This screen will update every 15 seconds. 

Exercise Manager. 

From the CART Reports Main Menu click on “Exercise Manager”. 

A report showing information such as the following. is displayed: 

EXERCISE MANAGER 
   EXERCISE NAME  CLASSIFICATION  PARAMETRIC 

DATA  
CART 

VERSION  DATE  START  STOP  

 TEST (active)  UNCLASSIFIED  BASELINE  CART 
Release V3.0 

Thu Jan 23 
14:54:08 
2003  

210800UJAN03  210901UJAN03  

 
TEST (TEST_v001)  UNCLASSIFIED  BASELINE  

CART 
Release V3.0

Tue Jan 21 
11:23:18 
2003  

080800UNOV02  081148UNOV02  
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TEST (TEST_v002)  UNCLASSIFIED  BASELINE  

CART 
Release V3.0

Wed Jan 22 
15:39:33 
2003  

210800UJAN03  220259UJAN03  

 
LF_DEMO (LF_DEMO)  UNCLASSIFIED  BASELINE  CART 

Release V3.0

Thu Jan 16 
14:44:41 
2003  

232032UOCT02  232353UOCT02  

 
LF_DEMO 
(LF_DEMO_v002)  UNCLASSIFIED  BASELINE  CART 

Release V3.0

Thu Dec 12 
17:54:50 
2002  

120901UDEC02  131112UDEC02  

 
V3.0-STRESS 
(V3_0_STRESS_v003)  UNCLASSIFIED  BASELINE  CART 

Release V3.0

Fri Dec 13 
09:11:50 
2002  

110300UDEC02  110445UDEC02  

 
STRESS (STRESS_v008)  UNCLASSIFIED  BASELINE  CART 

Release V3.0

Thu Dec 19 
07:21:53 
2002  

110300UDEC02  110337UDEC02  

   EXERCISE NAME  CLASSIFICATION  PARAMETRIC 
DATA  

DATE  CART 
VERSION  

START  STOP 

Activate
   

Delete
 

 

The form shows the databases that have been saved to the CART server. Each line 
describes information about a single database. Exercises are listed alphabetically except for 
the first, which is the currently selected exercise. The fields are the same as those listed in 
the Exercise Status form described above. 

To delete an exercise select the radio button to the left of the exercise name and click the 
“Delete” button. To select a different exercise, select the radio button to the left of the 
exercise name and select Activate. 

When the CART Data Capture is running, the “Activate” button is disabled to prevent the 
system database becoming corrupted. 

 

Controlling Access to CART Reports. 

When first installed only the CART server is permitted to run the CART reports, and only 
through the network loopback address ‘127.0.0.1’. The following steps will enable CART 
Clients to access the reports: 

Permitting machines to access the CART Reports. 

1. Determine and make a note of the IP address of the CART client. If you do not know 
the machines IP address each of the following steps should provide the information:  

a. On the Windows Desktop click on the “CART Reports” Icon. 
If the machine has not been added to the CART access list, a security message 
will be shown. The bottom line of the message will show the machines IP address. 

b. From Maui or the CART client select the menu Help->About 
… On the about box click on the “System Info …” button. The IP address of the 
client is shown on the third line of the “System Info” dialog box.  
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c. Start a “Command Prompt” from the Windows Start Menu by 
selecting “Programs->Accessories->Command Prompt”. Type “ipconfig”  into 
the window and press return. The IP address is shown in the resulting output. 

2. On the CART Server start the Mozilla Web Browser. 

3. From the CART Reports main menu select the “Add Workstation to Access List” 
link. 

4. A new page will be shown. In this new window type the IP address noted from step 
1. 

5. Check the “Reports” box.  

6. Click the Enable box. 

7. Reports from the Client will be immediately enabled, and the IP address will be 
added to the table shown on the current form. 

Workstations can also be assigned permissions to change the security settings, and to 
manage exercises by selecting the “Security”, and “Administration” check boxes. In 
general, this is not necessary. The ability to manage exercises is a powerful but also 
potentially very destructive feature and should be limited in its use. 

Removing report access from a workstation. 

1. Using the steps described in Step 1 of the previous 
section determine the IP address of the CART Client. 

2. On the CART Server select “Remove Workstation from 
Access List”. 

3. In the form enter the IP Address of the CART client. 

4. Click on the”Remove access for computer” button. 

Miscellaneous Security features. 

From the Report Generator main menu, the link “Access Permissions by Terminal” shows 
all the terminals that are able to access the CART reports. 

The link “Reset Access Permissions” will ask for confirmation, and if accepted will 
remove access to the CART reports from all machines. After executing this function, no 
machine will be able to access the reports. To enable the cart server to allocate access 
permissions again, start a shell on the CART server and type: 

/mtws/bin/dbcreate/addUser 127.0.0.1 
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Chapter 6 - Diagnosing System Problems 

This paragraph discusses some common system problems, how to diagnose them, and, in 
some cases, how to solve them.  This discussion is not exhaustive. 

Section 1 - Alerts 

Each primary MSC host has an Alert Window interface to display messages (alerts) which 
inform the viewer of a variety of system conditions.  Typically, an alert consists of two 
lines of text: the first line contains the textual information; the second includes the time, 
date, process ID, and hostname on which the alert was generated.  The MSC Alert Window 
displays alerts generated by the MSC host and by the MAN host(s).   

Each alert message is prefaced by INFO, WARN, or ERROR.  Generally, only those 
prefaced by ERROR should be of concern to the system operator. 

Alert Log Files 

All alerts displayed by a given host are saved in an "alert log" file; the full path name of 
this file is /var/tmp/alertlog.  Each time the MSC software is initiated on that host, the 
alertlog file is copied to a file whose full path name is /var/tmp/<timestamp>alertlog.bak 
and a new (initially empty) /var/tmp/alertlog file is created.  At this point on the MSC 
host, /var/tmp/<timestamp>alertlog.bak contains the MAN and MSC alerts from the 
previous exercise and /var/tmp/alertlog contains the MAN and MSC alerts for the current 
exercise.  All files in the /usr/...  directories are local to each host. 

Viewing the Alert Log 

To view the contents of /var/tmp/alertlog, display the MTWS root menu and select Alert 
Log --> Examine Log on the root menu.  See paragraph “Accessing the Root Menu” for 
procedures to access the root menu.  A window will appear displaying the beginning of the 
file. 

Printing the Alert Log 

To print the contents of /usr/tmp/alertlog, select display the MTWS root menu and select 
Alert Log --> Print Log on the root menu 

Notes on Alerts 

During system start-up, several alerts may be displayed, the initial text of which is given 
below; ignore them. 

ERROR: Trace_Support ...  NAME_ERROR ... 
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ERROR: Para_Data_Max_Sizes ...  NAME_ERROR ... 

Each MAN and MSC software component generates an alert which identifies the version 
of the software which is running.  These alerts have the form: 

INFO: ...  RELEASE xxx DD MM YY ... 

where "xxx" is the release ID; "DD MMM YY" are the day, month, and year that this 
version of the software was created.  Since each MAN and MSC software component 
generates this alert, there will be several of these generated on each host. 

Maui and CART Client Alerts 

The Maui software generates its own alerts log, system error log , and system output log 
local to the Maui Display Station on which the application is running.  The alerts.log file 
can be accessed by selecting the Alerts Log… option from the Help menu in the Maui 
Map window. This file as well as the System_Err.log and System_Out.log files can be 
found in the installed drive’s \MauiData\Logs\Maui folder for Maui; and in 
\MauiData\Logs\CART for CART logs.  At each startup of Maui, any existing log files in 
this folder are moved to a backup folder with a folder name determined by the date and 
time at which the log files were originally created. 

Note: These log files should be cleared out periodically, or when no longer needed.  The 
option to remove them is also made when installing the Maui software. 

CART Diagnostic Files 

The CART Software generates the following Alert logs. 

The Raw Data Processor (RDP), which communicates with the MSC and generates the database, 
creates the following files: 

?? /mtws/bin/output. This file contains the contents of messages sent from the MSC to 
CART, along with any diagnostics and error messages generated by the RDP. 

In general this file should contain only the following: 

CART messages descriptions and contents of message data i.e. 
Message recieved with MUI=76 ((null)) 1114 bytes of data.Length of inStr=1115 
inStr=300800UJAN03 
troop,new,-436776326, 1417: 37; 1401: 6; 1402:INITIAL; 1403: 358; 1404: 0; 1405: 0; 1406: 0; 
1407: 0; 
 

A recurring warning message that states “db_interface.c: No object class assigned: 
XXX”. 

The presence of other messages in this file ts is an indication of a possible error or 
malfunction. Note the contents of this file can be edited to re-generate a CART database 
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and can be useful for diagnosing purposes. If reporting a possible CART problem to 
Titan, please keep a copy of the CART output file. 

?? lan_xmit.log, lan_listener.log: contain diagnostics related to setting up, transmitting and 
receiving information to the MSC. 

?? Restart_CART.output, Restart_CART.log: contain information, diagnostics, and errors 
relating to setting up new databases. 

Each of these files is deleted each time the system is started. 

The Report Generator logs errors in the file /var/log/httpd/error_log, and records an entry for 
every web page served in the file /var/log/httpd/access_log. These files are archived every 
week. Archived files are stored for 4 weeks and then deleted. 

Mysql maintains a log file in /var/log/mysqld.log. It is archived every week and the archived 
file is removed after a month. 

CART Alerts 

During normal operation, CART will generate ‘Info’ messages describing connection and 
disconnection processing. These are routed to the MSC and can be seen in the normal MSC 
alerts window if ‘INFO’ messages are being shown. 

 

Section 2 - MTWS Diagnostic Utilities 

Message Queue Monitor 

To invoke the message queue monitor (Qmon) on any MTWS Unix host, open a terminal 
window and enter /mtws/bin/MSC/Qmon.  Qmon periodically examines the message 
queues that pertain to the host on which it is running and updates its display to reflect the 
number of bytes (byte count) in each queue.  Qmon displays a series of color-coded 
vertical scales labeled with the queue capacities (in bytes) and the current byte count for 
each queue.  Each scale is displayed in green, yellow, or red, depending on whether the 
queue's byte count is relatively low, medium, or high, respectively.  This application 
should be used with caution during an actual exercise. 

To terminate Qmon, select Close from its window menu, which is accessed by clicking on 
the button in the upper left corner of the window. 

Disk Utilization Monitor 

A disk utilization monitor program named chkdsk runs automatically on the MSC host 
whenever the MSC software is initiated.  This program periodically monitors the disk 
utilization on MSC; if capacity utilization (the percentage of the disk that is in use) exceeds 
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a threshold value, a red terminal window is displayed which lists the utilization of each 
disk mounted on MSC.  Otherwise, this window remains iconified. 

If disk utilization on the MSC root disk exceeds the threshold value, one of the following 
actions may be appropriate. 

a. Select Clean-up log files from the root menu.  This cleans up old copies of alert logs 
and update logs.  It will not affect any exercise saved on disk.   

b. Remove any extra exercise directories, excluding the current exercise.  This can be 
done either by writing the directory(ies) to tape and then deleting them or by moving 
the directories to another disk.  Simply deleting these directories is not recommended.  
All exercises are in the directory path /mtws/db/man.   

For example, if there are two exercises, E1 and E2, with E1 the current exercise, exercise 
E2 can be written to tape with the command tar cv /mtws/db/man/E2.  E2 can then be 
removed with the command rm -rf /mtws/db/man/E2.   

To restore an exercise directory from a tape written using the tar command described 
above, enter the command tar xv. 

c. Remove any other unneeded files from the disk (e.g., core files). 

d. Back-up older snap-shot files for the current exercise to disk.  For extremely long 
exercises with significant activity, the exercise directory in /mtws/db/man may begin to 
consume the entire disk.  The files with older time stamps may be archived to tape.  
Under no circumstances should anything saved over the last hour be removed from the 
exercise directory or a restart of the exercise will not be possible. 

The red terminal window displayed by chkdsk can be re-iconified.  However, unless some 
action is taken to reduce the percentage utilization of the disk, the window will be 
continually re-displayed each time chkdsk does its periodic check.  If the disk that is 
causing the re-display of the window is irrelevant to the conduct of the exercise, the best 
solution is to move the window so that most of it is off the screen and is therefore not 
obscuring the remaining MSC windows. 

Connection Monitoring 

If MSC is unable to transmit to an MDS station for an extended period of time, MSC will 
put that MDS station off-line.  Click the Users-Online button on the MSC status window.  
A window showing MAN/MDS connections with the MSC is displayed.  All active 
connections are shown in green; inactive connections are shown in red. 

Metrics Screens  

Metrics are collected for the MTWS system which show current quantities and levels of 
activity across the system.  Metrics are collected for all MAN periodics and for each host 
communicating with the MSC.  Database and Cycler metrics are available by clicking on 
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the respective button in the MSC status window.  Host and connection metrics are 
available by selecting clicking on any host button or connection line in the Connections 
Window (see 4.2.3).  Detailed information on the information displayed is available 
through the help interface on each of the metrics screens. 

Section 3 - MAN Software 

General 

On each active MAN host, the following processes should be running: 

a. man_sim -- the simulation program 

b. man_buffer – MAN I/O buffer 

c. lan_listener -- Input message processor.  There will be more than one instance of this 
process. 

d. lan_xmit -- Output message processor 

e. Lan_Control -- network status report generator 

The remainder of this paragraph refers to portions of the MAN process. 

MAN Cyclical Applications  

Many MAN applications are cyclical; they transmit start and finish messages to the MSC 
each time they process a cycle.  The information from these messages is displayed in the 
Cycler Metrics window (see 4.2.4).  Ideally, all cycles will complete in 60 seconds or less.  
If any cycle time consistently exceeds 60 seconds, the task is not running as fast as desired.  
If this happens, any of the following actions may be appropriate: 

a. Ensure Clock Synchronization is enabled as described in paragraph “Manipulating the 
Exercise Clock”. 

b. Reduce the exercise Clock Rate as described in paragraph “Clock Rate”. 

c. Terminate the exercise gracefully as described in paragraph “Suspending an Exercise” 
then restart it at End, as described in paragraph “Restarting an Exercise – End”, 
choosing a different application/host mapping. 

MAN Intelligence (IN) Application 

The IN MAN application maintains several databases which are fixed in size.  
Consequently, ground detection anomalies sometimes occur.  For example, sometimes a 
ground detection does not occur, even though all required criteria are met.  If this happens, 
look for the following alert on MSC: 
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ERROR: Full_Store_Error in Grd_Intel_Tracks ... 

This means that the system has actually made the detection, but is unable to store, report, 
or display it because IN's database is full. 

MAN Process Becomes Inoperative 

If any MAN process dies or becomes inoperative, a system restart is the only solution; 
there is no way to restart only a portion of the MAN software. 

MAN Message Queues 

On each MAN host there are three important message queues:  

a. TCP_XMIT - All message transmissions from a MAN host are buffered in the 
TCP_XMIT queue. 

b. MAN_COM - All messages received by a MAN host are buffered first in the 
MAN_COM queue. 

It is sometimes useful to use Qmon to examine the state of these queues if: 

a. The time between the entry of a command and receipt of the response seems unusually 
long or the responses are not received at all.  (NOTE: This does not apply to solicited 
report requests.) 

b. There is a sudden change in any of the MAN cycle times discussed above. 

c. One or both of the MAN cycle times seem unusually long. 

If the TCP_XMIT queue is relatively full (colored red) and the byte count remains 
constant, then that host is unable to send data to some other MAN host or to MSC.  This 
can cause processing in this host to cease; it is incapacitated (hung) trying to transmit.  The 
source of this problem usually lies in the host to which it is trying to transmit. 

The MAN_COM queue will often be relatively full.  As long as the byte count changes 
over time, there is usually no problem.  If the MAN_COM queue becomes full, then other 
MAN hosts and MSC will be unable to send messages to that host -- their TCP_XMIT 
queues will start to fill. 

If any MAN message queue becomes full and its byte count remains constant for more 
than one minute (approximately -- ideally, no message queue should exhibit this behavior 
for more than ten seconds or so), the most likely final result is that the system will need to 
be restarted. 
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Section 4 - MSC Software 

General 

MSC Host Configured to Receive Spot Reports 

The MSC host is configured to receive all spot reports.  The spot reports process 
(mds_spot) saves all spot reports received by the station in the  file 
/tmp/Spot_Report_Log.  If a hard copy record of these reports is desired, it is often 
convenient to configure the station to NOT print them automatically, but rather to wait 
until the exercise is complete and then print the file  
/tmp/Spot_Report_Log.  The advantage of doing this is that the spot report print-out will 
not be interspersed with extraneous data.   

Processes Running on MSC Hosts 

On each MSC host, the following processes should be running: 

a. msc_dbm -- database manager and solicited report generator 

b. msc_control-- message router 

c. sysop -- primary system operator interface 

d. status_window-- exercise status display 

e. station_control -- station control interface 

f. spot_rpts – spot report processor 

g. sol_rpts -- solicited report processor 

h. alert_window -- alerts display management 

i. lan_listener -- input message processor; there will be more than one instance of this 
process 

j. lan_xmit -- output message processor 

k. lan_control -- network status report generator  

MSC Message Queues 

Each MSC host has three important message queues:  

a. TCP_XMIT - All message transmissions from an MSC host are buffered in the 
TCP_XMIT queue. 
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b. MSC_CTRL - Most messages received by an MSC host are buffered first in  
the MSC_CTRL queue. 

c. MSC_DBM.  - From the MSC_CTRL queue, messages destined for 
MSC_DBM_Control are buffered in the MSC_DBM queue. 

It is sometimes useful to use Qmon to examine the state of these queues if:  

a. The time between the entry of a command or solicited report request  and receipt of the 
response seems unusually long or if the responses are not received at all. 

NOTE 

Solicited reports are generated by MSC, not MAN. 

b. An MDS station is unable to go on-line. 

If the TCP_XMIT queue is relatively full (colored red) and the byte count remains 
constant, then MSC is unable to send data to some MAN or MDS host.  This can cause 
processing in MSC to cease (it is hung trying to transmit).  The source of this problem 
usually lies in the host to which it is trying to transmit. 

 

Section 5 - Maui Software 

Processes running on Maui Hosts 

When Maui is running, it uses the Java Runtime Environment as its parent process to 
spawn the following tasks: 

a. Maui map window  

b. Station Control 

c. Spot Reports 

d. Exercise Status 

e. One task for every window opened in Maui 

To view these tasks, go to an open area in the task bar and click on the right mouse button.  
Then select Task Manager option from the resulting menu.  This will bring up the 
Windows NT Task Manager window. The Applications  tab should display, at a minimum, 
the above mentioned tasks. 

Select the Processes tab to view the Java Runtime Process (javaw.exe) CPU, CPU Time, 
and Memory Usage. 
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Select the Performance tab to view the overall CPU Usage, CPU Usage History. Memory 
Usage and Memory Usage History, and other Maui Display Station system statistics.  This 
is also a quick way to identify how many CPUs are being used by the Maui Display 
Station. Note that MTWS/Maui v2.3 requires the CPU limit to be set at 1 even if the 
system is equipped with more than one processor. 

Maui Troubleshooting 

Below are some solutions to common problems encountered while setting up and running 
Maui.  In most cases, check the Alerts log or System Error log either before or after trying 
the suggested solution(s). 

Problem:  When installing Maui a fatal error window appears with the message, “Failed to 
access kernel”.  

Solution:  Check your TEMP drive space setting.  If it is too small, or non-existent, the 
Maui Installation program will fail due to the lack of temp space required to run it. 

Problem:  When clicking the Online  button in the Station Control window Maui doesn't go 
online. 

Solution:  

- Make sure the Maui host file (c:\WINNT\system32\drivers\etc\hosts) has the 
correct IP address for the msc001. 

- Make sure the Maui resources file (accessed via the Maui Resources Editor, 
available from the MTWS Tools desktop folder) has the Maui 
CLIENT_REMOTE_PORT and SERVER_LOCAL_PORT set to the same mtws 
service number as the one set on the MSC in the /etc/services file. 

- On the MSC, make sure the Maui Station in question has been added to the 
/etc/host file or, if DNS is used, that this station's IP and hostname have been added 
to the name server. 

- Make sure the MDS interface is enabled on the MSC. 

Problem:  When Maui successfully goes online, but no symbols appear. 

Solution:  Look at the Maui alerts log, accessible via the ‘Help’ menu to bring up the 
Alerts window.  Verify that there are no errors display relative to controller lists, 
generating log files, or any other errors spelling out problems with symbol definition.  
The latter could be indicative of a mismatch between Maui versions and MTWS 
(Unix) versions. 

Problem:  In standalone mode, when trying to run the ‘static demo’, no symbols appear. 
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Solution: Verifiy that the standalone folder has a subfolder named Snapshot which 
contains snapshot sample *.sos files and corresponding folders in its subfolder, data. 

Problem: All Maui windows close at once and a Windows NT or Dr. Watson window 
appears with the message that an access violation has occurred. 

Solution: At this point, the problem is fatal for this run of Maui. You will have to restart 
Maui.  Prior to restarting:  

- Make sure that you are running in single processor mode, if you have a multiprocessor 
system.  If so, make sure to reboot your machine in single processor mode. 

Also check your Alerts log and System Error log for possible other causes for this software 
failure. 

You must restart your Maui software.   

Problem:  Maui runs slower than normal. 

Solution: - Make sure that you have a multiprocessor system you are utilizing both 
processors.  Also verify that no extraneous applications such as Microsoft Office products, 
C2PC, or Internet Explorer are running (potentially robbing Maui of processor memory 
and processing time).  For the same reason, it is also not advised to run any Java 
application which launches its own runtime environment. 

Problem:  Maui runs slower and the hard drive makes lots of noise. 

Solution:  Check your TEMP drive space setting.  If it is too small and Maui is running a 
memory intensive session, a high amount of paging (frequent swapping in and out of data 
to the hard drive) will occur.  Try cleaning up your hard drive of excess files both in your 
temp drive and your other application (e.g. Internet Explorer) temp space.  If your TEMP 
drive is on a drive with minimal free space and you have another drive with more free 
space, consider changing the location of your TEMP drive.  This option is made available 
to you at install time.  Consult your Windows NT manual or online help for instructions on 
changing/modifying your TEMP drive space. Also, see section 3.3.3.5. 

 

Problem:  A message appears that says your system is running low on memory. 

Solution:  The minimum memory requirements are 512 MB RAM.  If you get a low on 
memory system message, check to see how many tasks and processes are running on your 
system.  Close any tasks that you do not need while running Maui.  For example, close 
Internet Explorer or other web-browsers, and Microsoft Office tools such as Excel, Word.  
Disable any animated screen savers (the preferred screen saver setting for Maui Display 
Stations is Blank Screen). 

Problem:  Maui will not load, stating it can’t load the color map. 
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Solution:  Check your Color Palette setting in the Settings tab of the Display Properties 
window.  This window can be accessed by clicking the right mouse button in an open area 
of your desktop and selecting the Properties option from the drop down menu.  Then, 
select the Settings tab in the Display Properties window.  Maui requires the display’s 
color palette setting be set to 65536 or True Color in order to display its Raster Graphic 
maps.  

Problem:  Maui doesn't remember window settings. 

Solution: Make sure the read only file attribute is not set for the file 
MTWS\Maui\data\profile.default\profile 

See Appendix B for additional information related to Maui’s C4I interface. 

 

Section 6 - CART Troubleshooting 

Normal operating state. 

Processes: 

When connected to MTWS the following processes, all owned by the MTWS user “soc”, 
should be visible on the CART server:  

??/mtws/bin/Start_CART: Start_CART is the shell script that starts (directly or 
indirectly) all CART server processes. It is invoked by the MSC after the user 
selects the Menu MTWS->CART->Start from the Sysop window. 

??alerts-cart: routes alert messages to the MSC 

??lan_listener (multiple copies) and lan_xmit: These processes handle the 
communications between CART and the MSC. 

??rdp: The raw data processor creates the CART database, translates MTWS messages 
and inserts exercise information into the database. 

When attempting to identify the source of a problem, the command “ps –augxw | grep soc” 
should show all these processes. The absence of one or more of these processes is 
indicative of a problem.  

In addition, CART uses the third party, off-the-shelf software packages MySQL and 
Apache. 

The command “/etc/init.d/mysqld status” should show a list of running processes. If the 
MySQL deamon is not running, CART will be unable to add new data to the database, or 
report on existing exercises. The root user should be able to start the MySQL deamon with 
the command “/etc/init.d/mysqld start”. If this fails, re-installation of mysql should be 
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considered. If the mysqld can be started, it is likely that the boot process is not starting the 
deamon. Add a link from the appropriate run level directory (etc/rc.d/rcX.d)_to the mysqld 
file to fix this.  

The operation of the Apache software can be tested by the command “/etc/init.d/httpd 
status”. Again a list of the running processes should be returned. If Apache is not running, 
the CART Reports will not be available. Again “/etc/init.d/httpd start” should fix the 
problem. Linking this script to the appropriate run level directory should ensure correct 
startup in future. 

Message Queues: 
During normal operation the following queues should be present. 
 
0x000007da            
0x000003e9  
0x000007d1  
0x000003e8  
0x000003ea  
0x000007d8  

The command ‘ipcs –q’ should show each of these queues, repeated operations of the 
command should show that the queues are either empty or rapidly changing in size (that is, 
messages are being placed on the queue and then immediately taken back off). At times of 
heavy processing, and particularly while starting an exercise, a small backlog of messages 
may show. Each queue is allocated 64K of memory and should use the majority of this 
allocation very infrequently. Periods of more than a few seconds with a large and 
unchanging allocation of memory on the queue are indicative of a problem. 

Memory Usage: 

Server memory usage and CPU usage is typically small. Periodic use of “top” as described 
below may be carried out by those interested. 

 

Problems during Startup 

When the MTWS->CART->Start option is selected from the Sysop window, after a brief 
handshake CART needs to decide what to do with the current exercise. 

If the exercise is a new exercise, or an existing exercise is being loaded which is run from 
‘Start’ the existing CART exercise database is archived and a new CART exercise 
database is created. 

If the exercise is an existing exercise and is being run from END, CART will check its 
own end time. If the exercise end time recorded by MTWS is the same as that in the CART 
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exercise database, the new data will be added to the existing CART exercise database. 
Otherwise the existing database is archived and a new CART exercise database is created. 

If the exercise is being run from the middle of an exercise i.e. from a specified time, then 
the existing CART exercise database will be copied to create an archive, and the original 
exercise will be deleted from the specified time through to the end of the exercise database. 
The new data will join with the preexisting exercise to form a coherent whole database. 

In general operation of these procedures should not create problems, but the archive 
process is sensitive to the ownership of files in the /mtws/bin directory and can fail if there 
is insufficient available disk space in the system. If a problem is noted when starting the 
CART server, check the file /mtws/bin/Restart_CART.output. The file’s timestamp should 
be fresh and the contents should be similar to: 

starting cart: Thu Jan 30 16:34:13 PST 2003 
0 0 0210232032 
DBD::mysql::st execute failed: Can't find file: './cart/change_unit_init_flag.fr 
m' (errno: 24) at cart_db.pm line 335. 
DBD::mysql::st execute failed: File '/var/lib/mysql/cart/change_unit_front.MYD'  
not found (Errcode: 24) at cart_db.pm line 335. 
RestartCART.pl 1 <BR> 
startState=0 
startMode=0 
startTime=0210232032 
Database archived successfully 

The “DBD::mysql” messages are normal warnings and do not impede operation. Note that 
joining the end of an exercise does not require an archive operation. 
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Chapter 7 - O/S Utilities 

CPU Utilization 

The Linux operating system includes a CPU utilization monitoring program called "top".  
This utility can be of general use when diagnosing system problems.  Refer to the relevant 
Linux documentation for information on how to use top. 
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                         APPENDIX A: MTWS TERRAIN GENERATION PROCEDURES 

Section 1 - Overview 

The MTWS terrain database is a set of files containing digitized terrain information for 
wargaming simulation. These files contain terrain elevations, trafficability indexes for 
various modes of travel, and vegetation indexes for air and ground coverage. Produced from 
Defense Map Agency (DMA) elevation and features data, the terrain database is used by the 
MTWS Application Network (MAN) simulation software to facilitate movement and 
intelligence processing.  

MTWS geographic data consists of digitized DTED/DFAD (Digital Terrain Elevation 
Data/Digital Feature Analysis Data) terrain data files, and displayable map image files. The 
MAN software uses the digitized terrain data to support movement and intelligence processing. 
The Maui software uses the map image files to support its tactical display.  

Several software utilities support the creation and manipulation of these files. 

(1) TerrGen - generates digitized DTED/DFAD terrain data ('trr') files. These files support 
MAN's movement and intelligence processing. 

(2) Elevator - generates a displayable image file, using a 'trr' file as its input. This enables the 
Maui user to have a visual depiction of the elevation data in the MAN's terrain database. 

(3) smpadrg - converts an Arc Digitized Raster Graphic (ADRG) format map image to a 
Tagged Image File Format (TIFF) map image. 

(4) MapGen - converts a Compressed ADRG (CADRG) format map image to a TIFF-format 
map image. MapGen also supports geo-registration of TIFF maps - i.e., a map image can be 
positioned anywhere on the earth's surface. 

 

Section 2 - TERRGEN Terrain Creation 

TerrGen Overview 

 

An MTWS digitized terrain file contains terrain elevations, trafficability indexes for various 
modes of travel, and vegetation indexes for air and ground coverage. 

It contains terrain elevations, trafficability indexes for various modes of travel, and vegetation 
indexes for air and ground coverage. Produced from Defense Map Agency (DMA) elevation and 
features data, the terrain database is used by the MTWS Application Network (MAN) simulation 
software to facilitate movement and intelligence processing.  
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The MTWS Terrain Database is generated by the TerrGen software package running on a 
Windows PC such as a Maui Workstation.  It is then transferred from the Windows PC to the 
MAN network file system (NFS) using standard File Transfer Protocol (FTP) software running 
on the PC. 

The Terrain file generation is a 2-pass process through the TerrGen program. 

The first pass creates an intermediate file, called the CFE (Combined Features and Elevation) 
file. If not DMA DFAD is not present on the CD or hard-drive a ‘default’ features file is created.  

The second pass through the TerrGen program uses the features file created in the first pass, to 
create the terrain data file (.TRR).Currently MTWS only requires a major feature code consisting 
of basic soil features (codes 901-980). The minor feature code is for future expansion if another 
set of features is also required, such as urban areas. When installed on a Windows PC, e.g.: on 
the D drive, the MTWS Terrain Generator program is installed in a folder called Terrain. 

This folder, D:\Terrain, contains the following: 

Folders in D:\Terrain 

   combined 
   elev 
   features 
   font 
   mtws 

 

Files in D:\Terrain 

   DOS4GW.EXE 
   FEA_XLAT.TBL 
   TERRGEN32.EXE 
   TERRGEN.BAT 
   TERRGEN.EXE 

TerrGen Setup 

The location of the DTED data is hard coded in the script D:\Terrain\TERRGEN.BAT, as 
follows: SET CDROMDSK=d:\DTED\ 

If necessary, correct the specified drive name (hard drive, CDROM drive) where the DTED data 
exists: e.g.: SET CDROMDSK=e: 

 

View the DTED data to make sure you have valid E/W and N/S data for a given area. Note that 
not every degree within a range of degrees is necessarily covered by a given DTED database. For 
example, the DTED dataset, TCD DTED111 36"E 54"N to 66"N 36"E to 72"E, may contain 
56"N 69"E and 56"N 71"E, but not include 56"N 70"E. 
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Find and note the desired degrees (E/W N/S) data cell of interest and verify that it is contained 
on the CD, e.g.: 43"E 64"N would be found at E:\DTED\E043\N63.DT1 

Running TerrGen 

Either from a dos window or explorer window, go to the folder where TerrGen resides, 
e.g.: D:\Terrain and launch TerrGen.bat. 

Introductory information is displayed describing the MTWS Terrain Generator program. 
Read and then ‘PRESS ANY KEY WHEN READY!’ The screen will be split into 2 
columns/panels. The initial menu will appear on the left side and a blank map area on the 
right side. As the mouse pointer is moved over the menu items they will change from green 
to yellow and help information associated with a menu item will appear below. Any time 
the mouse is moved away from the menu area, general help information for the entire 
menu is displayed. SELECT OPERATION is the first menu panel displayed after the 
initial window. 

SELECT OPERATION menu provides you with the following options: 

Select Terrain Data: select MTWS or MCC terrain data file for display or build new 
terrain file from combined files. 

Select Combined File: select combined file (type '.CFE') for display, or build new 
combined file from DMA elevation and features data. 

Exit: Return to DOS, Any operation in progress will be terminated. 

From the SELECT OPERATION menu, click on the Select Operation option. Click 
the Select Combined File option. The SELECT COMBINED FILE menu will appear. 
Click on the Create CFE File option. 

SELECT COMBINED FILE: Select combined file (type '.CFE') for display, or build 
new combined file from DMA elevation and feature data. Provides you with the 
following options:  

 Create CFE File: Create new CFE file for the one degree cell and feature codes 
entered by the user. Lat/Lon degrees must be entered as integer values. File will be 
created on RAM disk, if available; otherwise hard disk will be used. Press ESC to 
abort the command. 

 Check CFE Files: Check CFE files for coverage of area entered by user, with the 
specified features codes.  May require multiple CFE files. 

 Load CFE File: Displays all CFE files in the map areas.  User will select desired file 
by clicking LEFT mouse button on filename. 

 Delete CFE File: Displays all CFE files in the map areas. User will select file to 
delete by clicking LEFT mouse button on filename. 
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 Exit: Select combined file (type '.CFE') for display, or build new combined file from 
DMA elevation and features data. 

Creating the CFE features File 

After selecting the Create CFE File option. The operator will be prompted to enter the 
following items into the keyboard input area at the lower left of display: 

 At lower left corner of the screen, after the "prompt": "Enter longitude of lower left 
corner of one degree cell as nnnE[W] or [-]nnn". Enter the E/W one-degree cell and 
then hit return. e.g. 117W.  

 At lower left corner of the screen, after the "prompt": "Enter latitude of lower left 
corner of one degree cell as nnN[S] or [-]nn". Enter the N/S one-degree cell and then 
hit return. e.g.: 33N.  

 At lower left corner of the screen, after the "prompt": "Enter major features codes in 
'from-to' format. Must be integers between 101-980."       Enter the major feature 
codes to be processed in the DMA features file. Normally this entry will be 901-980 
to process basic soil types. See DMA documentation for all possible feature codes.  

 At lower left corner of the screen, after the "prompt": "Enter minor features codes in 
'from-to' format. Must be integers between 101-980."      Enter in the minor features 
codes to be processed. Normally there are none, so just press Enter.  

 At lower left corner of the screen, after the "prompt": "Enter default feature code. 
Must be integer between 101 and 980. Enter the default feature code. It must be 
given and is normally 901.  

 At lower left corner of the screen, after the "prompt": "Enter default elevation, or 
press Enter to allow TerrGen to determine default elevation." Enter default 
elevation. If not given TerrGen will calculate average elevation for one-degree cell. 
The default or average is used in case elevation is not given for terrain elements. 
Press Enter to accept TerrGen's default.  

 Provides you with the following options: Hard Disk: DMA elevation data on hard 
disk. CDROM: DMA elevation data on CDROM. Exit:     Select the appropriate 
option, e.g.: if it is on a CDROM, select CDROM. It will pause a moment while it 
processes the selection, displaying the following instructional/status message in the 
lower left corner of the screen: "CDROM load input - load elevation CDROM data 
before menu." Make sure CDROM data is in CDROM drive. 

 When ready, use your mouse to select the Exit option. It will pause a moment while 
it processes the selection, displaying the status message in the lower left corner of 
the screen. When complete a fractal image will be displayed on the right panel of the 
screen and the FEATURES SOURCE menu is displayed in the left panel as 
described in the next step. 
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 Provides you with the following options: Hard Disk: DMA features data on hard 
disk. CDROM: DMA features data on CDROM. Exit. Note, selecting either Hard 
Disk or CDROM will generate the error... “No FEAPATH in environment”. You 
must still select either Hard Disk or CDROM to continue.  If not on the CD or hard-
drive a ‘default’ features file (.CFE) is created. The menu panel will then change to 
SELECT TERRAIN FILE menu: No DMA Features found for this location. The 
menu will then change back to Select CFE FILE. 

 When processing is done, a new prompt will appear: At lower left corner of the 
screen, after the prompt, enter CFE filename ('.CFE' appended). Use the format 
e[w]NNNn[s]NN. e.g.: w117n33, which will generate the CFE file, w117n33.cfe. 

 When processing is done, click the Exit option to return to the SELECT 
OPERATION menu. 

Creating the .Trr Terrain File 

From the SELECT OPERATION menu, click on the Select Terrain Data option. The 
SELECT TERRAIN FILE menu will appear. Click on the Create Terrain File option. 

 SELECT TERRAIN FILE: provides you with the following options: 

  Create Terrain File: Create new MTWS terrain file for the one-degree cell and 
feature codes entered by the user. Lat/Lon degrees must be entered as integer values. 
Press ESC to abort the command. 

  Edit Terrain File: Change MTWS terrain database elevation, trafficability, or 
coverage data within a user defined area. 

  Delete Terrain File: (this option is not implemented).  Display all terrain files in the 
map area. Select file to delete by clicking RIGHT mouse button on the filename.  

  Verify Xlate Table: (this option is not implemented). The MTWS terrain data 
translation table will be checked for validity. See environmental variable: 
TRANSLATEFILE for path and filename. 

  Exit: Return to DOS 

After selecting the Create Terrain File option. The operator will be prompted to enter the 
following items into the keyboard input area at the lower left of display: 

 At lower left corner of the screen, after the prompt: Enter longitude of lower left 
corner of one-degree cell as nnnE[W] or [-]nnn". Enter in the E/W one-degree cell 
and then hit return. e.g.:  117W.  

 At lower left corner of the screen, after the prompt: Enter latitude of lower left corner 
of one-degree cell as nnN[S] or [-]nn". Enter in the N/S one-degree cell and then hit 
return. e.g.: 33N.  
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 At lower left corner of the screen, after the prompt: Enter major features codes in 
'from-to' format. Must be integers between 101-980.       Enter the major feature 
codes to be processed in the DMA features file. Normally this entry will be 901-980 
to process basic soil types. See DMA documentation for all possible feature codes. 

 At lower left corner of the screen, after the prompt: Enter minor features codes in 
'from-to' format. Must be integers between 101-980.      Enter in the minor features 
codes to be processed. Normally there are none, so just press Enter.  

 At lower left corner of the screen, after the prompt: Enter default feature code. Must 
be integer between 101 and 980. Enter the default feature code. It must be given and 
is normally 901. 

 At lower left corner of the screen, after the prompt: Enter default elevation, or press 
Enter to allow TerrGen to determine default elevation." Enter default elevation. If 
not given TerrGen will calculate average elevation for one-degree cell. The default 
or average is used in case elevation is not given for terrain elements. Press Enter to 
accept TerrGen's default. It will pause a moment while it processes the selection, 
displaying the status message in the lower left corner of the screen. 

Section 3 - SELECT TERRAIN FILE 

At lower left corner of the screen, after the prompt: Enter MTWS Terrain Data filename 
('.TRR' appended). Use the format e[w]NNNn[s]NN. e.g.: w117n33, which will generate 
the TRR file, w117n33.trr.  

Installing TerrGen TRR files in the MTWS Terrain ‘Database’. 

  FTP the .TRR file(s) generated from TerrGen on the Windows PC to the MSC 
terrain database path, /mtws/db/terrain/high using FTP on the Windows PC. 

  After the terrain file has been transferred to the MTWS terrain database, the 
terrain compression program, hosted on the HP/UX computer, must be run.  

Running Terrain Compression. 

This program performs two functions: First it adjusts the foot, tracked and wheeled 
trafficability factors according to the terrain gradient, that is, the standard deviation of the 
slope around the terrain point; and second, it compresses the high accuracy (normally 3 
seconds) terrain file into a medium accuracy (6 second) and/or low accuracy (9 second) files. 
These compressed files are stored in the "/mtws/db/terrain/medium" and "/mtws/ 
db/terrain/low" directories, respectively. To run the terrain compression program enter the 
command compress_terrain; and follow the prompts provided by the program. A sample run 
is provided:  

$ compress_terrain 

MTWS TERRAIN GRADIENT ANALYSIS 
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Enter 'C' to continue, any other key to stop: c 
Enter Terrain Compression Factor 
Low    (9 second) 
Medium (6 second) 
Both 

: Both 

Enter Lower Left coordinate of area to be analyzed. 
Southern and Western hemispheres will be negative integers. 
Enter Longitude: 118 and Latitude: 33. 
Enter Upper Right coordinate of area to be analyzed. 
Enter Longitude: 117 and Latitude: 34. 
Processing Longitude: 118 and Latitude: 33. 
Trafficability already adjusted for database. 
Start low (9 second) compression. 
File Create Error - Can't write medium/low compressed file Terrain File Write Error. 
Start medium (6 second) compression. 
File Create Error - Can't write medium/low compressed file Terrain File Write Error. 
Processing Longitude: 118 and Latitude: 34. 
Trafficability already adjusted for database. 
Start low (9 second) compression. 
File Create Error - Can't write medium/low compressed file Terrain File Write Error. 
Start medium (6 second) compression. 
File Create Error - Can't write medium/low compressed file Terrain File Write Error. 
Processing Longitude: 117 and Latitude: 33. 
Trafficability already adjusted for database. 
Start low (9 second) compression. 
File Create Error - Can't write medium/low compressed file Terrain File Write Error. 
Start medium (6 second) compression. 
File Create Error - Can't write medium/low compressed file Terrain File Write Error. 
Processing Longitude: 117 and Latitude: 34. 
Trafficability already adjusted for database. 
Start low (9 second) compression. 
File Create Error - Can't write medium/low compressed file Terrain File Write Error. 
Start medium (6 second) compression. 
File Create Error - Can't write medium/low compressed file Terrain File Write Error. 

Cells Processed: Enter 'C' to continue, any other key to stop: #. 

 

Section 4 - TERRGEN Terrain Editor 

 

To edit a terrain data file, start up TERRGEN as described in the previous section. 

From the SELECT OPERATION menu, select  the Select Terrain Data option. 
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Then select the EDIT TERRAIN FILE option. 

EDIT TERRAIN FILE 

Select MTWS Terrain Data file and image type, then define area with mouse and enter 
modifications.  Entire area will be changed to the new value(s). 

Select Terrain File 

MTWS Terrain Data file and their locations,  will be displayed in the map area. 

Select desired file by clicking left mouse button on filename. 
File will be opened and elevation image displayed. 

Then select the Exit option to go back to the EDIT TERRAIN FILE menu. 

Select Image 
Select Terrain Data image for editing. 
The elevation image is the default image displayed when the file is selected. 
The options are: 
- Display Elevation 
- Display Features 
- Display Combined 
- Exit 

 

Select Display Elevation to display the elevation image for the terrain data file selected in 
the previous step. 

Then select the Exit option to go back to the EDIT TERRAIN FILE menu. 

Line Definition 
Defines linear area of a specified width in meters. 
The shape is defined by connecting one or more vectors. 
The options are: 
- Enter Width 
- Start Vectors  
- End Vectors  
- Cancel 

 

Enter Width 
Enter width in meters. Value must be between 50-10000 meters. 
This value must be entered  fore Start Vectors is selected. 
Press ESCAPE to abort input. 
- At lower left corner of the screen, after the "prompt": 
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"Enter width in meters" 
Enter in the width in meters and then hit return. 
e.g.: 1000 

   

Then select Start Vectors location. Continue selecting vector end points by clicking left 
mouse button on locations. 

Select End Vectors when line defintion is complete 

Shape Definition 

Defines a formless area.  The shape is generated by holding the left mouse button down at the 
start point and dragging the mouse around the area to be changed. 

 

Modify Terrain Data 
Enter change value for elev, traffic or cover. 
These value(s) will be entered for all terrain elements in the defined area. 
Enter mass change value for terrain data item(s), then select 'Update Data Base' 
to generate new terrain data, o r'Cancel'. Press ESCPE to abort keyboard entry. 

The options are: 

- Elevation 
Enter elevation in meters. 
Value must be between -5000 - 10000 meters. 

This value will mass change all elevation entries in the enclosed area. 

Enter -20000 to cancel prior entry. 

- Foot Traffic 

Enter foot traficability value as follows: 
-1 - Cancel change 
0 - Water 
1 - Impassable 
2 - Slow 
3 - Fair 
4 - Medium 
5 - Fast 
This value mass changes enclosed area. 

 

- Tracked Traffic 

Enter tracked traficability value as follows: 
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-1 - Cancel change 
0 - Water 
1 - Impassable 
2 - Slow 
3 - Fair 
4 - Medium 
5 - Fast 
This value mass changes enclosed area. 

 

- Wheeled Traffic 

Enter wheeled traficability value as follows: 
-1 - Cancel change 
0 - Water 
1 - Impassable 
2 - Slow 
3 - Fair 
4 - Medium 
5 - Fast 
This value mass changes enclosed area. 

 

- Air Coverage 

Enter air coverage value as follows: 
-1 - Cancel change 
0 - Open 
1 - Light 
2 - Medium 
3 - Dense 
This value mass changes enclosed area. 

- Ground Coverage 

Enter ground coverage value as follows: 
-1 - Cancel change 
0 - Open 
1 - Light 
2 - Medium 
3 - Dense 
This value mass changes enclosed area. 

 

Update Database 

Clicking on this item causes all terrain elements in the enclosed area to be updated with the 
selected mass change value(s) 
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- Cancel 

Cancels all selected mass change values. 
Too late if 'Update Data Base' has alread been selected. 
Returns to prior menu. 

 

Cancel 
Cancel Terrain File edit and return to prior menu. 
Too late if area has already been updated with changes. 

 

Exit 

Return to prior menu. 

Note: For more information, see Appendix A of the v2.3 CSOM, DCN 16. 

Manipulating Terrain 

Several operations are available to the system operator to manipulate the digitized terrain for an 
exercise.  Note that these operations are in addition to the terrain definition portion of the 
exercise definition operation. 

Loading Terrain 

To load one or more terrain areas, perform the following steps: 

Select Exercise Control --> Database --> Terrain --> Load from the System Operations 
window.  The terrain load interface will appear. 

Select Low -, Medium -, or High-Resolution from the terrain load interface. 

Enter at least one pair of coordinates in the template provided in the terrain load interface. 

Click on OK in the System Operations window. 

Wait for a response to appear in the System Operations window indicating that the terrain 
definition has been accepted. 

Removing Terrain 

Terrain areas can also be removed.  When terrain is removed from an area, that area reverts to 
the tabletop values defined in the parametric data for the exercise. 

To remove one or more terrain areas, perform the following steps: 
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Select Exercise Control --> Database --> Terrain --> Remove from the System Operations 
window.  The terrain remove interface will appear. 

Select Low -, Medium -, or High Resolution from the terrain remove interface. 

Enter at least one pair of coordinates in the template provided in the terrain remove interface. 

Click on OK in the System Operations window. 

Wait for a response to appear in the System Operations window indicating that the terrain 
removal has been accepted. 

Loading/Removing Tabletop Terrain 

 

The system operator can assign tabletop characteristics to a specified area. Tabletop means that 
all terrain points within the specified area have the same trafficability, cover, and elevation.   

 

 

 

 

To assign tabletop values to a terrain area or to restore an area's terrain values to those defined in 
the parametric data for the exercise, perform the following steps: 

Select Exercise Control --> Database --> Terrain --> TableTop from the System 
Operations window. 

The tabletop terrain interface will appear. 

Enter the locations and the action (LOAD or REMOVE) to be performed. 

 

 

 

 

 

Enter the elevation to be assigned to all points within the region defined by the specified 
locations. 

NOTE 

Tabletop values defined by this operation can differ from 
those defined in the parametric data for the exercise. 

NOTE 

If the REMOVE option is chosen, proceed to step (f).  As a result of the 
REMOVE, the trafficability, cover, and elevation values for the region 

revert to the tabletop values defined in the parametric data for the 
exercise. 
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For each type of trafficability to be defined, select a trafficability value  from those provided.  
Then click on the button(s) for each type of trafficability (foot, tracked, wheeled) which is to 
have the selected value.   

 

 

 

 

For each type of cover to be defined, select a cover value  from those provided.  Then click 
on the button(s) for each type of cover (air, ground) which is to have the selected value.   

 

 

 

Click on OK in the System Operations window. 

Wait for a response to appear in the System Operations window indicating that the tabletop 
terrain load/remove has been accepted. 

 

Section 5 - Transferring MTWS Terrain Data Base to MTWS Network 

Files are transferred to the MAN (MTWS Application Network) file system using the FTP 
software in the PC. 

The MTWS terrain database generated by TerrGen resides in the directory specified by the 
MTWSPATH environment. Observe the current directory by displaying the file <regional 
directory>.bat, containing the current TerrGen environment. This can be accomplished in 
windows using NotePad and opening <regional directory>.bat. 

In MS-DOS, enter the command type <regional directory>.bat or enter the set command, 
which displays the current environment. It is necessary to know the MTWSPATH 
directory when running FTP. Following is the step by step procedure for transferring a 
MTWS terrain data base to the MTWS Network: 

(1) Click on the Norton DOS icon; Windows will open a DOS window. This is a 
good time to find the MTWSPATH directory by entering the set command, if 

NOTE 

When a button is clicked, the label corresponding to that button 
displays the selected trafficability value. 

NOTE 

When a button is clicked, the label corresponding to that button 
displays the selected cover value. 
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necessary. 

Enter the command n to activate the network. 

(2) Make sure you are in the drive where the database files are located. Enter the 
command ftp <host> where <host> is the name of a HP model 400 computer 
acting as a gateway on the MTWS network. 

 Examples: Computer names at the development site are mapper and hp5.  

Other MTWS network computers can be used if they are listed as hosts in 
\etc\machine.db. 

(3) When the enter user prompt appears, enter a valid user name and the MTWS 
password. 

When accepted, FTP is ready.(Do ftp for EACH file). 

a.  Enter the command binary. It is imperative that this command is entered 
to insure the file transfers correctly.  

If not entered, the high order bit of each byte is dropped, because the data is 
assumed to be text and data transfer will terminate when the first Ctrl Z 
(End of Text, byte value 026) is encountered. 

b.  Enter the command lcd <MTWSPATH directory>. This sets the local 
directory to the directory containing the MTWS terrain data base. 
Example: 

lcd \terrain\mtws\wc_usa 

(4) Enter the command cd /mtws/db/terrain/save to select the MTWS network's 
terrain directory. 

(5) Enter the command put <filename>.trr, where filename is the name entered 
during TerrGen processing.  

Example: put w117n32.trr. The MTWS terrain data files are approximately 6 
Megabytes in size so the transfer may take up to 30 minutes, depending 
upon the network load. 

(6) When transfer is complete, enter the command quit to exit FTP. Then enter the 
command exit to return to Windows. 

Moving files to MTWS terrain data base 
(1) Move the files just entered from /mtws/db/terrain/save to /mtws/ db/terrain/high. 

(In DOS shell). 

  mv <filename> /mtws/db/terrain/high 
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(2) After the terrain file has been transferred to the MTWS terrain data base, the 
terrain compression program, hosted on the HP700 computer, must be run.  

Running Terrain Compression  
This program performs two functions: First it adjusts the foot, tracked and wheeled 
trafficability factors according to the terrain gradient, that is, the standard deviation of the 
slope around the terrain point; and second, it compresses the high accuracy (normally 3 
seconds) terrain file into a medium accuracy (6 second) and/or low accuracy (9 second) 
files.  
 
These compressed files are stored in the "/MTWS/db/terrain/medium" and "/MTWS/ 
db/terrain/low" directories, respectively.  
 
To run the terrain compression program enter the command compress_terrain; further 
operator entry is assisted by the program. 
 

Section 6 - Editing MTWS Terrain Database 

This feature of TerrGen allows the operator to modify regions of an existing MTWS 
terrain data base. Essentially the operator can change any or all MTWS terrain data items 
for data elements within a user defined area.  
 
The operator first defines the area to be changed, either a linear area consisting of vector(s) 
of a specific width, or an amorphous shape drawn by dragging the mouse pointer around 
the area.  
 
After defining the area to change, the operator selects the data item change(s) within the 
area. Specifically, the operator may set all elevations within the area to a constant value, as 
well as the trafficability factors--foot, tracked and wheeled--and the coverage indexes--air 
and ground.  
 
After specifying the change(s), the defined area of the MTWS terrain data base is 
modified.  

When the changes are complete, it is necessary to transfer the modified MTWS terrain data 
base to the MAN NFS using FTP (see section 6..) The modified MTWS terrain data base 
can be restored to its original state by performing the "Create Terrain Data" function again. 
Since the associated CFE file should be available, this operation will only take a few 
minutes.  

NOTE 
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While TerrGen is in the edit mode, the longitude/latitude displays in 
the lower left of the screen whenever the mouse pointer is in the image 
area. Also, the operator can click the left mouse button to display the 

elevation, trafficability and coverage indexes for that location. 

Following is the step by step procedure for editing MTWS terrain data: 

(1)  From the initial menu click on Select Terrain Data. The Select Terrain File 
menu is displayed 

(2)  Click on Edit Terrain File to display the Edit menu. 
(3)  The first required operation is to select the MTWS data base to be modified. 

This is accomplished by clicking on Select Terrain File. The file names 
of all MTWS terrain data bases currently available, along with their 
locations, are displayed in the map area. 

(4)  Move the mouse pointer to the desired filename (the filename will change 
from red to yellow) and click. If the associated CFE file is available the 
elevation image will display; otherwise, an error message is displayed. If 
the associated CFE is not available it must be regenerated by selecting 
Select CFE File from the main menu. 

(5)  After displaying the elevation image, the operator has the option of selecting 
the features or combined image, if they are more appropriate for the type 
of terrain editing. This is accomplished by clicking on Select Image. 

When the desired image is displayed, the operator must decide which shape will best 
define the area to be modified. The operator can choose Line Definition which enables 
defining a linear shape of connecting vectors, at a specific width, or Shape Definition, 
which defines an amorphous (formless) shape. 

a.  If Line Definition is selected, another menu is displayed, showing the selections 
required for defining a linear shape. 

(1) Click on Enter Width to enter the width of the linear shape, in meters. 
(2) Click on Start Vector to begin defining the linear shape. Then move the 

mouse pointer to the location in the image where the linear shape begins.  
(3) Click the left mouse button at the start location and at each successive 

vector end point required to define the linear shape. 

When the final vector end point is selected, the operator has the choice of accepting the 
linear definition by clicking on End Vector, or cancelling the definition by clicking on 
Cancel. If the definition is accepted then the shape is outlined with white vectors. 
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b.  If Shape Definition is selected, the operator is instructed to move the mouse to the 
location where the shape begins, then "drag" (hold left button down while moving 
the mouse) around the shape. After releasing the left button, the shape is enclosed 
and outlined in white.  

The operator may cancel the shape definition by clicking on Cancel. 

After defining the shape, the next step is to specify which terrain data item(s) 
is(are) to be mass changed within the shape.  

(1) Click on Modify Terrain Data; another menu is displayed containing 
each terrain data item. The operator will click on each item to be modified and 
enter the mass change value.  

(2) After all items are chosen, select Update Terrain Data Base to mass 
change the defined area in the MTWS terrain data base or Cancel to 
cancel the operation. 

(3) Exit the edit function and return to the main menu. Accomplish this by 
clicking on the last item of each menu. 

Section 7 - MTWS Terrain Database Generation 

Table 7, “Translation,” specifies trafficability and cover indexes for use by MAN (MTWS 
Application Network) simulation software. The trafficability indexes FT (Foot 
Trafficability), TT (Tracked Trafficability), and WT (Wheeled Trafficability) may range in 
value from 0 - 5, where zero is worst and 5 is best. The cover indexes AC (Air Cover), and 
GC (Ground Cover) may range in value from 0 - 2, where zero is worst cover and 2 is best 
cover.  

NOTE 

The trafficability indexes represent best movement rates over even 
terrain. An adjustment in trafficability according to terrain conditions 

in the direction of movement is necessary. 

The MTWS features to trafficability/coverage indexes translation table is specified by the 
TerrGen environmental variable TRANSLATEFILE. It may be modified using a text 
editor.  

After modification it is recommended that the table be verified by clicking on the "Verify 
Xlate Table" item in the "Create Terrain File" menu before using to create a MTWS terrain 
data base. 
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  FIC TABLE:    MTWS as of January 4, 1994 

Table 7:  Translation (Continued) 

 

  
100:  FT 2, TT 2, WT 2, AC 2, GC 2 
900: FT 3, TT 3, WT 3, AC 2, GC 2 
901-902: FT 5, TT 5, WT 5, AC 0, GC 0 
906: FT 4, TT 4, WT 4, AC 0, GC 0 
907: FT 3, TT 3, WT 2, AC 0, GC 0 
908:  FT 1, TT 2, WT 2, AC 1, GC 0 
909: FT 1, TT 1, WT 1, AC 1, GC 0 
910: FT 3, TT 2, WT 2, AC 0, GC 0 
911: FT 3, TT 2, WT 2, AC 0, GC 0 
912: FT 3, TT 2, WT 2, AC 0, GC 1 
913: FT 4, TT 4, WT 4, AC 0, GC 0 
914: FT 2, TT 1, WT 1, AC 0, GC  0 
915: FT 5, TT 5, WT 5, AC 2, GC 2 
916: FT 5, TT 5, WT 5, AC 0, GC 0 
920: FT 4, TT 4, WT 4, AC 1, GC 1 
921: FT 3, TT 2, WT 2, AC 0, GC 0 
922: FT 2, TT 1, WT 1, AC 0, GC 0 
923: FT 2, TT 1, WT 1, AC 0, GC 1 
924: FT 1, TT 1, WT 1, AC 0, GC 1 
925: FT 4, TT 3, WT 3, AC 0, GC 0 
926: FT 4, TT 4, WT 4, AC 0, GC 0 
927: FT 4, TT 5, WT 4, AC 0, GC 0 
928: FT 5, TT 5, WT 5, AC 2, GC 2 
929: FT 5, TT 4, WT 4, AC 1, GC 1 
930-933: FT 0, TT 0, WT 0, AC 0, GC 0 
934: FT 1, TT 1, WT 1, AC 0, GC 0 
940-943: FT 0, TT 0, WT 0, AC 0, GC 0 
944: FT 0, TT 0, WT 0, AC 1, GC 1 
945: FT 4, TT 4, WT 4, AC 1, GC 1 
946: FT 2, TT 3, WT 3, AC 1, GC 1 
947:  FT 3, TT 1, WT 1, AC 0, GC 0 
948-949: FT 0, TT 0, WT 0, AC 0, GC 0 
950: FT 3, TT 3, WT 3, AC 2, GC 2 
951: FT 3, TT 2, WT 2, AC 1, GC 2 
952: FT 3, TT 2, WT 2, AC 1, GC 1 
953-954: FT 3, TT 2, WT 2, AC 1, GC 1 
955: FT 3, TT 4, WT 4, AC 1, GC 1 
956: FT 3, TT 2, WT 2, AC 1, GC 2 
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960: FT 3, TT 4, WT 4, AC 1, GC 1 
961: FT 2, TT 2, WT 2, AC 1, GC 1 
962: FT 2, TT 2, WT 2, AC 0, GC 0 
963-967: FT 1, TT 1, WT 1, AC 0, GC 0 
980: FT 5, TT 5, WT 5, AC 0, GC 0 
999:       

 

FIC 100, the first entry, is the default entry. If the feature code being processed is not in 
this table then the FIC 100 entry will be used. "FIC TABLE:" is the table identifier and 
must be on the first line; the end table identifier is "999:". Anything following is ignored 
by table processing and may be comments. 
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Appendix B – C4I Interface Notes 

Section 1 - Introduction 

This Appendix describes aspects of the MTWS Command, Control, Communications, 
Computers, Intelligence (C4I) interface which are not directly addressed in Maui’s C4I Help 
screens.  

Section 2 - System Considerations  

The MTWS/C4I interface is implemented through the Maui user station. 

Multiple simultaneous MTWS/C4I connections can be supported. Each Maui host can output 
data to as many as six C4I hosts simultaneously. Each Maui host can receive data from one C4I 
host. The number of C4I connections has no impact upon the simulation (MAN or MSC) 
software. For example, there is no known negative impact upon the performance of the 
simulation. 

All messages sent to and received from C4I systems are logged locally on the Maui host on 
which the message was sent/received. These logs are the \MauiData\C4I\logs directory on the 
disk on which the Maui software is installed. This directory should be inspected periodically.  As 
explained in Maui’s C4I Help, the user can modify the names of the files to which messages are 
logged. Therefore, multiple versions of these log files may accumulate over time. 

Any C4I host should be configured to support inputs from a single Maui only.  Each Maui 
generates message and object identifiers for the messages it outputs. From a C4I system 
perspective, these identifiers should be unique. Since all Maui’s use the same algorithm for 
generating these identifiers, connecting multiple Maui’s to a single C4I system will generate 
conflicting information in the C4I system – a given identifier may (and almost certainly will) 
refer to different objects, depending upon the Maui from which it is received. 

MTWS passes JUNIT/JPOS, CTC, DEL (delete unit/contact), and OPNOTE Over-the-horizon 
Targeting GOLD (OTG) messages to C4I systems. All OTG messages from MTWS to C4I 
systems are generated by the Maui software. Maui generates OTG messages only when directed 
by the station operator, as described in Maui’s C4I Help. 

MTWS passes INTREP, TACREP, TACELINT, SENREP, RECCEXREP, and IIR U.S. 
Message Text Format (USMTF, or MTF) messages to C4I systems. All MTF messages from 
MTWS to C4I systems are generated by the simulation (i.e., the MAN) software, which passes 
them to Maui, which in turn passes them on to the C4I system. The MAN software always 
generates MTF messages, regardless of the presence or absence of an MTWS/C4I connection. 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

B-2 

 

As with OTG messages, Maui passes MTF messages to C4I only when directed by the station 
operator. 

MTWS receives and processes JUNIT/JPOS and DEL (unit) messages from C4I systems. No 
other OTG messages are processed by MTWS. 

MTWS also receives and processes ATO (air tasking order) MTF messages from C4I systems. 
The receiving Maui host passes an ATO message to the simulation, which creates air missions as 
specified in the ATO. The ATO software was written as a prototype to test the concept of 
automatic generation of air missions in MTWS. This software has significant restrictions; for 
example, a limited set of aircraft types is supported. This software has not been maintained. For 
further information on MTWS ATO processing, please contact the MTWS Help line at Titan 
Corporation, Tactical Systems Division (619) 278-2030 or mailto:MTWSHelp@titan.com. 

NOTE: the C4I-IN tab in Maui’s main C4I window has a Message Types button. This button 
brings up the Enable C4I Messages by Type pane, which includes an ATO button. This button 
should be dithered (non-functional) but is not. C4I operators should be advised that the ATO 
capability is not be used. 

To the extent specified above, MTWS conforms to the Operational Specification for Over-the-
horizon Targeting GOLD, Revision C, Change 2, September 1999; and to USMTF User 
Formats, March 2000. 
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APPENDIX C – MAUI SECURITY PROCEDURES 

Section 1 - Overview 

The Maui workstation is used to support exercise scenarios from the UNCLASSIFIED to the 
SECRET level of classification.  Security procedures and requirements for operating Maui 
workstations in a classified environment are described in this Appendix.  All Maui workstations 
should be configured to comply with these requirements for both unclassified and classified 
exercises. 

General Notes 

1) These instructions only apply to Windows NT.  Windows 2000 instructions are similar but 
not the same. 

2) In order for the registry instructions to work properly for administrators,  administrator 
account(s) must be configured to be in a different group or set of groups than user accounts. 

   For example, an administrator's account should only be part of the /MDSXXX\Adminstrators 
group in the following list: 

   BUILT IN\Account Unknown  Special Access 
   CREATOR OWNER             Full Control 
   Everyone                  Special Access 
   MDSXXX\Administrators     Full Control 
   MDSXXX\Power Users        Special Access 
   SYSTEM                    Full Control 

 

Likewise, a user should not be part of the administrators group, but either the group 
Everyone, or a separate group such as USER.  If an administrator is in the same group as a 
user, installing Maui will not work properly. 

 

Section 2 - Security Procedures and Requirements 

Passwords 

Passwords should be a minimum of six characters, contain one or more numeric and one or more 
special characters, one upper case letter, and should not be based on words or names with these 
features (such as Johnny-1).  
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Ensure that accounts do not continue to have passwords that are easy to identify. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Account from the menu 
4) Select "At Least..Characters" in Minimum Password Length section. 
5) Select "6" in character box. 
6) Click "OK" button after you are done. 

There is no GUI or logic in the system that helps to enforce part of this requirement. It is the 
responsibility of the Administrator who is setting the password to follow these rules. 

Password Aging 
Ensure that no user account is exempt from password aging policies. 
 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Account from the menu 
4) Select "Expires in .. Days" in Maximum Password Age section. 
5) Select "180" (suggested value is 6 months or 180 days 
6) Click "OK" button when done. 

 

Account Lockout 

Set the account lockout to a value that allows repeated attempts in cases of typographical errors, 
and yet prevents brute-force attacks. Set the lockout duration to a moderate value, such as 30 
minutes. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Account from the menu 
4) Select "Account lockout"  
5) Select "4" in "Lockout after..bad logon attempts" section  
   (Suggested value is 4 or less). 
6) Select "30" in "Reset count after..minutes" section as 
   (Suggested value is 30 minutes or more) 
7) Click "OK" button after you are done. 

 



The MTWS Documentation Suite – Volume IV 
MTWS System Administration 

C-3 

 

Unique Password Count 
Use the system manager to set the unique-password count to a value equal to or 
greater than the system policy requires to disallow reuse of passwords. 
 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Account from the menu 
4) Select "Remember..Passwords" in Password Uniqueness section. 
5) Select "24" (suggested value) 
6) Click "OK". 
 
Notes: 
For this to be effective, an age value should be specified for Minimum Password Age (Allow  
Immediate change should not be selected). In other words,  
do security procedure 2.2 first before this procedure. 

 

Active Administrator Account 

Disallow 'administrator' account name by renaming the administrator account. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select "rename" on the User menu 
4) Type a new administrator name in "Change To:" text field. 
5) Click "OK". 
 
Note: 
A user name cannot be identical to any other user or group name of the computer being  
administered. It can contain up to 20 uppercase or lowercase characters except for the following:  
"  /  \  [  ]  :  ;  |  =  ,  +  *  ?  <  > ".  A user name cannot consist solely of periods (.) and spaces.   

 

Adding Or Modifying Programs 

 

Prevent users from adding or modifying programs executed on abnormal program termination. 
Prevent users from adding or modifying programs executed on startup. 
Prevent users from adding or modifying programs executed during installation or removal. 
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Steps: 
1) Select Start -> Run. 
2) Type in regedt32 and click the OK button. 
3) In the Registry Editor window, select the HKEY_LOCAL_MACHINE tree if not  
   already selected.  
4) Select the Software\Microsoft\Windows NT\CurrentVersion\AeDebug folder 
   from the  tree HKEY_LOCAL_MACHINE. 
5) Select Security -> Permissions... from the Registry Editor main menu. 
6) Notice the list of users and groups in the Registry Permissions window: 
   BUILT IN\Account Unknown  Special Access 
   CREATOR OWNER             Full Control 
   Everyone                  Special Access 
   MDSXXX\Administrators     Full Control 
   MDSXXX\Power Users        Special Access 
   SYSTEM                    Full Control 
 
7) Leave the Administrators, System, and Power Users alone.  For all the other groups and users  
that have a type of access equal to "Full Control", select   the item and select "Read" in the Type  
of Access combobox. 
8) Leave the Administrators, System and Power Users alone.  For all the other groups and users  
that have a type of access equal to "Special Access", double click on the item.  In the Special  
Access window, unselect the following if they are selected: 
   Set Value 
   Create Subkey 
   Create Link 
   Delete 
   Write DAC 
   Write Owner 
   Click the OK button when done in the Special Access window. 
9) Click the OK button when done in the Registry Permissions window. 
 

Cached Data Objects  
Prevent cached data object hacking. 
Steps: 
1) Select Start -> Run. 
2) Type in regedt32 and click the OK button. 
3) In the Registry Editor window, select the HKEY_LOCAL_MACHINE tree if not  
   already selected.  
4) Select SYSTEM\CurrentControlSet\Control\SessionManager 
   from the tree HKEY_LOCAL_MACHINE. 
   Note: Some workstations have two folders named Session Manager. You should 
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   change both to ensure optimum performance. 
5) Look for the following in the list of values: 
   "Protection Mode: REG_DWORD: 0x1".  If this value already 
   exists, then this is already implemented.  If this value already 
   exists but is not 0x1, double click on the item and go to step 9. 
6) Select Edit -> Add Value... from the Registry Editor main menu. 
7) In the Add Value window, type in "Protection Mode" for the Value 
   Name, and select "REG_DWORD" as the Data Type.   
8) Click the OK button when done in the Add Value window. 
9) Type in "1" and then click the OK button when done in the DWORD  
   Editor window. 

 
Notes: 
The machine must be restarted for this change to take effect. 

 

Preventing Malicious Commands 

Prevent users from adding or modifying programs executed by the system. 
Steps: 
1) Select Start -> Run. 
2) Type in "regedt32" and click the OK button. 
3) In the Registry Editor window, select the HKEY_LOCAL_MACHINE tree if not  
   already selected.  
4) Select the Software\Classes\CLSID\ 
   {000C103E-0000-0000-C000-000000000046}\InProcServer32 
   folder from the tree HKEY_LOCAL_MACHINE. 
5) Select Security -> Permissions... from the Registry Editor main menu. 
6) Highlight the "INTERACTIVE" group. 
7) Select "Read" in the Type of Access combobox. 
8) Click the OK button when done in the Registry Permissions window. 

 

Adding Print Drivers 

Prevent malicious users from adding Trojaned drivers that can divert data or possibly execute 
malicious commands. 

Steps: 
1) Select Start -> Run. 
2) Type in regedt32 and click the OK button. 
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3) In the Registry Editor window, select the HKEY_LOCAL_MACHINE tree if not  
   already selected.  
4) Select SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print  
   Services from the tree HKEY_LOCAL_MACHINE. 
 
5) Look for the following in the list of values: 
   "AddPrinterDrivers: REG_DWORD: 0x1".  If this value already 
   exists, then this is already implemented.  If this value already 
   exists but is not 0x1, double click on the item and go to step 9. 
6) Select Edit -> Add Value... from the Registry Editor main menu. 
7) In the Add Value window, type in "AddPrinterDrivers" for the Value 
   Name, and select "REG_DWORD" as the Data Type.   
8) Click the OK button when done in the Add Value window. 
9) Type in "1" and then click the OK button when done in the DWORD  
   Editor window. 
 
Notes: 
The machine must be restarted for this change to take effect. 

 

Anonymous FTP 

Prevent users from using anonymous FTP to access a machine. 
Steps to determine if an FTP server is currently running on a machine: 
1) Select Start -> Run. 
2) Type in "cmd" and click the OK button. 
3) Type in "ftp <IP address of this machine>"  For example, "ftp 200.200.200.200" 
4) If the response is like the following then an FTP server is not running: 
   > ftp: connect: Connection refused 
5) If the response is asking for a password, type in "anonymous" and then press Enter.  If this is  
allowed, anonymous FTP is being allowed and must be disabled. 

 
Steps to prevent anonymous FTP: 
1) Remove or uninstall the FTP server. 
 
 
Notes:  
1) Even though an FTP server may not currently be running, it may still be installed. 
2) Because there are numerous FTP servers that can be installed on a machine, removing  
or uninstalling an FTP server is application specific. 
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Prevent Hacking Through FTP 

Prevent users from hacking using FTP by preventing users from reading FTP versions. 
Steps to determine if an FTP server is currently running on a machine: 
1) Select Start -> Run. 
2) Type in "cmd" and click the OK button. 
3) Type in "ftp <IP address of this machine>"  For example, "ftp 200.200.200.200" 
4) If the response is like the following then an FTP server is not running: 
   > ftp: connect: Connection refused 
5) If the response is asking for a password, type in "anonymous" and then press Enter.  If this is  
allowed, anonymous FTP is being allowed and must be disabled. 
 
Steps to prevent FTP hacking: 
1) Remove or uninstall the FTP server. 
 
Notes:  
1) Even though an FTP server may not currently be running, it may still be installed. 
2) Because there are numerous FTP servers that can be installed on a machine, removing or  
uninstalling an FTP server is application specific. 
 

Displayed SMTP Version 
Prevent users from hacking using a mail server by removing the version from the SMTP banner. 
Steps 
1) Remove or uninstall the mail server. 
 
Notes:  
Because there are numerous mail servers that can be installed on a machine, removing or  
uninstalling an mail server is application specific. 

 

Preventing NULL or Anonymous Login 
Prevent hackers from using a NULL or anonymous login to obtain useful information on account 
policy. 
 
Ensure that the account policy is set to good security values, such as limiting the number of  
unsuccessful logins and setting minimum password lengths. This may discourage 
hackers that retrieve this information from the system. Note security procedures 2.1 through 2.4. 
 

Restricting Access To Event Logs 
Prevent guests and unauthorized users from reading the System and Application 
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event logs. 
 
Steps to prevent unauthorized access to System event log: 
1) Select Start -> Run. 
2) Type in regedt32 and click the OK button. 
3) In the Registry Editor window, select the HKEY_LOCAL_MACHINE tree if not  
   already selected.  
4) Select SYSTEM\CurrentControlSet\Services\EventLog\System from the tree  
HKEY_LOCAL_MACHINE. 
5) Look for the following in the list of values: 
"RestrictGuestAccess: REG_DWORD: 0x1".  If this value already exists, then this is already  
implemented.  If this value already exists but is not 0x1, double click on the item and go to step 
9. 
6) Select Edit -> Add Value... from the Registry Editor main menu. 
7) In the Add Value window, type in "RestrictGuestAccess" for the Value Name, and select  
"REG_DWORD" as the Data Type.   
8) Click the OK button when done in the Add Value window. 
9) Type in "1" and then click the OK button when done in the DWORD Editor window. 
Notes: The machine must be restarted for this change to take effect. 
Steps to prevent unauthorized access to Application event log: 
1) Select Start -> Run. 
2) Type in regedt32 and click the OK button. 
3) In the Registry Editor window, select the HKEY_LOCAL_MACHINE tree if not  
   already selected.  
4) Select SYSTEM\CurrentControlSet\Services\EventLog\Application 
   from the tree HKEY_LOCAL_MACHINE. 
5) Look for the following in the list of values: 
   "RestrictGuestAccess: REG_DWORD: 0x1".  If this value already 
   exists, then this is already implemented.  If this value already 
   exists but is not 0x1, double click on the item and go to step 9. 
6) Select Edit -> Add Value... from the Registry Editor main menu. 
7) In the Add Value window, type in "RestrictGuestAccess" for the Value 
   Name, and select "REG_DWORD" as the Data Type.   
8) Click the OK button when done in the Add Value window. 
9) Type in "1" and then click the OK button when done in the DWORD  
   Editor window. 
 
Notes: The machine must be restarted for this change to take effect. 
 

Scheduling Priority Privilege 

Remove rights to this privilege from all users and groups except administrators to prevent users 
from altering the normal scheduling of tasks.  
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Steps: 

1) Select Start -> Programs -> Administrator Tools(Common) -> User Manager. 

2) From the User Manager window, under Policies, select User Rights. 

3) At the bottom of the User Rights Policy window, check the checkbox for 

   Show Advanced User Rights. 

4) From the pull down menu located next to "Right:", select 

   "Increase Scheduling Priority". 

5) For all users EXCEPT the administrators, select the user to highlight 

   them and then click the Remove button. 

6) Click the OK button and exit the User Manager. 

 

Closing Open Echo Port 
Prevent malicious users from utilizing an open echo port in a DoS attack. 
Steps: 
1) From Windows explorer, open the following file: 
   C:\WINNT\system32\drivers\etc\Services  using any editor such as Notepad. 
 
2) Place a '#' character in front of the 2 lines that have echo as their service name. 
 

Closing Open Chargen Port 
Prevent malicious users from utilizing a chargen port in a DoS attack. 
Steps: 
1) From Windows explorer, open the following file: C:\WINNT\system32\drivers\etc\Services 
 using any editor such as Notepad. 
2) Place a '#' character in front of the 2 lines that have chargen as their service name. 
 

Auditing Successful Logons 
Enable the auditing of successful logons using the NT system manager. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools -> User Manager. 
3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Success" check box for "Logon and Logoff".  
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Auditing Successful Shutdowns 

Enable the auditing of successful shutdowns using the NT system manager. 

 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Success" check box for "Restart, Shutdown, and System" . 

 

Auditing Successful Security Policy Changes 
Enable the auditing of successful security policy changes using the NT system manager. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Success" check box for "Security Policy Changes".  
 

Auditing Successful User/Group Changes 
Enable the auditing of successful user and group management changes using the NT system 
manager. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Success" check box for "User and Group Management".  

 

Auditing Unsuccessful User/Group Changes 
Enable the auditing of unsuccessful user and group management using the NT system manager. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
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3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Failure" check box for "User and Group Management". 
 

Auditing Unsuccessful File/Object Accesses 
Enable the auditing of unsuccessful file/object accesses using the NT system manager. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Failure" check box for "File and Object Access".  
 

Auditing Unsuccessful Logons 
Enable the auditing of unsuccessful logons using the NT system manager. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Failure" check box for "Logon and Logoff".  

 

Auditing Unsuccessful Process Tracking 
Enable the auditing of unsuccessful process tracking using the NT system manager. 
 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Failure" check box for "Process Tracking".  
 

Auditing Unsuccessful Restarts 
Enable the auditing of unsuccessful shutdowns using the NT system manager. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
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3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Failure" check box for "Restart, Shutdown, and System". 
 

 

Auditing Unsuccessful Security Changes 
Enable the auditing of unsuccessful security policy using the NT system manager. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
 
3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Failure" check box for "Security Policy Changes". 
 

Auditing Unsuccessful Users Rights Usage 
Enable the auditing of unsuccessful user rights use through the NT system manager. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Failure" check box for "Use of User Rights".  
 

Auditing Unsuccessful User and Group Management 
Enable the auditing of unsuccessful user and group management, using the NT system manager. 
Steps: 
1) Login as an administrator. 
2) Select Start -> Programs -> Administrator Tools (Common) -> User Manager. 
3) Select Policies -> Audit from the menu bar in the User Manager window. 
4) Select "Audit These Events" radio button. 
5) Select the "Success" check box for "User and Group Management".  


